Jump to content
scrappy

Custom Css Questions

Recommended Posts

scrappy

I am trying to change the margin from 1.6em to 1.1em of a particular css class.  I have done a lot of custom css to the site (as you can see :)), but for some reason nothing is working for this change.

 

i have tried everything, by adding the following snippets to the custom css tab in pagelines (to name a few):

 

.page-id-174 #highlight section.copy {

margin: 1.1em;

}

 

 

.page-id-174 #highlight .copy {

margin: 1.1em;

}

 

.page-id-174 #section .copy {

margin: 1.1em;

}

 

 

.page-id-174 .copy {

margin: 1.1em;

}

 

I have attached a screen shot of the page and the Google developer tools css output.

 

Any advice would be great.  

 

Thanks!

 

Steve

post-40718-0-65313000-1356209777_thumb.j

post-40718-0-22852600-1356209782_thumb.j

Share this post


Link to post
Share on other sites
osgzach

have you tried removing the  class before the section ID?

 

I haven't found that I've needed to use a prefacing class like that in any of my overrides?

Share this post


Link to post
Share on other sites
scrappy

I am putting this code in the custom css tab in pagelines.. so i have to call upon the section and the css to make the change that over rides the css ... you can see the css that i am trying to change in the css_help.jpg

Share this post


Link to post
Share on other sites
Rob

Other factors are in play here which may not be adjusted given the code provided. For example, you also have:

#highlight .copy-pad .highlight-area {
    padding-top: 8px;
}

You should use Firebug's options to identify the CSS elements to test.  It's not hard to do.


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
scrappy

I put that padding CSS in myself.. that is not a problem.. i am able to change the padding, but i am not able to change the margin.. i did look at it in firebug and it is the same issue as it is in chrome

 

section.copy {

margin: 1.5 em;

}

 

i have done a ton of css changes to the site.. but for some reason there is no way to change the css this css

 

thanks for the help...

Share this post


Link to post
Share on other sites
Rob

Try using

#highlight section-copy {margin:1.1em 0;}

That code is compiled, thus shortened from the full.  It's presuming that since it follows #highlight, it's associated with it. So, customizing, you need to add the prefix to it.


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
scrappy

Rob,

 

Thanks a lot for the advice, but unfortunately it did not work.  It is super odd.  It is the only piece of CSS that I have had trouble editing.

 

Steve

Share this post


Link to post
Share on other sites
Danny

Try this!

 

#site .section-highlight {
margin: 1.1em 0;
}

Please search our forums, before posting!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Similar Content

    • Michael Kummer
      By Michael Kummer+
      Hi guys!
      I have noticed that my primary sidebar becomes intermittently invisible when browsing through various blog articles on michaelkummer.com/blog.
      See:
      https://www.dropbox.com/s/z646sgoa3mfjl1j/Screenshot 2018-07-12 15.57.46.jpg?dl=0 and https://www.dropbox.com/s/vdledzzgginvwgv/Screenshot 2018-07-12 15.57.57.jpg?dl=0
      Upon refresh, the sidebar appears. I have been using the following CSS code to hide the sidebar on mobile without any issues. 
      @media only screen and (max-width: 993px) {
      /* hide sidebars */
           .plsb {
              display: none !important;
          }
      }
      I tried to add the following CSS to force the sidebar to show on screens that are wider than 994 pixels but to no avail. Any clue what could be causing this issue?
    • Michael Kummer
      By Michael Kummer+
      Hi guys!
      I am using the LESS/CSS Pagelines extension and tried to add the following code to make use of FontAwesome:
      a.c2a:before {
          content: "\f07a\00a0";
          font-family: "Font Awesome 5 Pro";
          Font-weight: 900;
          font-style: normal;
          font-weight: normal;
          text-decoration: inherit;
          padding-left: 4px;
      }
       
      The issue is that as soon as I have the CSS via the Custom Styling text box, Pagelines (or the extension) strips out the backslashes (\). As a result, I had to abandon the CSS/LESS extension and instead add all my CSS code to a separate .css file.
      Is there a fix or workaround for this?
      Thanks
      Michael
    • glyph.marketing
      By glyph.marketing+
      Hello, I am having a problem similar to that experienced by Michael Kummer here. We have pages that show this automatic scrolling issue (examples here and here) and it is sufficiently annoying that we have seen customers bounce while trying to convert. Strangely, it only happens at specific resolutions, so it can be difficult to reproduce. In general we can only consistently reproduce it on a 4k resolution with a browser width between 1517 and 1536px. 
      Thanks to Michael Kummer's help we were able to set the overflow-anchor property to none in the entire body, which fixed the issue as far as we can tell, but also obviously disabled scroll anchoring for the whole site. I tried applying it to the specific element that looked like it was being reloaded, which was the PL Meganav extension, but that was unsuccessful. 
      Can anyone help us figure out which element or ID we can apply this property to, so that we can fix the scrolling issue but not disable scroll anchoring for the entire site?
      Thank you - 
      Glyph Language Services
    • chamois_blanc
      By chamois_blanc+
      Hello,
      Shouldn't the image PL5 component be using the srcset/picture css directives to pick the correct size for an image? or it does already and I don't know how to use it? Thank you for any advice or enlightenment.
    • Dan Haddock
      By Dan Haddock
      Plugins Active and installed: 
      Akismet Anti-Spam
      Coming Soon Page & Maintenance Mode by SeedProd
      Contact Form 7
      Cookie Law Info
      DMS Professional Tools  
      Enhanced Media Library  
      Flamingo
      Google Analytics for WordPress by MonsterInsights
      Google XML Sitemap
      Jetpack by WordPress.com
      Legull 
      Loginizer   
      MailChimp for WordPress
      PageLines Updater    
      Schema App Structured Data 
      Sucuri Security - Auditing, Malware Scanner and Hardening
      Uber reCaptcha    
      Yoast SEO
      Wordpress Version: 4.8.1
      Pagelines Version: 2.2.4
       
      Good Evening/Afternoon or Morning, 
      I am running into a problem with CSS styling not applying inside of most browsers (Safari, Firefox) when I am logged in to wordpress, and all browsers that I have tested when I am logged off and the site has been made public (Chrome, Firefox and Safari).
      As a result, I have managed to identify the probable cause. It looks as though these browsers are refusing to render my sites compiled CSS file due to it being a HTTP URL rather than HTTPS.
      I have attempted to change this URL to HTTPS in my browser, however it brings back an ERROR: File not found page - https://www.shortfilmblog.com/wp-content/uploads/pagelines/compiled-css-core-1505847507.css
      What would you suggest in this regard? Would this be resolvable from your end?
      Happy to provide any further details required.
×