Jump to content
linkfr

Modify Css To Add A Stripe At The Top Of Pagelines Lite Theme

Recommended Posts

linkfr

Hi guys,

 

How can i add to PageLines Lite theme the thin stripe appearing at the top of Platform theme?

 

(I think it is indeed a transparent blank allowing the background to be seen - because such stripe is the same color as the footer).

 

Thanks for your so kind help!

 

(i'm not a webmaster as you may imagine).

Share this post


Link to post
Share on other sites
Danny

Hi,

 

Can you provide a link to your site please.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
linkfr

Thanks for your answer, hope you can help me, here you are:

www.conversationenallemand.fr (PageLines Lite)

www.conversationenjaponais.fr (Platform)

Share this post


Link to post
Share on other sites
catrina

You can add a top border to the body by adding this:

body {border-top: 5px solid #000;}

 

Change the border thickness by changing the pixel value.


Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites
linkfr

Great, just did it and it works, thanks a lot, have a fine day!

Share this post


Link to post
Share on other sites
anet

Hi, I want to do that too! But how do I control the color?

 

I tried this:

body {border-top: 5px solid #000;}

and this:

body {border-top: 5px solid color: #c7c7c7;}

 

but they both came out a dark blue/black color...

 

I put that code in my Custom CSS. The line is showing ok, just don't know how to control the color.

 

Thank you!

Edited by anet (see edit history)

Share this post


Link to post
Share on other sites
linkfr

Hi anet, a newbie myself i think for the first time in life i will be able to help someone here! )

 

That's normal. Code for black is #000000, and #c7c7c7 is for a grey.

 

Go to pagelines settings or new post and try to play around with the colors: you will see new codes showing for each tone (always a hashtag followed by 6 numbers).

 

So if you type #ffffff border will be white, if you type #ff0000 it'll be red.

 

Hope i correctly understood your problem.

Share this post


Link to post
Share on other sites
anet

Hi, linkfr,

 

I'm pretty familiar with the hex color codes themselves. So I was playing around with c7c7c7, which I knew was gray, just to see if I could make the bar on the site gray. But I can't get the color to change at all, no matter what hex code I put in.

 

There must be something I'm missing in how to write the code .


Thanks for your help though. Looking for someone with css knowledge. :)

 

anet

Share this post


Link to post
Share on other sites
Danny

Hi Anet,

 

This topics questions has been resolved, therefore can you create a new topic and we will be able to assist you.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
anet

By the way, I figured out what was wrong with my code, in case anyone else reads this thread.

 

What didn't work, that I'd posted above:

body {border-top: 5px solid color: #c7c7c7;}

 

And here what did work:

body {border-top: 5px solid #c7c7c7;}

 

The word 'color' was in the first code; messed it up.

 

TTFN

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Similar Content

    • glyph.marketing
      By glyph.marketing+
      Hello, I am having a problem similar to that experienced by Michael Kummer here. We have pages that show this automatic scrolling issue (examples here and here) and it is sufficiently annoying that we have seen customers bounce while trying to convert. Strangely, it only happens at specific resolutions, so it can be difficult to reproduce. In general we can only consistently reproduce it on a 4k resolution with a browser width between 1517 and 1536px. 
      Thanks to Michael Kummer's help we were able to set the overflow-anchor property to none in the entire body, which fixed the issue as far as we can tell, but also obviously disabled scroll anchoring for the whole site. I tried applying it to the specific element that looked like it was being reloaded, which was the PL Meganav extension, but that was unsuccessful. 
      Can anyone help us figure out which element or ID we can apply this property to, so that we can fix the scrolling issue but not disable scroll anchoring for the entire site?
      Thank you - 
      Glyph Language Services
    • chamois_blanc
      By chamois_blanc+
      Hello,
      Shouldn't the image PL5 component be using the srcset/picture css directives to pick the correct size for an image? or it does already and I don't know how to use it? Thank you for any advice or enlightenment.
    • Dan Haddock
      By Dan Haddock
      Plugins Active and installed: 
      Akismet Anti-Spam
      Coming Soon Page & Maintenance Mode by SeedProd
      Contact Form 7
      Cookie Law Info
      DMS Professional Tools  
      Enhanced Media Library  
      Flamingo
      Google Analytics for WordPress by MonsterInsights
      Google XML Sitemap
      Jetpack by WordPress.com
      Legull 
      Loginizer   
      MailChimp for WordPress
      PageLines Updater    
      Schema App Structured Data 
      Sucuri Security - Auditing, Malware Scanner and Hardening
      Uber reCaptcha    
      Yoast SEO
      Wordpress Version: 4.8.1
      Pagelines Version: 2.2.4
       
      Good Evening/Afternoon or Morning, 
      I am running into a problem with CSS styling not applying inside of most browsers (Safari, Firefox) when I am logged in to wordpress, and all browsers that I have tested when I am logged off and the site has been made public (Chrome, Firefox and Safari).
      As a result, I have managed to identify the probable cause. It looks as though these browsers are refusing to render my sites compiled CSS file due to it being a HTTP URL rather than HTTPS.
      I have attempted to change this URL to HTTPS in my browser, however it brings back an ERROR: File not found page - https://www.shortfilmblog.com/wp-content/uploads/pagelines/compiled-css-core-1505847507.css
      What would you suggest in this regard? Would this be resolvable from your end?
      Happy to provide any further details required.
    • Borries
      By Borries+
      I know this is not an easy problem. Maybe there is a easy solution.
      I have tryed to uses the existing solution, that I have found in the forum
      I changed the colours of my nav (simple nav) and the hover effect (a. hover).
      I really tryed to highlight the active/used link in the nav but I cant figure it out.
      I want it to be black when active.
      Any help would be appreciated. Thanks.
      http://www.marcborries.de  nav link: "Sinn & Selbst" 
    • Michael Kummer
      By Michael Kummer+
      Hi guys,
      every since Chrome introduce scroll anchoring (see chrome://flags) blog posts on my page start scroll automatically as soon as the user scrolls down a bit. It is super annoying and I don't know exactly what triggers the incompatibility with Chrome's latest feature that is supposed to improve usability.
      Since I don't know what causes it (Pagelines, or a Plugin), I would like to disable the feature using a CSS override that Google describes as follow:
      "Scroll anchoring aims to be the default mode of behavior when launched, so that users benefit from it even on legacy content. A CSS property overflow-anchor can disable scroll anchoring in part or all of a webpage (opt out), or exclude portions of the DOM from the anchor node selection algorithm. This property supports the following values when applied to an element E:
      overflow-anchor: auto (the default value) declares that the DOM subtree rooted at E is eligible to participate in the anchor node selection algorithm for any scrolling box created by E or an ancestor of E. overflow-anchor: none declares that the DOM subtree rooted at E is not eligible to participate in the anchor node selection algorithm for any scrolling box created by E or an ancestor of E." Do you guys happen to know how to use that property with the ROOT element so it applies to the whole page?
      Thanks
      Michael 
×