Jump to content
infojerrytattoocom

Jigoshop Products Page Layout Problem

Recommended Posts

infojerrytattoocom

Hello, I've set up my site and starting with Jigoshop, I've the Pagelines Jigoshop plugin installed.

Everything is working well but the products page is messed up and text in buttons are white instead of black:

http://jerrymagni.com/wp/shop

http://jerrymagni.com/wp/product/sketchbook-no-1/

what can I do to have it whit the same layout of the rest of my website?

Please be specific because I'm not a css expert at all.

 

Thanks in advance

Share this post


Link to post
Share on other sites
James B

Hello there,

 

First thing i'd suggest is to deactivate any other third party plugins to see if there is a conflict with jigoshop. If the layout reverts back to how it is meant to be, then go through the plugins one by one to see which one is causing the problem.

 

In order to change the button colors using css you'd need to follow the guidelines laid out here http://www.pagelines.com/wiki/Custom_CSS 

 

I'd advise you download firebug or use google chromes developer tools to find the Id's and Classes as in the tutorial, they'll really help.

 

To find out more on css check out http://www.w3schools.com/


Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites
infojerrytattoocom

Thanks James,

 

I already tried to deactivate plugins, nothing happened.

Share this post


Link to post
Share on other sites
infojerrytattoocom

Additional Info, might help,

if I switch to Transarency theme (that's not what I want) the Products page works as it supposed to be, except the single product page where I still have a duplication of description, iformation, etc. tabs

Share this post


Link to post
Share on other sites
Danny

HI,

 

Can you revert back to PageLines Framework and also do the following:

 

Disable all non-PageLines plugins

Enable PageLines debug, the option is in PageLines > Site Options > Advanced

 

Once you have done the above, can you please reply here informing us please.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
infojerrytattoocom

Hi Danny,

 

I did it, now the website is just a list of links

Share this post


Link to post
Share on other sites
James B

Hi there,

 

I've checked your debug screen and it appears 'Posix functions are disabled on this host', which could be causing a problem. I've spoken to one of our developers for you and they've advised to do the following which might be able to fix this for you.

 

Looking at the source code you're using the base theme. In the base theme's functions.php add the following code in the functions area and save.

 

add_filter( 'render_css_posix_', '__return_true' );

Then clear all the caches and refresh your site to see if there is a difference.

 

 

If that has made no difference ( writing a css file just wont work ) then your need to add the following code to wp-config.php (you'll need to do this via ftp or cpanel in your hosting account) above the line that says /* That's all, stop editing! Happy blogging. */

 

define( 'PL_NO_DYNAMIC_URL', true );

Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites
infojerrytattoocom

Hi James,

 

thank you very much but probably I misunderstood what Danny wrote.

I switched to Base theme, because I thought I had to do that for debugging, but I'm using Ignite theme.

Would these changes be ok also on the Ignite theme?

 

If not, I've just switched back to the Ignite theme, could you please check this out again?

 

Sorry for the inconvenience

Share this post


Link to post
Share on other sites
James B

If you're using a premium theme you can put the 1st line of code in the functions.php of the child theme. If the author of the theme ever issued an update and you updated the code would be overwritten, so keep a note of it somewhere so that you can paste back in if that ever happened.


Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites
infojerrytattoocom

Hi James,

 

I did what you said, nothing changed except that now my menu is completely messed up, :(

 

what now?

Share this post


Link to post
Share on other sites
James B

Hi there, can you reset your permalinks again in settings>permalinks. Make sure pagelines debug is still on in the Site options>advanced tab for us.


Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites
infojerrytattoocom

Hi James,

 

I did it, I set permalinks with default settings and debug is on

Share this post


Link to post
Share on other sites
James B

Excellent, we're checking. Have you disabled jigoshop? Your store page is going to a page of Pagelines boxes.


Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites
infojerrytattoocom

No, I didn't disabled jigoshop, but changing the permalinks probably caused some navigation problem.

Now I set them as before, Date and name, so you should see the store

Share this post


Link to post
Share on other sites
James B

I can see it now, css styling is showing on the page too, which is good. You seem to have some alignment issues on the posts though, has anyone edited any custom css for main layout when developing your site?

 

If you could setup a new user with admin status and pm me the login details we'll login at some point this evening and take a look for you.


Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites
James B

Ok i've logged in and had a look around, looking at the templates and the setup, you seem to have done everything correctly but I couldn't say 100% as my Italian's a little rusty :)

 

I tried to switch the themes over to see if anything changes but the other themes seemed to be hidden. So if you could also switch over to the default to see if now the css is loading whether the shop page displays correctly or not. If it does load correctly then this will be isolated to the theme and you'd need to contact the theme author at http://www.pagelines.com/store/themes/ignite/

 

I think the problem lies within the plugins you have installed, i can see they've all been deactivated in the plugins menu except the the jigoshop plugins. However, all the inactive plugins are still alive and working the admin area. For example the translation plugin is deactivated, but the site is still translating and the mobile menu plugin is inactive but the tab and options are still available in the dashboard. This seems to be the same for the rest of the plugins on the site, so something not working properly there. Is it a multisite?


Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites
infojerrytattoocom

Hi James,

 

yes it's a multisite, that's why. I think  the problem is the theme since if I activate Transparency theme there's no problem.

I prefer to don't switch again the theme because any time I do it, when I switch back, I have to reset widgets and other stuff and, sincerely, after many times it's such a pain in the ass.

 

I'll try to contact the author hoping he will reply soon or I will throw away the f****n jigoshop

 

Anyway thanks for the support.

Share this post


Link to post
Share on other sites
infojerrytattoocom

Another problem.

 

since the codes I put in wp-config.php and in function.php wasn't doing anything good for my website I deleted them and I was sure to have back my menu, well it's not. In the menu I still have links to pages that don't exist, they're not in my menu and I don't know how to delete them.

 

Any Idea to solve this?

Share this post


Link to post
Share on other sites
James B

Hi there, the theme switch has probably knocked out your custom menu. Go to appearance>menus from the wp dash and in the top left hand side you'll see some drop downs for the various navs. Choose the one thats on your site and put select the name of the menu you created from the drop down.

 

If you're using the navbar, go to Pagelines>site options>navbar, you'll see an option in there to select a custom menu for the navbar. Select the name of the menu and save :-)


Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites
infojerrytattoocom

Hi James,

 

thank you, problem solved.

I knew these options but it's good to have someone point you in the right direction when you're overwhelmed by nervousness :D

 

Thanks again.

 

Hope to solve the jigoshop problem soon too.

 

Wish you merry Xmas and happy new year.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×