Jump to content
callmestupidbut

Browser Specific Css Plugin Not Working?

Recommended Posts

callmestupidbut    1
callmestupidbut

Hi there

 

I'm using the Browser Specific CSS plugin to fix a whole range of issues in IE7.

 

The first issue I want to fix is the width. It's a responsive site, but the maximum width doesn't work in IE7 so everything becomes stretched. I want to add a fixed width to the site for IE7 users, so I've added:

 

body.ie7{width:924px}

It works for a split second, then jumps back to full width.

 

I've tried adding !important, but it just does the same.

 

I've tried different CSS like changing text alignment and, again, it changes briefly, but jumps back as if something else is overwriting the CSS.

 

I'm using a child theme and adding the CSS into the style.css, rather than custom code.

 

http://ultragraphics.skitti.sh

 

Thanks in advance

 

Share this post


Link to post
Share on other sites
Rob    547
Rob

I'm unsure how to explain this, but I don't think you can mix responsive and non-responsive elements in the same site, particularly with global things like body width.

 

I'd suggest making the px width a percentage. Of course, that's not fixed, but if that's the problem, at least testing it will determine if I'm wrong or right.


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
callmestupidbut    1
callmestupidbut

Hi Rob - you say "you can mix responsive and non-responsive elements in the same site", but in the site options, you can have a responsive site with a pixel width - that's what I have in all browsers from IE8 upwards.

 

I've tried changing the pixel width to a percentage and it made no difference to how the site appears in IE7.

 

I've tried changing the site to a fixed width layout under site options, but it doesn't fix the width in IE7.

 

I've checked the Google compatibility script checkbox too, but that did nothing.

 

I tried a separate stylesheet with conditional comments for IE7, but that didn't work either.

 

I've run out of ideas now.

 

Share this post


Link to post
Share on other sites
Danny    1,327
Danny

Hi,

 

I do have access to Internet Explorer but can you try this please.

body.ie7 .content {
max-width: 800px;
}

 


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
callmestupidbut    1
callmestupidbut

Hi Danny,

 

Thanks for your reply.

 

Tried it, and it's pretty much the same, it'll set the width to 800px for a split second then jump back out. There's obviously something overriding it later in the code/css.

Share this post


Link to post
Share on other sites
Danny    1,327
Danny

Can you try disabling all non-PageLines plugins and see if this resolves the issue.

 

If this doesn't can you use Jing (free application) and record the issue please.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
callmestupidbut    1
callmestupidbut

HI Danny

 

I only have the browser specific CSS plugin installed. If I switch this off, it obviously looses the 'ie7' class so the style doesn't work at all.

 

I've taken a screencast of what happens with the plugin, but can't upload video files here, so it's on my website as a .avi file http://skitti.sh/wp-content/uploads/2012/12/IE7-screen.avi

 

It starts as IE9 - how the website should look - then changes to compatibility view when it looses its background colour. You should see the width jump from 800 wide to full width

 

I've checked its definitely IE7 and not just the compatibility view version on an old machine I have - the same result.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Similar Content

    • Michael Kummer
      By Michael Kummer+
      Hi guys,
      every since Chrome introduce scroll anchoring (see chrome://flags) blog posts on my page start scroll automatically as soon as the user scrolls down a bit. It is super annoying and I don't know exactly what triggers the incompatibility with Chrome's latest feature that is supposed to improve usability.
      Since I don't know what causes it (Pagelines, or a Plugin), I would like to disable the feature using a CSS override that Google describes as follow:
      "Scroll anchoring aims to be the default mode of behavior when launched, so that users benefit from it even on legacy content. A CSS property overflow-anchor can disable scroll anchoring in part or all of a webpage (opt out), or exclude portions of the DOM from the anchor node selection algorithm. This property supports the following values when applied to an element E:
      overflow-anchor: auto (the default value) declares that the DOM subtree rooted at E is eligible to participate in the anchor node selection algorithm for any scrolling box created by E or an ancestor of E. overflow-anchor: none declares that the DOM subtree rooted at E is not eligible to participate in the anchor node selection algorithm for any scrolling box created by E or an ancestor of E." Do you guys happen to know how to use that property with the ROOT element so it applies to the whole page?
      Thanks
      Michael 
    • wyo22ski
      By wyo22ski+
      Hello,
       
      I'm basically a designer and understand a little on how to change CSS, etc., so please excuse my ignorance...  I recently upgraded to the newest platform from the DMS and my old DMS theme no longer functions.  I'm trying to replace the image slider that my Horizon Photography Theme (Nick Haskins) had created.  The Impulse image slider seemed the closest to what I need, but there are problems.
      It seems the the Impulse section for sliding images defaults to the image width, no the height.  I can change the Impulse stage height and width, but this does nothing to the internal content.  For instance, if I change the height to 200 pixels, the image remains the full width and only shows a cropped section.  I would like the ability to change the Impulse height, and have the image height fit space. 
      I've put this custom CSS in, but again, this only controls the stage height of Impulse:
      .pl-sn-impulse .pl-impulse-cell .cell-wrap, .pl-impulse-container, .owl-stage-outer {
        width: 100%;
      }
       
      Any suggestions welcome.  Thanks 
    • Objectif-Mariage
      By Objectif-Mariage+
      Hello. 
      I have just realized that CSS (Less plugin) , is not working..... I have disable all plugins (except PL CUSTOM LESS and PL5) , and ... it's not working ... 
      It's not the first time. Usually I had trouble with a plugin name Autoptimize , but it's Desactivate now , all memory have been purge, and it's still not working! :-/ So it's not from this plugin. 
      NB : When I am logged on my website, if i go on the black wordpress dashboard bar, go on the PL icon, clic on </> LESS/CSS => then the page suddenly apply the CSS .... But As soon that i reload the page, nothing. I think the problem is that the plugin LESS/CSS does not load properly (if I can say that with my simples words).
      I order to keep the site "good looking" I have temporally copy/paste all my LESS code in a plugin : Script n Styles that apply the LESS/CSS code... but it's not a solution for long time.
      Can someone help me ? Did I do something wrong ? Is it an update ? 
       
      my website : https://www.wedding-photography-minneapolis.com
    • Jason
      By Jason+
      Feel free to delete this post if its not helpful or its just plain wrong.
       
      I though it might be useful to share how I customize the size of the builder. (reduce my eyestrain )
      1 - install stylerbot extension in chrome (stylerbot keeps this css every time you access the url)
       
      2- add this css to stylerbot for the site you are working on
      .CodeMirror {
          font-size: 14px;
          height: 600px;
      }
      .pl-workarea.pl-has-sidebar .pl-workarea-sidebar-container {
          right: 0px;
          width: 500px;
      }
      .pl-workarea.pl-has-sidebar .iframe-container {
          right: 500px ;
      }
       
      change sizes to suit.
       
      Cheers.
    • Jason
      By Jason+
      Hi.
      I can't seem to get the Teamwork section to accept custom css. I am trying to change the padding from 7em to 1em on the splash part
      I have tried
        .pl-sn-teamwork .pl-tw-splash {
          padding-top: 1em;
          padding-bottom: 1em;
        }
       
      This works in chrome inspect but when added to custom css nothing happens.
      I have also tried most of the classes I can see accoiated with this section but again nothng seems to happen.
      Any ideas?
×