Sign in to follow this  
Followers 0

Platformpro, Constantcontact, Features, Boxes, Javascript Problem

4 posts in this topic



I have a ConstantContact form ready to go in a PlatformPro Box on a home page. When I stick in the form code from the ConstantContact form generator tool, it includes a <SCRIPT call that apparently conflicts with the Features code. What I see is Form displaying nicely, then it disappears as soon as an image trasition happens to the second image in the feature slider set AND the feature slider rotation of images stops - just hangs on the last one.


So I replaced the CC code with some HTML shortcode for a CForms form instaed.


Is there no way to have a Feature and a Box with javascript in it on the same page???


Check out but remember I have the Cform short code in now instead of this ConstCon code:

<script type="text/javascript" src="http://www.formstack...ug6ZlO-v3"></script><noscript><a href="http://www.formstack...0946-TeDeug6ZlO" title="Online Form">Online Form - Constant Contact List Signup</a></noscript><div style="text-align:right; font-size:x-small;"><a href="http://www.formstack...fa&fa=h,1350946" title="HTML Form Generator">HTML Form Generator</a></div>





Share this post

Link to post
Share on other sites

Hi Jeo


If its the Js conflicting then no, not unless they changed the code to make it compatible. Have you spoken to ConstantContact to see if they have any other options or can apply an alternate script?

Share this post

Link to post
Share on other sites


No have not contacted them yet. Getting ready for holiday travel, so may take a while to do so.

Thanks for suggestion.



Share this post

Link to post
Share on other sites

WordPress is using updated jQuery, and even if you've not updated, it can cause issues.


On a side note,  PlatformPro is now a legacy product and won't be updated any longer.  As WordPress changes moving forward, there is a high probability that some elements like Features won't work properly and there won't be a fix available.   Thus, I'd strongly recommend you upgrade to PageLines Framework as soon as possible. This will ensure that your site will be kept up to date and functional


We have a holiday sale going on that could be very beneficial.


Have a wonderful holiday and enjoy your travel.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
Followers 0

  • Similar Content

    • Migrating from framework, how to keep content from boxes
      By attac+
      I'm migrating from Framework to DMS now. I have a lot of content made with Framework "Boxes", and wonder what's the best method to keep that content in DMS? 
      I tried to search the forums and support sites, but couldn't find the answer. 
      I'd also take general tips on migrating, the support sites doesn't say much.
    • Link from feature image
      By flaxpits
      Is there a way to use the whole image in the feature slider as a link? I have searched the forum and noticed in 2011 this was posted and the reply was no. Has anything changed in 4 years?
    • boxes and sidebar floating outside global content width
      By liberatedspaces
      My site ( started having a couple of weird problems on my home page all of a sudden, without me doing anything. It's run on the latest version of Pagelines Framework.
      1. My Facebook widget that is set to the secondary sidebar to the right of the page content (the info and Open Table widget) is dropping down into the box section
      2. The box section below the content is no longer conforming to the global content width set to 960px in the Site Option Layout Editor and stretching out to the edge of the browser on both sides.
      Any help would be much appreciated!

    • Features resizes?
      By dfsdafd23
      I'm using features on the landing page of my website. My issue is that when the page loads the feature slider will resize itself every time. I've tried to tinker around with the layout of the site (static, responsive, %, px) and with the source images (not to big, the actual size) but it doesn't help. Any tips? 
      Here's a video of how it looks:
      Website URL:
      Framework Version: 2.4.4 w. child theme
      WordPress Version: 4.2.1
      Plugins in Use: simple css lite, pagelines security patcher, contact form 7, backWPup
    • First two images of Features Slides are not working properly
      By chambermv
      The features images are not displaying properly. The first image is blank and the second displays this script: if (document:)document.getElementbyld("divcb6b4a52").style.height = (441-440)+"px";
      There should only be 8 images to display, but it adds two images before that are blank and have that text I indicated.
      Platform Pro