Jump to content
Sign in to follow this  
karengrovesdesignnet

Extra Space Being Added in Widgets By Default

Recommended Posts

karengrovesdesignnet

Hi - I am getting a non-breaking space in the bottom of my widgets and I don't know how to get rid of it. It's driving me, and my client, crazy. Is this a CSS function or PHP? If PHP, can someone tell me what file and what line to look at as I don't know PHP very well. See My Test Site. Under the wp125 ad widget is an extra space that is being generated automatically somehow. Here's the code I'm getting right after the ending div tag for that widget.

</div> [b]Non breaking space is being added here[/b]
	? </div></div>

Thanks, Karen.

Share this post


Link to post
Share on other sites
Andrew

Hey Karen, There was a username/password issue. I couldn't get it... I'm sure this is an easy fix though. Maybe a screenshot?

Share this post


Link to post
Share on other sites
karengrovesdesignnet

Hi - Sorry about the login issue. Below is a link to an image which highlights where the non-breaking spaces are being added. Thanks, Karen VUNsC.gif

Share this post


Link to post
Share on other sites
bryan-hadaway

Can you post the code for each widget you're using, as in the code/text you're putting in. Thanks, Bryan

Share this post


Link to post
Share on other sites
karengrovesdesignnet

Sorry, I'm having trouble getting the code display to work properly in this post box. It's just generating the images, so I'm uploading a new screenshot.oaBjJ.gif The top widget is a text widget. It has basic HTML in it. The second and third one are using plugin widgets, AdSquares and Contact. Here's the code for the contact widget:

[contact-form 1 "Subscribe Form"]

I'm not getting email updates when you post replies...so sorry for being slow on responding. Karen

Share this post


Link to post
Share on other sites
bryan-hadaway

Okay, that's a problem... you're wrapping code/text in h4 tags, please remove those and any other tags you may be trying to wrap text/code in and instead of using them or the Automatically add paragraphs option, use this to space items: `

` So for example: ` Item/Text 1

Item/Text 2 ` Thanks, Bryan

Share this post


Link to post
Share on other sites
karengrovesdesignnet

Hi Bryan - Did that and seeing no change. Also, this doesn't explain why I have the same problem with the Contact Widget, does it? All of my widgets add the extra space. I'm hoping to get this site back up onto a live server this afternoon. when I get that done, I'll check back here and post a link. Thanks, Karen

Share this post


Link to post
Share on other sites
cmunns

In config_sidebars.php try erasing this ` ` from this line: `'after_widget' => '

Share this post


Link to post
Share on other sites
karengrovesdesignnet

Hooray! Worked like a charm. Thank you Adam! Karen

Share this post


Link to post
Share on other sites
jdownnza

@cmunns That worked like a charm for me too. However, there is a weird looking line on the top left and top right of one of my widgets (very top widget on right side). You can see it in Firefox & Chrome at http://padtip.com Any way to fix this? Thanks!

Share this post


Link to post
Share on other sites
catrina

Hello, Can you please tell me what the line looks like or provide a screenshot if possibl? I can't see it on either Firefox or Chrome.


Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites
jdownnza

Well, on the top right of the "Search" button, there is a rounded corner line, and on the top left of the "In All Catgeories" box, there is the same rounded corner line.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×