Jump to content
Sign in to follow this  
scottimpactyourcompanycom

Posts yielding 404 error - Permalink issue?

Recommended Posts

scottimpactyourcompanycom

I'm having an issue with my blog posts. http://blazemarketinginc.com/blog When a visitor goes to the blog page, he sees them listed out (5 at a time), but when he clicks through a category and wants to read a particular one, a 404 error message comes up. I believe the problem has to do with the permalinks. I'd like the pages of the site to have the page description in the url, which is why I designated the permalink in settings with a custom "/page". That works great for the pages of the site. But this means that each post is designated as "http://blazemarketinginc.com/pages", which yields a 404 error. Is there a way to keep the pages scheme for the pages and a different scheme for the posts that would allow a visitor to read without getting a 404 error? Ideally, I'd like the posts url to have the headline of the post in the URL. Thanks for your help in advance, Scott

Share this post


Link to post
Share on other sites
cmunns

Hey Scott this is an interesting question. I would recommend posting in the WP forum as this is more their expertise. It sounds like you may have to write some advanced htaccess rules?

Share this post


Link to post
Share on other sites
scottimpactyourcompanycom

will do

Share this post


Link to post
Share on other sites
bryan-hadaway

Here's what you want to do: - From your WordPress Admin, navigate to: Settings > Permalinks - Under Common settings, select Custom Structure and paste in: /%postname%/ - Click Save Changes and you??™re done Thanks, Bryan

Share this post


Link to post
Share on other sites
scottimpactyourcompanycom

Bryan, I didn't see your response on this until just now. I will give that a shot once I'm able to access the Wordpress portal. Everything got messed up when I tried to add code to the functions.php page to alter wording on a password protect page. It's all Fubar right now. But once I'm up, I'll definitely try that. Thanks, Scott

Share this post


Link to post
Share on other sites
scottimpactyourcompanycom

Bryan, Works like a charm, thanks!! Now the pages AND the posts have there own text naming. Scott

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×