Jump to content
hansinke

Alt Text Does Not Display In The Image (I Did Customize It In My Site)

Recommended Posts

hansinke    0
hansinke

In class.posts I changed the code to:

 

 

$img = ( $mode == 'top' ) ? get_the_post_thumbnail( null, 'large', trim(strip_tags( $attachment->post_excerpt ))) : get_the_post_thumbnail( null, 'thumbnail',trim(strip_tags( $attachment->post_excerpt )) );
 
For 508 section alt text is needed; maybe you should pick it up when it was filled in (and when null maybe you can use the title field).
 
 

Share this post


Link to post
Share on other sites
beardedavenger    158
beardedavenger

I would never edit core files, it's just going to be reverted when you update. Also, alt tags work by default. Just tested with both images in a post and featured images. 

 

In Post

http://screencast.com/t/0oe1QL9Ycs

 

Featured Thumb

http://screencast.com/t/wL42tap1

 

Nick


Something big is coming for DMS + photographers.

http://fotostheme.com

 

Nick Haskins & CO - New home for all of my PageLines Store products! 

http://nickhaskins.co

 

Better DMS - News, Tutorials, and Tips

http://betterdms.com

 

Share this post


Link to post
Share on other sites
hansinke    0
hansinke

Indeed it works, I do not know why I got the problem... I removed the code as indeed I should need to correct it every version.

 

Resolved!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Similar Content

    • Claudio
      By Claudio+
      I have a problem with the typography settings. I set the H1 class with "font-weight: 300;" (Very thin weight), and "font-size: 50px;" (To have considerable evidence of my problem). Unfortunately, as you can see on the screenshots, those setting don't have any incidence on the site, Infact in the home page editor there is a trial title called "Text test", bold, and 26 px approximatly sized.
      Why the typography settings are not transposed on the site? Where I wrong?


    • wbeddoe
      By wbeddoe
      Greetings,
       
      Looking to be able to change the font of the Standard Title text in the Header/Highlight section.
       
      See screen shot
       
      Also, if I leave Highlight Header text and Highlight Subheader text blank, I get default text "Here's to the crazy ones..." appearing so I have to put a single space in the header and subheader text boxes to make that go away.
       
      Thoughts?
    • ssgro66
      By ssgro66
      Is there a way to have a second fixed section that isn't a sitewide element? I would like to have the site's section titles like "Portfolio" or "About Us" remain at the top of the page while scrolling. I would need this section to have the capability of changing text depending on the section of the site its on.
    • hottheo
      By hottheo
      Ahoy 
       
      I would like to have my flipper page titles on top and centered above my images. 
      Any suggestions?
       
      - the bipedal Chimp clone
    • rcpessemier
      By rcpessemier
      How do I change the font size of a post title (entry-title I think)? I have been trying to do this for hours and can't seem to come across anything that works.
×