Jump to content
Sign in to follow this  
tiptopcare

How To Remove Empty Div Tags *only* In 'page' Content Area?

Recommended Posts

tiptopcare

Greetings,

I have made my original post at http://wordpress.sta...ge-content-area, but am inquiring here for assistance in case anyone here is familiar with the issue. In addition, I have also submitted a support request via http://www.pagelines.com/contact/. A commenter at my StackExchange post suggests I should possibly seek assistance from here and PageLines Premium Support (as I did purchase the Premium framework).

The problem:

Wordpress(?) is inserting empty DIV tags throughout the page, and this is cosmetically affecting my form big-time by resulting in a very vertically-dragged out form with huge spacing in between rows. It looks ugly and awful. I have spent hours last month Googling for solutions and tried many that did nothing. There was one that worked, but unfortunately it broke the image slider I have at http://www.tiptopcare.net/ so I couldn't use that solution.

As per suggestions from my StackExchange post, I have also enabled debug mode with logging and more detail enabled. Unfortunately, the only things showing up are two minor and irrelevant errors about WP Super Cache (irrelevant because during development I had the WP Super Cache plugin entirely disabled, and still had the empty DIV tag problem), and one error being printed on my wp-admin dashboard "Notice: has_cap was called with an argument that is deprecated since version 2.0! Usage of user levels by plugins and themes is deprecated. Use roles and capabilities instead. in /home/username/public_html/wp-includes/functions.php on line 2722".

These are the plugins I presently have enabled:

Contact Form 7

TinyMCE Advanced

WP-DBManager

WP Super Cache

Any assistance and support is much appreciated!

post-43780-0-13085000-1353782833_thumb.p

Share this post


Link to post
Share on other sites
Rob

Deactivate the plugins, one at a time and clear the cache before visiting the site to see if these mystery divs vanish. If they do, then the plugin last deactivated was the culprit and should be replaced.


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
tiptopcare

Deactivate the plugins, one at a time and clear the cache before visiting the site to see if these mystery divs vanish. If they do, then the plugin last deactivated was the culprit and should be replaced.

I've deactivated *all* my plugins (except for the very plugin that does the contact form) and I still have this problem. I have Googled and researched, and it isn't the form plugin that is doing this -- it isn't supposed to.

Share this post


Link to post
Share on other sites
James B

Hi there, it looks like Pagelines is adding an extra margin to the P tag, try the css below to remove it. Paste into Pagelines>Site Options>Custom Code

 

.wpcf7 form.wpcf7-form p {

    margin: 0 0;
    orphans: 4;
}



Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Similar Content

    • stebac
      By stebac+
      Hello!

      Since i recently updated to WordPress 4.9.4 there have been some unusual behaviours with Platform 5 (version 5.1.8).

      I am unable to edit the colour pickers for the backgrounds (the boxes do not show up anymore) and when i activate a plugin from the extend menu it does not show up in my page editor tools.
      Is this a problem for everyone else?
      Thank you in advance for your time.
      Ste.
    • chamois_blanc
      By chamois_blanc+
      Hello,
      Shouldn't the image PL5 component be using the srcset/picture css directives to pick the correct size for an image? or it does already and I don't know how to use it? Thank you for any advice or enlightenment.
    • Dan Haddock
      By Dan Haddock
      Plugins Active and installed: 
      Akismet Anti-Spam
      Coming Soon Page & Maintenance Mode by SeedProd
      Contact Form 7
      Cookie Law Info
      DMS Professional Tools  
      Enhanced Media Library  
      Flamingo
      Google Analytics for WordPress by MonsterInsights
      Google XML Sitemap
      Jetpack by WordPress.com
      Legull 
      Loginizer   
      MailChimp for WordPress
      PageLines Updater    
      Schema App Structured Data 
      Sucuri Security - Auditing, Malware Scanner and Hardening
      Uber reCaptcha    
      Yoast SEO
      Wordpress Version: 4.8.1
      Pagelines Version: 2.2.4
       
      Good Evening/Afternoon or Morning, 
      I am running into a problem with CSS styling not applying inside of most browsers (Safari, Firefox) when I am logged in to wordpress, and all browsers that I have tested when I am logged off and the site has been made public (Chrome, Firefox and Safari).
      As a result, I have managed to identify the probable cause. It looks as though these browsers are refusing to render my sites compiled CSS file due to it being a HTTP URL rather than HTTPS.
      I have attempted to change this URL to HTTPS in my browser, however it brings back an ERROR: File not found page - https://www.shortfilmblog.com/wp-content/uploads/pagelines/compiled-css-core-1505847507.css
      What would you suggest in this regard? Would this be resolvable from your end?
      Happy to provide any further details required.
    • Borries
      By Borries+
      I know this is not an easy problem. Maybe there is a easy solution.
      I have tryed to uses the existing solution, that I have found in the forum
      I changed the colours of my nav (simple nav) and the hover effect (a. hover).
      I really tryed to highlight the active/used link in the nav but I cant figure it out.
      I want it to be black when active.
      Any help would be appreciated. Thanks.
      http://www.marcborries.de  nav link: "Sinn & Selbst" 
    • Michael Kummer
      By Michael Kummer+
      Hi guys,
      every since Chrome introduce scroll anchoring (see chrome://flags) blog posts on my page start scroll automatically as soon as the user scrolls down a bit. It is super annoying and I don't know exactly what triggers the incompatibility with Chrome's latest feature that is supposed to improve usability.
      Since I don't know what causes it (Pagelines, or a Plugin), I would like to disable the feature using a CSS override that Google describes as follow:
      "Scroll anchoring aims to be the default mode of behavior when launched, so that users benefit from it even on legacy content. A CSS property overflow-anchor can disable scroll anchoring in part or all of a webpage (opt out), or exclude portions of the DOM from the anchor node selection algorithm. This property supports the following values when applied to an element E:
      overflow-anchor: auto (the default value) declares that the DOM subtree rooted at E is eligible to participate in the anchor node selection algorithm for any scrolling box created by E or an ancestor of E. overflow-anchor: none declares that the DOM subtree rooted at E is not eligible to participate in the anchor node selection algorithm for any scrolling box created by E or an ancestor of E." Do you guys happen to know how to use that property with the ROOT element so it applies to the whole page?
      Thanks
      Michael 
×