Jump to content
dokether

5Px Gap At Bottom Of Footer

Recommended Posts

dokether    4
dokether

So I'm a fairly experienced developer with php and css, and I'm finding a small problem with the pagelines framework that I can't seem to fix. There appears to be a 5px gap at the bottom of my pagelines sites that I'm unable to find the cause of.

HTML, BODY, div#site, and footer#footer, the only elements I could think of that would cause this, all have their margin/padding set to 0. When I turn the body background off/on, it is showing that it is the BODY element showing through. When I click on it using firebug, firebug highlights the html element. In the image below, the green line is where the browser should be sitting, but for some reason it has that 5px gap below the site.

site_screenshot.png

And this is a more visible example from another site I'm working on. The light beige/green at the bottom shouldn't be there and I'm not sure how to get rid of it:

site_screenshot_2.jpg

Share this post


Link to post
Share on other sites
thejinxters    1
thejinxters

I too am having this problem on my sites. Adjusting margins and padding does not appear to fix it. I've tried adjusting on html, body, site, and footer with no avail. Also, It seems to appear with all web layout handler options and site design mode options.

here is one of the sites I am developing right now with that issue:

http://radicalcoaching.com/

Share this post


Link to post
Share on other sites
Rob    547
Rob

Usually when this happens there's some code error of some kind, such as an extra empty paragraph tag or a missing ; in CSS. It can also be an empty div. Had you removed anything from the footer area like a sidebar?

Unfortunately, I cannot find anything looking at it and so I'm going to escalate this, but while I do, please copy your custom code and paste it into the Direct Input tab here and validate: http://jigsaw.w3.org/css-validator/

This will tell you if there's anything wrong with your custom code.


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
thejinxters    1
thejinxters

I think it is something with the newest version of pagelines. I have a website with no custom code... just a straight install that was running an older version of pagelines and there was no gap. I updated to the latest version and now the gap is there.

http://aslimmehcg.com/newsite/

Share this post


Link to post
Share on other sites
Rob    547
Rob

I will discuss this with our developers.


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
dokether    4
dokether

Yeah, the only thing the validator returned was a couple of filter references for IE — filter:alpha(opacity=50); — which obviously wouldn't cause this. Thanks for looking into this.

Share this post


Link to post
Share on other sites
Rob    547
Rob

As soon as I hear back from our developers, I'll let you know.


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
Simon    247
Simon

Well im no css expert, but 2 mins with firebug lef me to :

#footer { padding-bottom: 10px }[/CODE]

Share this post


Link to post
Share on other sites
dokether    4
dokether

Do you know what line or file that is from? It isn't showing up in my firebug and I just did a search in my style.css and it says that that line can't be found?

Share this post


Link to post
Share on other sites
catrina    103
catrina

You don't need to find it in your CSS file to adjust it. You can simply add it to Site Options > Custom Code > Custom CSS and it should overwrite the existing line.


Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites
dokether    4
dokether

Yes, but my point is that I would like to find out where it is happening so I can correct it at the source instead of needing to include a line resetting this padding in every website I develop.

Share this post


Link to post
Share on other sites
catrina    103
catrina

It isn't advised to correct the file if it's a core file (not a child theme) because that change will be overwritten when you update the theme.


Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites
Rob    547
Rob

Simon seems to have found it, mysteriously in Firebug. It could be in any one of a myriad of places, from a plugin to WP to something totally unexpected. I apologize for the confusion. I'm curious too, as to where it originated.


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
olly54    0
olly54

I have the same problem tried the code simon found but it does not work for me?

Share this post


Link to post
Share on other sites
Rob    547
Rob

Did you paste Simon's code as is?

Because what he found and posted is what causes the problem. The proper solution is:


#footer { padding-bottom: 0; }


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
dokether    4
dokether

You can view that exact line of code at heartbeing.com on line 174 of my style.css (viewable in Firebug). Still got a gap at the bottom unfortunately.

Share this post


Link to post
Share on other sites
Rob    547
Rob

The only thing I can think of would be a plugin that's conflicting with the same code and overriding the code you have.

Despite having it, paste the code into Custom Code > CSS Rules and see if that takes control of the situation.


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
Danny    1,327
Danny

Olly,

Can you provide a link to the site in question please.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
beardedavenger    158
beardedavenger

This is in the reset.less file.

http://screencast.com/t/GEVDsoRVvD

For some reason, the margin:0 being applied to body is actually doing the reverse. To fix;

1. Create a /less directory in your child theme.

2. COPY (not move) reset.less from pagelines/less into your childs /less directory

3. Remove body from the reset. http://screencast.com/t/6sZLTdxs

4. In your style.less, add

body {margin-left:0;margin-right:0;}

Without spending a lot of time I really can't tell you why it's doing that. I haven't seen this pop up on any of the sites I've been doing so that's kinda strange. None the less, hope this helps.


Something big is coming for DMS + photographers.

http://fotostheme.com

 

Nick Haskins & CO - New home for all of my PageLines Store products! 

http://nickhaskins.co

 

Better DMS - News, Tutorials, and Tips

http://betterdms.com

 

Share this post


Link to post
Share on other sites
dokether    4
dokether

Hrm.... I did as you asked, and it doesn't seem to have fixed the site. I added the reset.less into the less folder (see attached image) and edited it as you specified. I also re-saved my pagelines settings in the backend to force a re-build of the less documents... and it is still showing that 5-10px at the bottom (you can see the updated css styles in Firebug). I also looked at it in Safari and Chrome and both of those browsers are showing the same thing. Its like the <body> tag is inheriting it from somewhere that Firebug can't identify because its not showing up anywhere. I've also tried turning off all the plugins as per Rob's earlier suggestion and it was still there.

Also, I just downloaded a fresh copy of Wordpress, a fresh copy of Pagelines 2.3.6 and installed both as clean installs with no modifications at all. That gap is there still...

post-30217-0-01949400-1354052219_thumb.j

Share this post


Link to post
Share on other sites
James B    436
James B

Another case with the same issue has just had a response issue which worked for the user, check out http://www.pagelines.com/forum/topic/23571-random-space-outside-page-area/


Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites
beardedavenger    158
beardedavenger

Weird, works for me on the site I'm currently working on. Did you add margin-left:0 and margin-right:0 to your body in less?


Something big is coming for DMS + photographers.

http://fotostheme.com

 

Nick Haskins & CO - New home for all of my PageLines Store products! 

http://nickhaskins.co

 

Better DMS - News, Tutorials, and Tips

http://betterdms.com

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Similar Content

    • Michael Kummer
      By Michael Kummer+
      Hi guys,
      every since Chrome introduce scroll anchoring (see chrome://flags) blog posts on my page start scroll automatically as soon as the user scrolls down a bit. It is super annoying and I don't know exactly what triggers the incompatibility with Chrome's latest feature that is supposed to improve usability.
      Since I don't know what causes it (Pagelines, or a Plugin), I would like to disable the feature using a CSS override that Google describes as follow:
      "Scroll anchoring aims to be the default mode of behavior when launched, so that users benefit from it even on legacy content. A CSS property overflow-anchor can disable scroll anchoring in part or all of a webpage (opt out), or exclude portions of the DOM from the anchor node selection algorithm. This property supports the following values when applied to an element E:
      overflow-anchor: auto (the default value) declares that the DOM subtree rooted at E is eligible to participate in the anchor node selection algorithm for any scrolling box created by E or an ancestor of E. overflow-anchor: none declares that the DOM subtree rooted at E is not eligible to participate in the anchor node selection algorithm for any scrolling box created by E or an ancestor of E." Do you guys happen to know how to use that property with the ROOT element so it applies to the whole page?
      Thanks
      Michael 
    • wyo22ski
      By wyo22ski+
      Hello,
       
      I'm basically a designer and understand a little on how to change CSS, etc., so please excuse my ignorance...  I recently upgraded to the newest platform from the DMS and my old DMS theme no longer functions.  I'm trying to replace the image slider that my Horizon Photography Theme (Nick Haskins) had created.  The Impulse image slider seemed the closest to what I need, but there are problems.
      It seems the the Impulse section for sliding images defaults to the image width, no the height.  I can change the Impulse stage height and width, but this does nothing to the internal content.  For instance, if I change the height to 200 pixels, the image remains the full width and only shows a cropped section.  I would like the ability to change the Impulse height, and have the image height fit space. 
      I've put this custom CSS in, but again, this only controls the stage height of Impulse:
      .pl-sn-impulse .pl-impulse-cell .cell-wrap, .pl-impulse-container, .owl-stage-outer {
        width: 100%;
      }
       
      Any suggestions welcome.  Thanks 
    • Objectif-Mariage
      By Objectif-Mariage+
      Hello. 
      I have just realized that CSS (Less plugin) , is not working..... I have disable all plugins (except PL CUSTOM LESS and PL5) , and ... it's not working ... 
      It's not the first time. Usually I had trouble with a plugin name Autoptimize , but it's Desactivate now , all memory have been purge, and it's still not working! :-/ So it's not from this plugin. 
      NB : When I am logged on my website, if i go on the black wordpress dashboard bar, go on the PL icon, clic on </> LESS/CSS => then the page suddenly apply the CSS .... But As soon that i reload the page, nothing. I think the problem is that the plugin LESS/CSS does not load properly (if I can say that with my simples words).
      I order to keep the site "good looking" I have temporally copy/paste all my LESS code in a plugin : Script n Styles that apply the LESS/CSS code... but it's not a solution for long time.
      Can someone help me ? Did I do something wrong ? Is it an update ? 
       
      my website : https://www.wedding-photography-minneapolis.com
    • Jason
      By Jason+
      Feel free to delete this post if its not helpful or its just plain wrong.
       
      I though it might be useful to share how I customize the size of the builder. (reduce my eyestrain )
      1 - install stylerbot extension in chrome (stylerbot keeps this css every time you access the url)
       
      2- add this css to stylerbot for the site you are working on
      .CodeMirror {
          font-size: 14px;
          height: 600px;
      }
      .pl-workarea.pl-has-sidebar .pl-workarea-sidebar-container {
          right: 0px;
          width: 500px;
      }
      .pl-workarea.pl-has-sidebar .iframe-container {
          right: 500px ;
      }
       
      change sizes to suit.
       
      Cheers.
    • Jason
      By Jason+
      Hi.
      I can't seem to get the Teamwork section to accept custom css. I am trying to change the padding from 7em to 1em on the splash part
      I have tried
        .pl-sn-teamwork .pl-tw-splash {
          padding-top: 1em;
          padding-bottom: 1em;
        }
       
      This works in chrome inspect but when added to custom css nothing happens.
      I have also tried most of the classes I can see accoiated with this section but again nothng seems to happen.
      Any ideas?
×