Jump to content
helvetik_a

Border-Bottom Does Not Display In Safari+Chrome

Recommended Posts

helvetik_a

Hello.

I would like to know why the dotted border-bottom doesn't show up in safari and chrome. Everything is okey with firefox.

I have all elements in the content-area, without header and footer section.

www.komputagroove.ch

Many thanks

Corina

Css:

/*logo*/

.wp-image-92{

display: block;

margin-left:100px;

margin-right: ;

margin-top:50px;

}

/*dl*/

#container_dl{

position:relative;

border-bottom:2px dotted #CCCCCC;

}

/*pdf*/

#center_download{

width:200px;

margin-left: auto;

margin-right: auto;

margin-top:-100px;

}

#center_download{height:200px;}

#center_download img{

position:absolute;

right:100px;

top:-110px;

display:block;

width: 200px;

opacity:1;

-webkit-transition: opacity 1s ease-in-out;

-moz-transition: opacity 1s ease-in-out;

-o-transition: opacity 1s ease-in-out;

transition: opacity 1s ease-in-out;}

#center_download img:hover {opacity:0;}

/*box generell*/

#boxes{

position:relative;

margin-top:-100px;

}

/*box class*/

.splash_box{

margin-top:-80px;

margin-left:30px;

}

Share this post


Link to post
Share on other sites
catrina

In Safari, the dotted border doesn't work because it requires different syntax as shown here: http://old.macedition.com/cb/resources/safari/bordertest1.html

In Chrome, the dotted border doesn't work because it requires that you use a border image instead (the dotted border doesn't render in Chrome): http://www.css3.info/preview/border-image/

You can add additional CSS for these to your current CSS.


Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites
helvetik_a

Hi Catrina. Thanks for your response.

Unfortunately it does not work even with the other syntax.

I tried this:

#container_dl{

position:relative;

border-bottom:2px dotted #CCCCCC;

border-style: dotted;

}

In firefox everything ok.

Share this post


Link to post
Share on other sites
helvetik_a

I tried also this:

#container_dl{

position:relative;

/*border-bottom:2px dotted #CCCCCC;*/

border-color: #CCCCCC;

border-style: dotted;

border-width: 0px 0px 2px 0px;

}

No way :(

Instead dotted border i tried also with the "solid border". i understand the google chrome problem, but it does not shows up even in safari....

Share this post


Link to post
Share on other sites
helvetik_a

Nothing there's no border at all. Take a look on my site: www.komputagroove.ch

I tried also with a simply solid border, but there's nothing....

thx

Share this post


Link to post
Share on other sites
helvetik_a

Yes Catrina i wrote you, i tried also with a solid border...

Share this post


Link to post
Share on other sites
James B

Hi there, it doesn't look like you're adding the css correctly, you're putting in a shorthand version as a comment, then placing the full css below it, but then you're not adding the full syntax underneath, so certain instructions are missing. If you're adding as shorthand all you need to put is

#container_dl{

/*border-bottom:2px dotted #CCCCCC;*/

}
If you're adding as full css, then you need to specific area in the border you're targeting, example below,
{

border-bottom-style:dotted;

}

If you're looking for browser specific css or further examples check out http://www.w3schools.com/css/css_border.asp


Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Similar Content

    • Michael Kummer
      By Michael Kummer+
      Hi guys!
      I have noticed that my primary sidebar becomes intermittently invisible when browsing through various blog articles on michaelkummer.com/blog.
      See:
      https://www.dropbox.com/s/z646sgoa3mfjl1j/Screenshot 2018-07-12 15.57.46.jpg?dl=0 and https://www.dropbox.com/s/vdledzzgginvwgv/Screenshot 2018-07-12 15.57.57.jpg?dl=0
      Upon refresh, the sidebar appears. I have been using the following CSS code to hide the sidebar on mobile without any issues. 
      @media only screen and (max-width: 993px) {
      /* hide sidebars */
           .plsb {
              display: none !important;
          }
      }
      I tried to add the following CSS to force the sidebar to show on screens that are wider than 994 pixels but to no avail. Any clue what could be causing this issue?
    • Michael Kummer
      By Michael Kummer+
      Hi guys!
      I am using the LESS/CSS Pagelines extension and tried to add the following code to make use of FontAwesome:
      a.c2a:before {
          content: "\f07a\00a0";
          font-family: "Font Awesome 5 Pro";
          Font-weight: 900;
          font-style: normal;
          font-weight: normal;
          text-decoration: inherit;
          padding-left: 4px;
      }
       
      The issue is that as soon as I have the CSS via the Custom Styling text box, Pagelines (or the extension) strips out the backslashes (\). As a result, I had to abandon the CSS/LESS extension and instead add all my CSS code to a separate .css file.
      Is there a fix or workaround for this?
      Thanks
      Michael
    • glyph.marketing
      By glyph.marketing+
      Hello, I am having a problem similar to that experienced by Michael Kummer here. We have pages that show this automatic scrolling issue (examples here and here) and it is sufficiently annoying that we have seen customers bounce while trying to convert. Strangely, it only happens at specific resolutions, so it can be difficult to reproduce. In general we can only consistently reproduce it on a 4k resolution with a browser width between 1517 and 1536px. 
      Thanks to Michael Kummer's help we were able to set the overflow-anchor property to none in the entire body, which fixed the issue as far as we can tell, but also obviously disabled scroll anchoring for the whole site. I tried applying it to the specific element that looked like it was being reloaded, which was the PL Meganav extension, but that was unsuccessful. 
      Can anyone help us figure out which element or ID we can apply this property to, so that we can fix the scrolling issue but not disable scroll anchoring for the entire site?
      Thank you - 
      Glyph Language Services
    • chamois_blanc
      By chamois_blanc+
      Hello,
      Shouldn't the image PL5 component be using the srcset/picture css directives to pick the correct size for an image? or it does already and I don't know how to use it? Thank you for any advice or enlightenment.
    • Dan Haddock
      By Dan Haddock
      Plugins Active and installed: 
      Akismet Anti-Spam
      Coming Soon Page & Maintenance Mode by SeedProd
      Contact Form 7
      Cookie Law Info
      DMS Professional Tools  
      Enhanced Media Library  
      Flamingo
      Google Analytics for WordPress by MonsterInsights
      Google XML Sitemap
      Jetpack by WordPress.com
      Legull 
      Loginizer   
      MailChimp for WordPress
      PageLines Updater    
      Schema App Structured Data 
      Sucuri Security - Auditing, Malware Scanner and Hardening
      Uber reCaptcha    
      Yoast SEO
      Wordpress Version: 4.8.1
      Pagelines Version: 2.2.4
       
      Good Evening/Afternoon or Morning, 
      I am running into a problem with CSS styling not applying inside of most browsers (Safari, Firefox) when I am logged in to wordpress, and all browsers that I have tested when I am logged off and the site has been made public (Chrome, Firefox and Safari).
      As a result, I have managed to identify the probable cause. It looks as though these browsers are refusing to render my sites compiled CSS file due to it being a HTTP URL rather than HTTPS.
      I have attempted to change this URL to HTTPS in my browser, however it brings back an ERROR: File not found page - https://www.shortfilmblog.com/wp-content/uploads/pagelines/compiled-css-core-1505847507.css
      What would you suggest in this regard? Would this be resolvable from your end?
      Happy to provide any further details required.
×