Jump to content
entrysoftware

(Edit) Hyperlink Showing Up When Not Logged In

Recommended Posts

entrysoftware    0
entrysoftware

The front page of my website, www.entry.com has an (edit) hyperlink beside each of the boxes and banners. It does not seem to affect any other part of the website and it is the only page using template 1. At first I thought it was because I was logged in but, when I logged out and I cleared all my cache, cookies, etc.... still had the same issue. Please let me know how to turn this off.

Thanks,

John McDonald

Share this post


Link to post
Share on other sites
James B    436
James B

Hi there, these usually only appear when you're logged in. When i clicked on one of the 'edit' tabs it sends me to your login page. Do you have any caching plugins active? If so please clear them and dump the cache. Then log out and refresh.


Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites
entrysoftware    0
entrysoftware

Hi James, Jenny put me on that track earlier. I was using WP-Cache and I disabled it, then deactivated it, then deleted it, checked the cache files on the server using FTP and made sure they weren't there. It's still in edit mode on the first page. It's like it thinks that someone with rights is logged in - like there is some kind of meta data for this page. I even updated template #5 with the same features, banners, and boxes and assigned the page to that template. To no avail. I went into pgadmin and saw there were three pages with the same name. Change the name of the actual page from the interface and then deleted the other pages that had the same name.

Share this post


Link to post
Share on other sites
entrysoftware    0
entrysoftware

Pretty sure that pagelines is the culprit here. It's using a class called pledit and referencing the post.php function

<!-- Banners | Section Template -->

<section id="banners" class="container no_clone section-banners fix"><div class="texture"><div class="content"><div class="content-pad">

<div class="banner_container fix banners homepage">

<div class="banner-area pprand-pad banner_left with-pad">

<div class="banner-text pprand" style="width:1%;">

<div class="banner-text-pad pprand-pad" style="padding:0px 0px 0px 0px;">

<div class="banner-text-wrap">

<div class="banner-title">

<h2></h2>

</div>

<div class="banner-content">

<p> <a class="pledit" href="http://www.entry.com/wp-admin/post.php?post=4539&amp;action=edit"><span class="pledit-pad">(<em>edit</em>)</span></a> </p>

</div>

</div>

</div>

</div>

<div class="banner-media pprand" style="width:99%;" >

<div class="banner-media-pad pprand-pad">

<img src="http://www.entry.com/wp-content/uploads/2012/10/custbar.gif" alt="" /> </div>

</div>

<div class="clear"></div>

</div>

</div><div class="clear"></div>

</div></div></div></section>

Share this post


Link to post
Share on other sites
Simon    247
Simon

Have you any 'permissions' or 'roles' type of plugins? Because those links only show if the user has permission to view them, typically the post author, or admin.

Share this post


Link to post
Share on other sites
entrysoftware    0
entrysoftware

Here is a list of my plugins. I don't think that any of them apply to a role

adismet

co-authors plus

easy fancybox

google analytics

googlefonts

google sitemap plugin

pagelines sectins

random text

seo ultimate

simple 301 redirects

simple links

wordpress database backup

wp realtime sitemap

Share this post


Link to post
Share on other sites
Simon    247
Simon

Well, first thing to suggest is deactivate them all except pagelins ones. And if the problem still persists then we can look further.

Share this post


Link to post
Share on other sites
entrysoftware    0
entrysoftware

Excellent suggestion. Co-Authors plus is broken and creates the problem.

Thanks for your help.

Share this post


Link to post
Share on other sites
Rob    547
Rob

The topic was marked as resolved.


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Similar Content

    • jeremya
      By jeremya
      URL's are not updating when added to QuickSlider's "Slide LInk URL"? Any assistant would be appreciated. 
    • GOTO11
      By GOTO11
      Hi Nick,
       
      Second try to post this one, one more 'bug' i have found ;-)
       
      Hope to get a reply now soon.
       
      I experience a lot problems with the EVENTS section:
       
      Gravity form does not show up when i fill in the de ID number. The Single Event shortcode is very unclear to me. Nothing i put in seems to make any difference. The date icons do not turn blue as i hover over them like on the demo site The date icons icons won’t sort by month The event agenda doesn't scroll with mouse like in the demo. Shouldn't it be a good idea to have the month also noted in the single-event? www.goto11events.nl
       
      Thanks!
       
      Frank
    • janpeeters
      By janpeeters+
      Over the last month I had extensive communications with the developer of the (premium) Anything Boxes section (in Pagelines store) (Adam Munns) and the developer of the WP Polylang Multilingual plugin (Frederic Demarle).
       
      This was because the following problem occurred:
      Anything Boxes showed all posts of two languages (Dutch and English) on the respective static frontpages for each language. It should of course have filtered posts for Dutch language on the Dutch frontpage and English on the English frontpage.
       
      The solution to this problem was simple in the end. When duplicating a page for use in another language the settings for Anything Boxes were not copied to the new page and I should have set these settings manually again on the new page. I wasn't aware of this, but it makes sense. Because of this the pages didn't know how to differentiate between posts from different languages.
       
      The dev of Polylang told me that Polylang is currently smart enough to synchronize metas like Featured images and page templates but it does not work out of the box with metas created by plugins and themes but (according to Frederic) it is rather easy to add them in the list using the filter 'pll_copy_post_metas'.
      He mentions that he is not sure that these 'PageLines Meta Settings' are stored in post meta but that would make sense according to him. He asks if the Pagelines dev team will be interested to support this feature in the future.
       
      I'm also wondering if you will consider adding Polylang translation support for manually editable strings like the 'Read more…' strings in Pagelines Settings.
       
      Well that's of course up to you but I thought to let you know to be able to take this into consideration. I also post this for other users in case they experience the same kind of trouble and are looking for an answer.
       
      Best regards,
      Jan Peeters
    • bankrollbuilder
      By bankrollbuilder
      I used a custom hook to put a banner ad in my header. It works but its not in the right position. it is centered and above my logo and I would like to float it to the right of my logo in the header. heres the link: http://shaboopie.com/shaboopie-wp/free-logos-pg1/

      thanks.

      Dan B.
    • starlit
      By starlit
      Can one have two hero sections on one page?

      I want a landing page which leads/advertises two subpages.

      Or is there another option?

      Please help.

      THANK YOU
×