Jump to content
lakersalex

Help My Site Is Loading So Slow!

Recommended Posts

Simon    247
Simon

Did you try adding the code from the other post you commented in?

Share this post


Link to post
Share on other sites
lakersalex    4
lakersalex

no what does it do?!

Share this post


Link to post
Share on other sites
Simon    247
Simon

Its tells the framework to use a file instead of a dynamic url for the css, so its written to an actual css file which can be cached by the browser/cdn/isp/moonbase whatever.

Share this post


Link to post
Share on other sites
Simon    247
Simon

Your server might not be compatible, enable debug mode under the advanced tab

Share this post


Link to post
Share on other sites
lakersalex    4
lakersalex

debug enabled.

Share this post


Link to post
Share on other sites
Simon    247
Simon

No reason there why it shouldn't work, where did you add the define line?

Share this post


Link to post
Share on other sites
lakersalex    4
lakersalex

in wp-config.php at the bottom of the file.

Share this post


Link to post
Share on other sites
Simon    247
Simon

ok, right at the bottom? Below the do not edit below this line?

Share this post


Link to post
Share on other sites
lakersalex    4
lakersalex

looking closely now.

Here's the bottom of the wp-config.php file:

/* That's all, stop editing! Happy blogging. */

/** Absolute path to the WordPress directory. */

if ( !defined('ABSPATH') )

define('ABSPATH', dirname(__FILE__) . '/');

/** Sets up WordPress vars and included files. */

require_once(ABSPATH . 'wp-settings.php');

I had originally pasted the code below these lines. now I just pasted the line above the line that reads

/* That's all, stop editing! Happy blogging. */

Share this post


Link to post
Share on other sites
lakersalex    4
lakersalex

thanks, the css file is still nearly 200k. Is that normal?

Share this post


Link to post
Share on other sites
Simon    247
Simon

200k is fine. Its loaded once and stored, thats the idea.

Share this post


Link to post
Share on other sites
lakersalex    4
lakersalex

i see. tests now range between 3 and 6 seconds now. it is faster for sure. anything else I could be doing? I checked the box to Enable CSS minification

Share this post


Link to post
Share on other sites
James B    436
James B

Hi there, take a look at this post, it has some other suggestions on speeding up the load time http://www.pagelines.com/forum/topic/22660-extremely-slow-website-loading-time/


Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Similar Content

    • JawDesigns
      By JawDesigns
      Hi everyone,
      Flywheel have reported errors on my clients site 'www.racewaredirect.co.uk' and it's not loading. Can someone please provide some information on how to fix this? The site has never experienced these issues before.
      Thanks,
      James Wilson
    • JawDesigns
      By JawDesigns
      Hi to all,
       
      Last night I looked at using Flipper to load specific pages with a meta key and value applied. This has all worked well but for some reason the posts (pages) are loading slowly compared to other web elements on my web page.
       
      Could someone please take a look and let me know how I can speed it up? Everything else on the page loads quickly. It just takes a few more seconds to load the posts: http://www.jawdesigns.co.uk/portfolio/
       
      Kind regards,
       
      James Wilson
    • jagipson
      By jagipson+
      I was curious why our video is loading so slow on our site we are working on http://pharmacistrecruitersusa.com/
      When its finally up and running it runs smooth, but until it loads it just a blank white screen. This is just a sample video as well, low quality. Its going to take forever to load when we get a better quality video in place of it.
       
      So why is it taking so much time to load?
      Is there a program or settings you suggest to make the video load quicker?
       
      I used after effects to render out my mp4 and then used a convertor for the webm and ogg
       
       
    • outtareach
      By outtareach
      Installed and updated the plugin and could barely use wordpress.  I did a scan and the speed was a D, I deactivated it and deleted it and now performance is better and backend loads better.  Uninstalled all other plugins til I got to that and it is what was slowing site down.  Just wanted to let you know.
    • _jack
      By _jack+
      Hello all,
       
      Just launched a site and its super slow so trying to clean it up.  One thing I have found is a bit of unnecessary javascript in the footer in an invisible text box.  It is not showing up in the editor and I have looked in every file to see how i can delete this but with no luck.  
      The code is: 
       
      // <![CDATA[   (function() {     var th = document.createElement('script'); th.type = 'text/javascript'; th.defer = true;     th.src = 'https://web-shop.th-apps.com/external/iframe.js';     var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(th, s);   })(); // ]]>   Website: http://www.tallyhocycletours.com   Any ideas?   The site is currently running through CloudFlare hence the rocketscript.   Other suggestions on how to make this run faster would be appreciated!   Thanks,   Jack 
×