Jump to content
Beny Schonfeld

How To Remove "bullets" From Post Tags

Recommended Posts

Beny Schonfeld    1
Beny Schonfeld

Hello again,

1. The post tags display with "bullets" or discs in the single post layout. How do I remove these????

Here's a pic of what it looks like now, I'd like to remove the little bullets in between tags.

https://www.evernote...15133f28d8158ff

2. I'd also like to know what CSS instruction I need to use in order for the "line break" to NOT happen in the middle of a word (FIREFOX). See pic: https://www.evernote.com/shard/s21/sh/3e4302d1-a4b1-49da-a1b8-ac93c1f910a2/5fcd002246ba292a6b24ed753a319456

Thanks


Beny Schonfeld

Appeando.com

On Twitter: @appeando

On Facebook: http://facebook.com/appeando

Share this post


Link to post
Share on other sites
Rob    547
Rob

Beny,

If you can, provide a link to where the bullets are, please.

To be candid, I suspect the answer to question 2 is the same as for question 1. When the bullets are removed, the margins/padding around the bullets will also vanish, making more room on the line of menu items, causing the wrap to disappear.


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
Beny Schonfeld    1
Beny Schonfeld

Beny,

If you can, provide a link to where the bullets are, please.

Here's a link to a blog post. At the bottom you can see the tags as shown in the screen pics above... http://www.designsbyfelicia.com/dummy-cat-5/dummy-post-number-10-is-the-last-one-of-the-dummies/


Beny Schonfeld

Appeando.com

On Twitter: @appeando

On Facebook: http://facebook.com/appeando

Share this post


Link to post
Share on other sites
catrina    103
catrina

Those bullets are implemented in the code used to generate the tags (as shown here: http://codex.wordpress.org/Function_Reference/the_tags#Separated_by_a_Bullet). Do you want to replace these bullets with something else or just remove them?


Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites
catrina    103
catrina

The bullets are set in a core file (class.posts.php in the includes folder in your theme directory). It's not recommended that you edit core files since the change will be overwritten when you update Framework, but if you can remember to make the change again after updating, you should be fine. You just need to remove this term (just find it and delete it but do not remove the apostrophes and spaces that are around it): •


Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites
Beny Schonfeld    1
Beny Schonfeld

OK, that worked perfectly. Thanks!

What about the second issue: what CSS instruction do I use to make sure that if a tag is long, it doesn't break the tag mid-word. I would rather it shoot the whole tag link to a new line.

Look at this screen pic to see what I mean... https://www.evernote.com/shard/s21/sh/9fd124f7-45ea-4bd0-b665-ad2db5397cc1/1c4b18122cc24d69153ed76957d0899b


Beny Schonfeld

Appeando.com

On Twitter: @appeando

On Facebook: http://facebook.com/appeando

Share this post


Link to post
Share on other sites
catrina    103
catrina

You can try using display: block; for the link tags but the problem is, that will probably create a vertical list of your tags. I don't think this is something that can prevented.


Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites
Beny Schonfeld    1
Beny Schonfeld

Yeah, display: block doesn't do it... The strange thing is if you look at this link (http://www.designsbyfelicia.com/dummy-cat-5/dummy-post-number-10-is-the-last-one-of-the-dummies/ ) in Chrome you'll see that it breaks the tag mid-word.

But if you open that link in Firefox it displays that last tag in a new line... Which is how I would like it to display in every browser. Any thoughts?


Beny Schonfeld

Appeando.com

On Twitter: @appeando

On Facebook: http://facebook.com/appeando

Share this post


Link to post
Share on other sites
catrina    103
catrina

Strangely, when I view the tags in Firefox (on Mac), the last tag is broken mid-word. I think it's going to vary from different browsers, but not sure why this happens.


Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Similar Content

    • John Olsson
      By John Olsson+
      Hello, how do I show tags in WP-content-section... or what am I missing out? 
    • Dana
      By Dana+
      Hi DMS team,
      Please help out on how to add Post tags to the bottom of each post. Tried looking at the hooks tutorials but not sure what to do here.
      Thanks a lot.
       
       
       
       
    • JudithKlinger
      By JudithKlinger+
      I'm having a problem with post formatting that I never encountered before PL5. 
      I keep losing my paragraph formatting. I've gone in manually 4 and 5 times...adding in the <p></p> tags, updating...then I go to the visual editor or the pagebuilder and when I go back..they're gone and so is the 
      formatting. In digging around I think it has to do with the wpautop filter. See this: https://codex.wordpress.org/Function_Reference/wpautop
       
      I'm in the process of converting pages from DMS to PL5 and something in PL5 seems to be interacting with the formatting. I'm also getting other strange formatting issues (random <i></i> with no text n between, etc.)
      Frankly, I don't care if I need to manually add <p> or not... I just need the formatting to stick. 
      Thanks. J
       
    • dawsonbarber
      By dawsonbarber+
      Currently, the main heading for an element is automatically wrapped with a <h1> tag.
      That's okay if the content its wrapping around is, in fact, meant to be the main heading for the page.
      But I suspect there may be people who will already have a heading on the page wrapped with <h1> tags, so that's going to create a bit of a semantic issue (theoretically, from what I understand about HTML5 spec, it is possible to have more than one <h1> tag on a page, but you really need to know what you're doing).
      So I think that designers should have the option to select that tag for each text part that makes up an element.
      Additionally, if the main heading of an element is being used as the <h1> heading for a page, if designers are able to select the tag, then it should automatically wrap the <h1> tag with <header> tags (and maybe even the appropriate classes - e.g., entry-heading, entry-title).
      When you look at the other text parts that make up an element, you see that the subheading is automatically wrapped in a <h3> tag.
      If the main heading tag is a <h1> tag (as it is at present) then, logically/semantically, the subheading should be wrapped in <h2> tags or <p> tags (perhaps it could be set conditionally - depending on designer selection of main heading).
      Further, the subheading <h3> tag actually wraps around <p> tags that contain the subheading content.
      That makes no sense whatsoever.
      Finally when you specify a tag in the paragraph textbox of an element, it doesn't actually that tag as HTML. Instead, it adds a class - using the specified tag (e.g., class="h2") to a span.
      That also does not make sense.
    • eusebius
      By eusebius+
      Hello,
      Is there a way to mass apply a template to all tag archives?
      On my site, all tag archive pages claim they are using the Default template, but they look nothing like the Default template. I'm having a difficult reapplying that template to those pages without going through each one.
      Thanks in advance
      Thank God, I found the answer.
      My question was a bit more complex than I thought. It turns out that, when the Powerloop section is enabled, it overrides the queries for individual tags so that the page type reads pl_powerloop_TAG. It changes for each tag, which makes it impossible to target with a single template.
      When I disabled Powerloop (which I don't need anyway, since I use Toolset), all the tag queries reverted to normal and I was able to target that specific type with a template easily.
×