Jump to content
Sign in to follow this  
onlinetracker

Jigoshop + Framework 2.3.5, Layout Corruption

Recommended Posts

onlinetracker    2
onlinetracker

Occassionally I run into something that I can't figure out, but I run pretty standard layout sites. This one has plagued me on all of the sites that I've launched with Jigoshop.

I can't link to it because it isn't public, but I'll describe it as best I can and the steps to reproduce it.

Completely clean install. Install Jigoshop + Jigoshop for Pagelines. Custom Menu, moving functions so there is a dropdown. Nothing too amazing here but this is where it gets odd. Perhaps I'm missing something easy.

As soon as I activate the drop down function on pagelines... the CSS goes wonky and the formatting is lost [no graphics, no layout control, just one element under another element]. So, I think, oh, disable the drop down. Well, that doesn't change anything. So I disable Jigoshop, then disable Jigoshop for Pagelines and I get all of the formatting back. Reactive the dropdown menu function in Pagelines and the menu dropdown works even with Jigoshop disabled.

Reactivating Jigoshop takes the formatting away again.

Any ideas?

If this is the wrong place, feel free to move it. Thanks.

edit: I just changed up the way I activated Jigoshop, the dropdown menu and the Jigoshop for Pagelines plugin and behold, the site loads properly. I was easily able to reproduce it by activating the dropdown functionality last, but I'm not willing to go back and disable the feature just to test. Perhaps after a couple beers.

Edited by onlinetracker (see edit history)

Share this post


Link to post
Share on other sites
Rob    547
Rob

I was going to ask if you had the Jigoshop for PageLines plugin activated. I don't think you'll have problems with the slider now either.

Enjoy the beers.


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
onlinetracker    2
onlinetracker

I did enjoy the beer, picked up a growler of kingpin kolsch from a local brewpub and had a glass [or two] but that made me noodle around with the site and its back to its abnormal state of not having any formatting. As soon as I disabled Jigoshop and the Jigoshop for Pagelines plugins.. everything works. I can't believe I'm the only one with this glitch. I'll keep working on it, but thought I'd update this. I guess it wasn't a perfectly clean install in that I had installed Jetpack and bbPress (and the pagelines plugin for it). I've since disabled everything and reactivated Jigoshop+Pagelines and will see if it breaks it. It seems like it might be a cache problem but on the server side because three different browsers exhibit the same lack of layout control.

edit: Whatever is going on, just happened again and the formatting was lost. I disabled Jigoshop and the formatting came back, reactivated Jigoshop and the formatting is holding, but I'm fairly certain that in 30 minutes the formatting will be lost again.

edit: So I just added some CSS to the custom CSS section and right after I hit save, it lost its formatting. I deactivated Jigoshop, then reactivated it and the formatting came back. I'm completely lost at this point.

I was going to ask if you had the Jigoshop for PageLines plugin activated. I don't think you'll have problems with the slider now either.

Enjoy the beers.

Edited by onlinetracker (see edit history)

Share this post


Link to post
Share on other sites
James B    436
James B

Are these pages set to use SSL? If so you might need to follow the advice on this thread http://www.pagelines.com/forum/topic/20593-https-issue/page__hl__pl_force_ssl


Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites
onlinetracker    2
onlinetracker

Okay, after some more noodling around. No on the SSL, haven't gotten to that point yet.

So, even after everything is disabled, including drop downs and custom menus... after some point in time, the layout goes wonky with Jigoshop activated. I deactivate it, and the layout control comes back. I'm now going to try to duplicate it on another install.

Share this post


Link to post
Share on other sites
Danny    1,327
Danny

Keep us posted.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
onlinetracker    2
onlinetracker

Okay, so I keep trying things out and the problem definitely comes and goes depending on various switches, I think there is a glitch in the CSS and interwork of Jigoshop. I've got a large multisite going and deployed Jigoshop on it and can't remove the sidebars on the Jigoshop Archive page option in Pagelines does not hold its checkmarks. Layout is somewhat botched as well [the sidebars are misaligned with the product].

as an aside:

I'm sure most people hack their installations apart to make it work or suffer in silence, so I'll do the latter. I can't seem to fix a glitch that shows itself periodically and differently on various installs. It seems like a similar problem is with the TwitterBar drag&drop function where if you put it in the footer it becomes a victim of CSS code pertaining to the entirety of the Footer and if you put it in the MoreFoot section the grey bar doesn't show all the way across [it is victim to the CSS in the Content page] and only appears on the edges of the page.

I'm forcing myself into the Pagelines Framework because I don't have time to customize all of my personal pet projects.

Edited by onlinetracker (see edit history)

Share this post


Link to post
Share on other sites
James B    436
James B

Hi a couple of things I've just thought of which might help with troubleshooting

Do you have any header scripts or alterations to the functions.php which could be interfering?

What css are you adding? Are you getting any Less/Parse errors in the admin bar?

If you have any caching plugins active please disable them when making changes.

Whats the link to the jigoshop install so we can take a look

Do you have any other jigoshop plugins activated? I know sometimes they have some additional widget etc.


Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites
onlinetracker    2
onlinetracker

I've now had this same issue on two installs, both installs only have bbPress and typical extensions that are presumably core Pagelines compatible out of the box [ Bootstrap Icons, GoogleFonts, Grid Shortcodes, Pagelines Sections, Sexy Snips] and I always add Jetpack and may or may not use Pagelines Customize if I run into problems with a default install. One thing I have seen on both the problem site that I'm working with and a new site I'm working on [both aren't publicly accessible] is when I activate bbPress and bbPress for Pagelines, the CSS gets wonky the exact same way... no layout control. So, now I'm just confused as hell because it implies both builds have a problem with bbPress and not Jigoshop or at least with the Pagelines compatibility extension. I don't see many complaints about this issue [at least, I'm the only one on this thread] so I'll keep noodling around.

Share this post


Link to post
Share on other sites
Rob    547
Rob

bbPress actually requires an integration provided in The Store (Dashboard > PageLines > Store > Plugins > Top Free). Remember to both install and activate that.

This could explain the problem you're facing.


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×