Jump to content
justfitness

Less Compile Error...

Recommended Posts

justfitness

Hi,

I have looked through a couple of other threads which had the same issue but I can't seem to sort this out.

Very sorry but I really don't have much of a clue when it comes to any of this stuff.

I enabled WP_DEBUG as mentioned by other posts and get this:

Notice: load_plugin_textdomain was called with an argument that is deprecated since version 2.7 with no alternative available. in /home/content/61/7859861/html/wp-includes/functions.php on line 2724

Notice: Constant PLUGINDIR already defined in /home/content/61/7859861/html/wp-content/plugins/quick-notice/quick-notice.php on line 20

Notice: wp_enqueue_script was called incorrectly. Scripts and styles should not be registered or enqueued until the wp_enqueue_scripts, admin_enqueue_scripts, or init hooks. Please see Debugging in WordPress for more information. (This message was added in version 3.3.) in /home/content/61/7859861/html/wp-includes/functions.php on line 2758

Notice: wp_enqueue_style was called incorrectly. Scripts and styles should not be registered or enqueued until the wp_enqueue_scripts, admin_enqueue_scripts, or init hooks. Please see Debugging in WordPress for more information. (This message was added in version 3.3.) in /home/content/61/7859861/html/wp-includes/functions.php on line 2758

Notice: Undefined variable: plugin in /home/content/61/7859861/html/wp-content/plugins/wp-fb-fan-box/wp-fb-fan-box.php on line 71

Notice: register_sidebar_widget is deprecated since version 2.8! Use wp_register_sidebar_widget() instead. in /home/content/61/7859861/html/wp-includes/functions.php on line 2638

Notice: register_widget_control is deprecated since version 2.8! Use wp_register_widget_control() instead. in /home/content/61/7859861/html/wp-includes/functions.php on line 2638

Notice: unregister_sidebar_widget is deprecated since version 2.8! Use wp_unregister_sidebar_widget() instead. in /home/content/61/7859861/html/wp-includes/functions.php on line 2638

Notice: Undefined index: number in /home/content/61/7859861/html/wp-content/plugins/page-link-manager/page-link-manager.php on line 18

Notice: register_sidebar_widget is deprecated since version 2.8! Use wp_register_sidebar_widget() instead. in /home/content/61/7859861/html/wp-includes/functions.php on line 2638

Notice: register_widget_control is deprecated since version 2.8! Use wp_register_widget_control() instead. in /home/content/61/7859861/html/wp-includes/functions.php on line 2638

Notice: register_sidebar_widget is deprecated since version 2.8! Use wp_register_sidebar_widget() instead. in /home/content/61/7859861/html/wp-includes/functions.php on line 2638

Notice: register_widget_control is deprecated since version 2.8! Use wp_register_widget_control() instead. in /home/content/61/7859861/html/wp-includes/functions.php on line 2638

Notice: Use of undefined constant zframe - assumed 'zframe' in /home/content/61/7859861/html/wp-includes/widgets.php on line 324

Notice: has_cap was called with an argument that is deprecated since version 2.0! Usage of user levels by plugins and themes is deprecated. Use roles and capabilities instead. in /home/content/61/7859861/html/wp-includes/functions.php on line 2722

Notice: has_cap was called with an argument that is deprecated since version 2.0! Usage of user levels by plugins and themes is deprecated. Use roles and capabilities instead. in /home/content/61/7859861/html/wp-includes/functions.php on line 2722

Notice: has_cap was called with an argument that is deprecated since version 2.0! Usage of user levels by plugins and themes is deprecated. Use roles and capabilities instead. in /home/content/61/7859861/html/wp-includes/functions.php on line 2722

Notice: has_cap was called with an argument that is deprecated since version 2.0! Usage of user levels by plugins and themes is deprecated. Use roles and capabilities instead. in /home/content/61/7859861/html/wp-includes/functions.php on line 2722

I know it's a lot but I don't have a clue what to do :(

Thanks in advance for any help,

Justin

Share this post


Link to post
Share on other sites
Danny

Hi,

First thing to do, is disable WP_debug.

Once you have done that, can you reply here with the error you're receiving please.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
justfitness

Hi,

First thing to do, is disable WP_debug.

Once you have done that, can you reply here with the error you're receiving please.

Ok thanks, I have disabled WP_DEBUG.

All that's happening is my whole dashboard is white and unusable, it does say:

"LESS Compile error!" in the top right, and when I hover over that it says:

"Error in custom Less code: parse error: failed at" ...and that's it.

Thanks

Share this post


Link to post
Share on other sites
Rob

Did you add any custom CSS code or plugins before this error started?


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
justfitness

Did you add any custom CSS code or plugins before this error started?

No. I hadn't logged in for quite a while, I logged in yesterday and updated to the latest version of pagelines. And today when I went to do some stuff to the site I couldn't because it's all white apart from the menus.

Share this post


Link to post
Share on other sites
Rob

Let's try some basic steps then.

Reactivate the debug so you can get into the Dashboard.

Deactivate all the non-PageLines plugins. If you have a cache plugin activated, clear the cache then deactivate it.

If you have custom CSS, copy it all. Go to this link. Click the "By direct input" tab and paste the CSS. Run the validation. Fix any errors found, then copy from the lower part of the results page and paste back to replace the original. Save.

Check to see if you find errors. If they've gone, it was one of those two things.

Now, in Dashboard > Plugins > Installed Plugins, reactivate the ones you deactivated one at a time, checking after each one. I'm pretty sure you'll find one that may have caused this. When you do, find a replacement for it, remove it then implement the replacement.


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
justfitness

Hi,

Thanks for your reply. However I can't deactivate the plugins or do anything really because the whole dashboard is blank/white.

Share this post


Link to post
Share on other sites
catrina

Can you please upload a fresh version of the functions.php file to overwrite the one you have now? (This is where debug was enabled - perhaps that caused the Dashboard to go blank)


Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites
justfitness

Can you please upload a fresh version of the functions.php file to overwrite the one you have now? (This is where debug was enabled - perhaps that caused the Dashboard to go blank)

Hi,

Thanks, I uploaded a fresh functions.php file and still nothing :(

Share this post


Link to post
Share on other sites
Simon

PM me your admin login, i'll look at it for you.

Share this post


Link to post
Share on other sites
Simon

Right, took a look in wp-admin, and it looks like you had put javascript in the CSS box. Common mistake lol.

http://screencast.com/t/8ajexxJj8aU5

Anyway the fix is simple, add this to customize plugins functions.php:

add_action( 'admin_init', function() { plupop( 'customcss', '' ); } );
Then load the frontend a couple of times, the backend will now load as customcss has been set to NULL. Here is a copy of your css so you can copy it back after:
input, textarea {
color: white;
}
.current_page_item a {
background: #0dff00 !important;
color:black !important;
}
.banner_container .banner-area {
padding: 0 0;
}
element.style {
margin-bottom: 0;
}
#branding .content-pad {
padding: 20px 0px 15px;
}
.jetpack_subscription_widget div {
background-color: black !important;
}
[/code]

  • Like 1

Share this post


Link to post
Share on other sites
justfitness

Sorry, but where do I add this? I'm rubbish at this stuff.

Share this post


Link to post
Share on other sites
Simon

wp-content/plugins/pagelines-customize/functions.php, at the bottom of the file.

  • Like 1

Share this post


Link to post
Share on other sites
justfitness

Ok I've done that, now I get this error:

Parse error: syntax error, unexpected T_FUNCTION in /home/content/61/7859861/html/wp-content/plugins/pagelines-customize/functions.php on line 45

Guess I did it wrong :(

Share this post


Link to post
Share on other sites
Simon

Ahh, its an old version of PHP, my bad:

add_action( 'admin_init', create_function( '', 'plupop("customcss", "");' ) );[/CODE]

  • Like 1

Share this post


Link to post
Share on other sites
Simon

Dont forget to remove the line, else it'll keep clearing that option.

  • Like 1

Share this post


Link to post
Share on other sites
Simon

The topic was marked as resolved.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Similar Content

    • Michael Kummer
      By Michael Kummer+
      Hi guys!
      I have noticed that my primary sidebar becomes intermittently invisible when browsing through various blog articles on michaelkummer.com/blog.
      See:
      https://www.dropbox.com/s/z646sgoa3mfjl1j/Screenshot 2018-07-12 15.57.46.jpg?dl=0 and https://www.dropbox.com/s/vdledzzgginvwgv/Screenshot 2018-07-12 15.57.57.jpg?dl=0
      Upon refresh, the sidebar appears. I have been using the following CSS code to hide the sidebar on mobile without any issues. 
      @media only screen and (max-width: 993px) {
      /* hide sidebars */
           .plsb {
              display: none !important;
          }
      }
      I tried to add the following CSS to force the sidebar to show on screens that are wider than 994 pixels but to no avail. Any clue what could be causing this issue?
    • Michael Kummer
      By Michael Kummer+
      Hi guys!
      I am using the LESS/CSS Pagelines extension and tried to add the following code to make use of FontAwesome:
      a.c2a:before {
          content: "\f07a\00a0";
          font-family: "Font Awesome 5 Pro";
          Font-weight: 900;
          font-style: normal;
          font-weight: normal;
          text-decoration: inherit;
          padding-left: 4px;
      }
       
      The issue is that as soon as I have the CSS via the Custom Styling text box, Pagelines (or the extension) strips out the backslashes (\). As a result, I had to abandon the CSS/LESS extension and instead add all my CSS code to a separate .css file.
      Is there a fix or workaround for this?
      Thanks
      Michael
    • MiraAdmin
      By MiraAdmin+
      Looking for some help on a recently developed issue. Editor will not load. 
      Theme:  DMS2
      Error from:  Chrome - Inspector - console view
      Error message: Refused to execute script from 'http://xxxx.xxx/wp-content/themes/dms/dms/editor/js/gettext.js/?ver=4.9.7' because its MIME type ('text/html') is not executable, and strict MIME type checking is enabled.
      Occurs on all sites on same server. 
      WP versions to 4.9.5, 4.9.6, 4.9.7 = same behavior. Worked properly on these same versions until 07/04/2018.
      No new plugins. Isolating plugins offers same behavior. 
      Server vendor reports no changes, patches, etc. 
      Server re-starts no impact.  

      Thank you. 
    • glyph.marketing
      By glyph.marketing+
      Hello, I am having a problem similar to that experienced by Michael Kummer here. We have pages that show this automatic scrolling issue (examples here and here) and it is sufficiently annoying that we have seen customers bounce while trying to convert. Strangely, it only happens at specific resolutions, so it can be difficult to reproduce. In general we can only consistently reproduce it on a 4k resolution with a browser width between 1517 and 1536px. 
      Thanks to Michael Kummer's help we were able to set the overflow-anchor property to none in the entire body, which fixed the issue as far as we can tell, but also obviously disabled scroll anchoring for the whole site. I tried applying it to the specific element that looked like it was being reloaded, which was the PL Meganav extension, but that was unsuccessful. 
      Can anyone help us figure out which element or ID we can apply this property to, so that we can fix the scrolling issue but not disable scroll anchoring for the entire site?
      Thank you - 
      Glyph Language Services
×