Jump to content
davestolte

Completely Remove Footer, By-Page Control?

Recommended Posts

davestolte+    0
davestolte

I'm building a site for a client at http://politeprovisions.com and would like to remove the white footer area at the bottom and have the background continue tiling. I've seen plenty of topics about removing the PageLines leaf logo, but none about removing the footer entirely.

When the final site launches, though, we'll probably want the footer in there. Is there a way to control this by page?

Share this post


Link to post
Share on other sites
Rob    547
Rob

If you have a static page or post, you can go to PageLines Meta Settings there and check "Hide Footer". A div may remain. If that's the case, we can control it with the Site Options setting to Hide Sidebars when Empty.


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
davestolte+    0
davestolte

I believe I already have both of those set, and still no go. Is there a custom CSS I can paste in?

Screen-Shot-2012-11-10-at-3.09.09-PM.png

Screen-Shot-2012-11-10-at-3.10.18-PM.png

Share this post


Link to post
Share on other sites
Danny    1,327
Danny

Hi,

I am not sure what you're trying to do, if you have no content in your Footer, then what is it you wish to hide ?


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
davestolte+    0
davestolte

There's a white block at the bottom of the page - I'd like the tiling background to continue off the page.

Share this post


Link to post
Share on other sites
Rob    547
Rob

Hi, if your Layout Mode is Responsive with Pixel Width and the Site Design Mode is Full Width Sections, and you've gone to Dashboard > PageLines > Site Options > Color Control and your background is uploaded there, set it to Tile, with 0 for the Vertical Position and 50 for the Horizontal. Make sure Supersize is unchecked. After you've saved, the background should appear everywhere.

  • Like 1

Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
davestolte+    0
davestolte

Thanks Rob - I double-checked all those and the only items that weren't set were vertical & horizontal. I set those, and it's still showing the white block at the bottom. See attached screen grab.

Any other ideas?

Screen-Shot-2012-11-13-at-11.05.06-AM.png

Share this post


Link to post
Share on other sites
Danny    1,327
Danny

Can you provide a link to the site in question please, so we can take a closer look.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
davestolte+    0
davestolte

I'm building a site for a client at http://politeprovisions.com and would like to remove the white footer area at the bottom and have the background continue tiling. I've seen plenty of topics about removing the PageLines leaf logo, but none about removing the footer entirely.

When the final site launches, though, we'll probably want the footer in there. Is there a way to control this by page?

Share this post


Link to post
Share on other sites
catrina    103
catrina

To hide or disable footer by page, you can do so in PageLines Meta Settings by hiding the sections in your footer.


Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites
davestolte+    0
davestolte

See attached screen grab for the page's Meta settings... I must be missing something somewhere.

Screen-Shot-2012-11-14-at-9.07.42-AM.png

Share this post


Link to post
Share on other sites
catrina    103
catrina

I'm referring to PageLines Meta Settings in the page editor (where you edit the page content). The screenshot above shows the Global Settings for pages.


Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites
davestolte+    0
davestolte

Unless I'm misunderstanding something, that's where this is set. See attached. I've also tried setting the specifics of the page background tiling globally and per page, no difference.

Screen-Shot-2012-11-14-at-9.54.52-AM.png

Share this post


Link to post
Share on other sites
James B    436
James B

The background doesn't get applied to the footer area. The easiest way to do what you're trying to do is remove the bg from the upload area in the color control tab and apply it with css to the below. Applying it the the #site tag will force the bg to cover the footer area as well.


#site {background: url(your-full-url-goes-here);}


Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites
davestolte+    0
davestolte

Tried that, still not working: http://politeprovisions.com

I'm surprised there isn't an easy way to completely remove the footer and let the page background tile infinitely.

Any other ideas?

Share this post


Link to post
Share on other sites
James B    436
James B

Hi there, just checked your link, your page is set to a min-height of 400px. If you use the below css and change the figure to suit, that code is giving me this result, http://screencast.com/t/nhCQurKJD


#site #page, #site #dynamic-content {



	min-height: 800px;

}

Or you could use css to apply the bg to the footer section as well so it just continues the repeating pattern.

#footer {

background: url(...);

}

  • Like 1

Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites
davestolte+    0
davestolte

It's a kludge, but it works! Thanks, James.

Share this post


Link to post
Share on other sites
mackenzie    12
mackenzie

The topic was marked as resolved.


Mackenzie - PageLines Help Desk

The Centsible Family - Writer, Photographer and Coffee Addict

---------------------------------------------------

Kindly search this forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Similar Content

    • janpeeters
      By janpeeters+
      Over the last month I had extensive communications with the developer of the (premium) Anything Boxes section (in Pagelines store) (Adam Munns) and the developer of the WP Polylang Multilingual plugin (Frederic Demarle).
       
      This was because the following problem occurred:
      Anything Boxes showed all posts of two languages (Dutch and English) on the respective static frontpages for each language. It should of course have filtered posts for Dutch language on the Dutch frontpage and English on the English frontpage.
       
      The solution to this problem was simple in the end. When duplicating a page for use in another language the settings for Anything Boxes were not copied to the new page and I should have set these settings manually again on the new page. I wasn't aware of this, but it makes sense. Because of this the pages didn't know how to differentiate between posts from different languages.
       
      The dev of Polylang told me that Polylang is currently smart enough to synchronize metas like Featured images and page templates but it does not work out of the box with metas created by plugins and themes but (according to Frederic) it is rather easy to add them in the list using the filter 'pll_copy_post_metas'.
      He mentions that he is not sure that these 'PageLines Meta Settings' are stored in post meta but that would make sense according to him. He asks if the Pagelines dev team will be interested to support this feature in the future.
       
      I'm also wondering if you will consider adding Polylang translation support for manually editable strings like the 'Read more…' strings in Pagelines Settings.
       
      Well that's of course up to you but I thought to let you know to be able to take this into consideration. I also post this for other users in case they experience the same kind of trouble and are looking for an answer.
       
      Best regards,
      Jan Peeters
    • bankrollbuilder
      By bankrollbuilder
      I used a custom hook to put a banner ad in my header. It works but its not in the right position. it is centered and above my logo and I would like to float it to the right of my logo in the header. heres the link: http://shaboopie.com/shaboopie-wp/free-logos-pg1/

      thanks.

      Dan B.
    • starlit
      By starlit
      Can one have two hero sections on one page?

      I want a landing page which leads/advertises two subpages.

      Or is there another option?

      Please help.

      THANK YOU
    • hutruk
      By hutruk
      Hi!

      I am using the shortcodes for tabs, as described in the documentation.

      When I insert the following code:


      [pl_tabs][pl_tabtitlesection type="tabs"] [pl_tabtitle number="1"]Title 1[/pl_tabtitle] [pl_tabtitle number="2"]Title 2[/pl_tabtitle] [/pl_tabtitlesection] [pl_tabcontentsection] [pl_tabcontent active="yes" number="1"] Lorem ipsum dolor sit amet, consectetur adipiscing elit [/pl_tabcontent] [pl_tabcontent number="2"] Lorem ipsum dolor sit amet, consectetur adipiscing elit [/pl_tabcontent] [/pl_tabcontentsection] [/pl_tabs]

      I get a strange output (in the attachment).

      Any ideas?

      Thanks in advance!

    • MooiWeb
      By MooiWeb
      Hello,

      I would like to align my qtranslate with my breadcrumb so that the flags are on the same hight.
      I'm aware of putting a code in the custom css and tryed severall codes from your site but for now, no succes

      The site i'm working on is http://nieuw.vazdias.nl

      Thx,
      Edwin



×