Jump to content
Sign in to follow this  
stedic

Level 1, Level 3 Navbar Not Appearing

Recommended Posts

stedic    0
stedic

While the website I'm working on is currently masked by an underconstruction plugin. The problem I'm running into is fairly simple.

The Navbar is broken down like this.

Home (Main Static Page)

1st Level - Portfolio

2nd Level - Highrise

3rd Level - Title of Project

However, A. 1st Level cannot be selected and B. 3rd level does not appear at all in the dropdown nav. Can someone explain why this happens and if there is a work around? Thanks

-S

Share this post


Link to post
Share on other sites
Rob    547
Rob

Okay, to clear up the conventions of language, 1st level is called Parent, 2nd is Child and 3rd is Grandchild.

NavBar is the wrong product to use for that kind of menu. I'd recommend Nav Classic.

In NavBar, the Parent item for anything that has a drop down only links to open the menu. If there's no child items, it will go directly to the link intended. The solution is to repeat the parent link in the child list, usually as the first or top item in the drop list. Grandchild items, I don't believe, work in the menu.

The penultimate solution would be to replace NavBar with Nav Classic in Dashboard > PageLines > Drag & Drop > Header. Just swap them. The menu items remain the same.


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
stedic    0
stedic

That worked, but this "Grandchild items, I don't believe, work in the menu." I need grandchild items to work. Hell with navclassic I can't even get Children to work. Any pointers?

Share this post


Link to post
Share on other sites
James B    436
James B

If you go to Pagelines>site options>header and footer when the nav classic is active you'll see the options for activating the drop downs in the classic nav. Tick the check boxes and refresh.


Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Similar Content

    • Grant Turck
      By Grant Turck+
      Navbar Broken on All Devices When Not Logged Into Wordpress. See screenshots attached from mobile. What is causing this issue and how do I fix? Site is venicepride [dot] org.


    • PierreFF
      By PierreFF+
      Hello, 
      I have an issue with NavPro on mobile when the link of the menue is on the same page. 
      Here is my website: http://foundersofthefuture.co
      The isssue comes from the fact that in my menue most of the items send somewhere else on the same page using anchor link (eg. #container_u788888). 
      This works well on desktop but on mobile, nothing happens when clicking on the link. One of the link of the menue of the homepage "France" sends to another page of the website and this one works well even on mobile. 
      I am using the Pagelines framework theme and also used a wordpress plugin (jQuery Smooth Scroll) for smooth scrolling . 
      Thanks in advance for your help and let me know if I need to provide more information. 
      Best,
      Pierre
    • tristanrodgers
      By tristanrodgers+
      Hi there!
      I'd love to have some social media buttons in my navbar like my online-shop has!
      http://mc1r-magazine.com/
      Can someone explain me how to create them? I tried a lot but don't know how to realize them...
      Greetings from Germany,
      Tristan
    • jeomiland
      By jeomiland+
      Hi guys. Just now trying out Platform 5. I like the reletive simplcity of the new interface but there are things I'm used to in DMS that I'm not seeing yet in 5. Is there a good manual, documentation, video series about some of the basics?
      In particular, I've got a simple navigation menu, created the standard way in WP menus section with several top level parents, then 3-4 children menu items below a couple parent items. Have them moved to the right to create the standard parent-child relationship but all I see on the page is the parent level items - no dropdown!. So I changed themes from Platform5 to the standard 2015 default theme and now I see absolutely no menu at top, except for the mobile (hamburger?) icon.
      In DMS, one had Navi and Navbar, etc sections and each would work differently and give different results. How do you work the menu system in 5? And how get different results ?
      thanks
    • nizami
      By nizami+
      I have a problem at http://kambo.world. Using navbar for the main site navigation. It works fine in normal/desktop mode [first screenshot], using the WP Menu I have specified. But in hamburger mode it seems to do its own thing, picking a few pages at random [second screenshot] A fix for this greatly appreciated! 
       


×