Jump to content
adampfoster

Views (And Types Custom Types / Fields) Compatibility?

Recommended Posts

adampfoster    1
adampfoster

Hi,

I've noticed that custom field data from custom posts isn't showing up when I create template to display the custom field data via the Views plugin which also works with the free Types plugin.

The tutorial that I'm following is here - http://types-tutorials.com/how-to-make-a-job-board-system-using-types-and-views-part-3/

I realise that Views is a premium plugin, however I'm happy to setup a test environment with Pagelines installed, for someone to jump into, and try to diagnose what's going wrong.

I switched themes to the stock wordpress theme and the custom field data shows up fine and represented correctly as defined in the view template, so it's evident that something is different with PageLines that results in the custom field data not appearing.

I would appreciate any help with this.

Cheers

Adam

Share this post


Link to post
Share on other sites
Danny    1,327
Danny

Hi Adam,

As you know PageLines isn't like a standard Wordpress theme. Therefore, I recommend you contact the plugin author first and see what they recommend, as they may be able to provide you with some code that will allow this to work.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
adampfoster    1
adampfoster

Hi Danny,

Yes it seems to be different. I figured out that the_content function in Pagelines is actually post_content, and Views lets you very easily replace the function in case it changes, which is great on their part.

Thanks for your quick response anyhow.

Curiously why does Pagelines change the function?

Cheers

Adam

  • Like 1

Share this post


Link to post
Share on other sites
catrina    103
catrina

@adam I'm not sure why PL changed the function, but you should try Ellen's solution above and let us know how it works for you.


Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites
adampfoster    1
adampfoster

Hi,

Ellen and Catrina, that solution worked great!

Thanks for your help with this!

Issue resolved.

Cheers

Adam

Share this post


Link to post
Share on other sites
James B    436
James B

The topic was marked as resolved.


Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Similar Content

    • flourishdesignstudio
      By flourishdesignstudio
      Hi,
      I am using PL5 as well as Advanced Custom Fields (AFC) to help add meta data to individual posts on our blog. However, where I am getting stuck is how to display the meta data on the actual public post page (frontend). For example, if we have posts that have a subject matter of plants then there are custom fields that the client fills out such as "Scientific Name", "Region", etc. I have used ACF before to display this meta data onto the loops section as well as in Revolution Slider or Essential Grid. However, I am not sure if there is a way to have this metadata display on the actual post page. Can you point me in the right direction? I am using a child theme so I wasn't sure if that meant I had to edit the functions.php file or if there was some other workaround that you knew of.
      Thanks so much!
    • PeriniNero
      By PeriniNero+
      We are building a Custom Post Type with Custom Fields and Custom Taxonomies.
      The only thing we dont understand is how to embed the Custom Fields including header tags and stuff in the Postloop (now we use a text-box below the postloop section but also SEO wise this is not best pratice).
      So we thought to copy the dms Postloop section to our child theme and rename this, to add an extra Postloop section to our theme. Is this the way?
      What exactly to adjust in those 3 files class.posts.php, section.php and style.less (at this point we know how to change the thumb LOL) and where to add the Custom Fields shortcodes?
      Thanks.
    • MissT
      By MissT+
      It looks like there is a plugin conflict with the Platform5 Maps and Toolset Views plugin which prevents the map from displaying on screen.  Deactivate the views plugin and the map appears.
      There are the following browser warnings...
      Google Maps API warning: NoApiKeys https://developers.google.com/maps/documentation/javascript/error-messages#no-api-keys util.js (line 219)   Google Maps API warning: SensorNotRequired https://developers.google.com/maps/documentation/javascript/error-messages#sensor-not-required   Maps v 5.0.5 Toolset Views v 11.1.11 WP v 4.4.2 PL5 - 5.0.132   URL can be provided privately.  
    • dawsonbarber
      By dawsonbarber+
      I found that I'm unable to create and save custom field groups with WP Types when Single Bits is installed and active.
       
      I'm not sure if it interferes with any other functionality, but there's definitely an issue with custom field groups.
       
      When I deactivate Single Bits, I'm able to create custom field groups.
       
      Custom fields appear to be fully functioning after creating them and reactivating Single Bits, so that's good.
    • CjrMotley
      By CjrMotley+
      Ok, I'm having problems with my custom post types showing on my front blog page along with my regular blog post, here is a link to the custom post type (sample post) ==> http://www.definitiondjs.com/musiclibrary/this-is-a-post-title-test/ ..... my custom fields doesn't show, Why?
       
      Also, when I edit the custom post, all the fields change to blank (the previous text that was in the field is somehow deleted), why?
       
      Wordpress: 4.0
      Pageline Frameworks: 2.4.5
      cpt plugin is: WCK, here is a link to the site ==> http://www.cozmoslabs.com/docs/wordpress-creation-kit-documentation/
       
      I linked snapshots of the custom fields area, which doesnt show after publishing or after clicking edit this post:
       
      http://www.definitiondjs.com/wp-content/uploads/2014/09/01.png
      http://www.definitiondjs.com/wp-content/uploads/2014/09/02.png
      http://www.definitiondjs.com/wp-content/uploads/2014/09/03.png
       
      Summary, I would like my custom post to display on my front page, along with my blog post.
       
      Also I would like to have an option to hide post from showing on front page, but I would like for all posts to show in search, archieved and category, even if hidden from the front page.
       
      Thanks in advance!
×