Jump to content

Archived

This topic is now archived and is closed to further replies.

hireconrad

Creating A New Template For Drag And Drop?

Recommended Posts

hireconrad    0
hireconrad
Hi,
i have used up all the available templates for the drag and drop section, and was wondering if there was a way I can add additional templates.

Share this post


Link to post
Share on other sites
James B    436
James B
Hi there, yes you can. Please check out this page for further information http://www.pagelines.com/wiki/How_to_Create_a_Custom_Page_Template

Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites
hireconrad    0
hireconrad
[quote name='James B' timestamp='1352173801' post='135172']
Hi there, yes you can. Please check out this page for further information [url="http://www.pagelines.com/wiki/How_to_Create_a_Custom_Page_Template"]http://www.pagelines...m_Page_Template[/url]
[/quote]

Hi, i followed the instructions, however the template appears from the drop down menu when I'm on a page, however in the Drag and Drop section of the Pagelines settings, it does not appear, and therefore I cannot setup what elements are found on the custom template.

Share this post


Link to post
Share on other sites
Danny    1,327
Danny
Hi,

Go to PageLines > Store, then return to PageLines > Drag and Drop and your template should now be visible. If it still isn't available to use, then please disable all non-PageLines plugins and see if this resolves your issue.

Please search our forums, before posting!

Share this post


Link to post
Share on other sites
hireconrad    0
hireconrad
[quote name='Danny' timestamp='1352194277' post='135212']
Hi,

Go to PageLines > Store, then return to PageLines > Drag and Drop and your template should now be visible. If it still isn't available to use, then please disable all non-PageLines plugins and see if this resolves your issue.
[/quote]

I tried what you suggested and still nothing.
I disabled all non-Pagelines plugins and checked to see if the template would show up in the Drag and Drop section, and it does not appear.

What am i missing? What to do next?

Share this post


Link to post
Share on other sites
James B    436
James B
Hi there, first check you've definitely got the base theme or the customize plugin active. If you do, then I would delete the first attempt and try again from the beginning. Do you have any kind of caching plugin's or services active? Any custom script added anywhere which could interior with the code?

Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites
hireconrad    0
hireconrad
Hi, i have the customize plugin active (as I use it to add all my custom css for my site).
I do not have any kind of caching plugin or services active. I have disabled all plugins (except pagelines plugins) and the template has not appeared on the drag and drop section.
No custom scripts as I do not even know how to write scripts.

I will try again from scratch.

Share this post


Link to post
Share on other sites
hireconrad    0
hireconrad
Just went through the process again…. and still no luck

Here is what I did:
1)Downloaded the Base Child Theme
2)using filezilla, navigated to ../wp-content/themes/pagelines-template-theme
3)copied the file page.example.php onto my desktop
4) using dreamweaver accessed the file and added the following code:


[CODE]
<?php
/*
Template Name: Template | 6
*/

/**
* Page Template - Template 6
*
* @package PageLines Framework
* @since ...
*
* @link http://www.pagelines.com/
* @link http://www.pagelines.com/tour
*
* @author PageLines http://www.pagelines.com/
* @copyright Copyright (c) 2008-2012, PageLines hello@pagelines.com
*
* @internal last revised November 6, 2012
* @version ...
*
* @todo Define version
*/

setup_pagelines_template();[/CODE]

5) changed the name of the file to page.template6.php
6) went back into filezilla, made my way to ../wp-content/themes/pagelines/ and uploaded it next to the other template files

I can choose Template 6 from within a page, however it does not appear in the Drag & Drop section of Pagelines, and therefore I cannot customize which elements get added to this template. Only the default templates appear.

Share this post


Link to post
Share on other sites
James B    436
James B
Hi there, I've just set one up myself to test those instructions are definitely working and it's come straight up in the d&d. Are you sure you copied the correct file, as my example page only has the below inside, nothing else.

[CODE]
<?php
/*
Template Name: Example Page
*/
setup_pagelines_template();
[/CODE]

Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites
hireconrad    0
hireconrad
[quote name='James B' timestamp='1352260898' post='135372']
Hi there, I've just set one up myself to test those instructions are definitely working and it's come straight up in the d&d. Are you sure you copied the correct file, as my example page only has the below inside, nothing else.

[CODE]
<?php
/*
Template Name: Example Page
*/
setup_pagelines_template();
[/CODE]
[/quote]

Here are some screen grabs from filezilla and textmate (can you spot something wrong?):

[img]http://img.photobucket.com/albums/v222/Vio1/2.jpg[/img]

[img]http://img.photobucket.com/albums/v222/Vio1/1.jpg[/img]

[img]http://img.photobucket.com/albums/v222/Vio1/3.jpg[/img]

[img]http://img.photobucket.com/albums/v222/Vio1/4.jpg[/img]

Share this post


Link to post
Share on other sites
Danny    1,327
Danny
Hi,

I have just found out that the PageLines Customisation plugin used to support this. But due to it causing conflicts with permission issues with cheap hosting, this option has been removed.

In order to create custom page templates, you will need to use a child theme and add them in the child theme folder.

Please search our forums, before posting!

Share this post


Link to post
Share on other sites
hireconrad    0
hireconrad
[quote name='Danny' timestamp='1352298859' post='135424']
Hi,

I have just found out that the PageLines Customisation plugin used to support this. But due to it causing conflicts with permission issues with cheap hosting, this option has been removed.

In order to create custom page templates, you will need to use a child theme and add them in the child theme folder.
[/quote]
i bought am and using heavily the iblogpro theme, and am not starting from scratch to load the child theme so that i can create new templates. Is there any way I can manage this with the iblogpro theme?

Share this post


Link to post
Share on other sites
Simon    247
Simon
Put the file in the iblog5 folder, simple.
  • Like 1

Share this post


Link to post
Share on other sites
hireconrad    0
hireconrad
[quote name='Simon_P' timestamp='1352299928' post='135429']
Put the file in the iblog5 folder, simple.
[/quote]
thank you. it worked.

Share this post


Link to post
Share on other sites

  • Similar Content

    • janpeeters
      By janpeeters+
      Over the last month I had extensive communications with the developer of the (premium) Anything Boxes section (in Pagelines store) (Adam Munns) and the developer of the WP Polylang Multilingual plugin (Frederic Demarle).
       
      This was because the following problem occurred:
      Anything Boxes showed all posts of two languages (Dutch and English) on the respective static frontpages for each language. It should of course have filtered posts for Dutch language on the Dutch frontpage and English on the English frontpage.
       
      The solution to this problem was simple in the end. When duplicating a page for use in another language the settings for Anything Boxes were not copied to the new page and I should have set these settings manually again on the new page. I wasn't aware of this, but it makes sense. Because of this the pages didn't know how to differentiate between posts from different languages.
       
      The dev of Polylang told me that Polylang is currently smart enough to synchronize metas like Featured images and page templates but it does not work out of the box with metas created by plugins and themes but (according to Frederic) it is rather easy to add them in the list using the filter 'pll_copy_post_metas'.
      He mentions that he is not sure that these 'PageLines Meta Settings' are stored in post meta but that would make sense according to him. He asks if the Pagelines dev team will be interested to support this feature in the future.
       
      I'm also wondering if you will consider adding Polylang translation support for manually editable strings like the 'Read more…' strings in Pagelines Settings.
       
      Well that's of course up to you but I thought to let you know to be able to take this into consideration. I also post this for other users in case they experience the same kind of trouble and are looking for an answer.
       
      Best regards,
      Jan Peeters
    • bankrollbuilder
      By bankrollbuilder
      I used a custom hook to put a banner ad in my header. It works but its not in the right position. it is centered and above my logo and I would like to float it to the right of my logo in the header. heres the link: http://shaboopie.com/shaboopie-wp/free-logos-pg1/

      thanks.

      Dan B.
    • starlit
      By starlit
      Can one have two hero sections on one page?

      I want a landing page which leads/advertises two subpages.

      Or is there another option?

      Please help.

      THANK YOU
    • hutruk
      By hutruk
      Hi!

      I am using the shortcodes for tabs, as described in the documentation.

      When I insert the following code:


      [pl_tabs][pl_tabtitlesection type="tabs"] [pl_tabtitle number="1"]Title 1[/pl_tabtitle] [pl_tabtitle number="2"]Title 2[/pl_tabtitle] [/pl_tabtitlesection] [pl_tabcontentsection] [pl_tabcontent active="yes" number="1"] Lorem ipsum dolor sit amet, consectetur adipiscing elit [/pl_tabcontent] [pl_tabcontent number="2"] Lorem ipsum dolor sit amet, consectetur adipiscing elit [/pl_tabcontent] [/pl_tabcontentsection] [/pl_tabs]

      I get a strange output (in the attachment).

      Any ideas?

      Thanks in advance!

    • MooiWeb
      By MooiWeb
      Hello,

      I would like to align my qtranslate with my breadcrumb so that the flags are on the same hight.
      I'm aware of putting a code in the custom css and tryed severall codes from your site but for now, no succes

      The site i'm working on is http://nieuw.vazdias.nl

      Thx,
      Edwin



×