Jump to content
danoah

Theme Cutting Off Facebook "like" Box Comment Drop-Down

Recommended Posts

danoah

Hello, when I install a like button in the content itself (for example in the first paragraph of this post: http://www.danoah.com/2011/11/im-christian-unless-youre-gay.html) the drop-down is cut off and doesn't display properly after a user clicks like.

Google searches lead me to believe that there is a problem with the CSS somewhere. Any idea how I can fix that?

Thanks, Dan

Share this post


Link to post
Share on other sites
Rob

Dan, I'm not sure why it's doing that. Very weird, I dare say. I'm looking into it and should have some answers by Monday or so. Unfortunately, I'm a hurricane evacuee at the moment, so if I don't answer this again, please bump it to one of my colleagues.


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
danoah

BUMP

Thanks for your reply Rob, stay safe!

Any others have any idea how I can fix this?

Share this post


Link to post
Share on other sites
James B

Hi there, the buttons seem to be using inline css which specify the width and height. I'd imagine these settings are built into the widget/plugin somewhere. At the moment it's showing a height: 86px & width: 49px.

I can't any css fixes for this other than the inline options. I'd say email the plugin author and see if he has a fix for the css or a container he can suggest we target.


Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites
danoah

Thanks for the reply. I don't use a plugin or inline CSS for these with the exception of float:right and padding (this problem happens when I eliminate the inline). I simply copy the code from Facebook's developer site.

I've also tried setting the width higher in the plugin itself.

I'm being told this is definitely theme/css related so any help would be really appreciated.

Share this post


Link to post
Share on other sites
Danny

Hi,

I don't use Facebook, so can you take a screenshot of the issue please. Also, where abouts on Facebook did you find the code, can you link it please and where/how did you add it to your site.

One last thing, please do not Bump topics.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
yoavtaler

Hi. 

I have the same issue with the Facebook like button. I tried using the button with two different plugins, and the behaviour was the same. One of them is the Facebook plugin for wordpress, the other is called Facebook Button Plugin. The guys at the facebook developer forum claim this problem originates in the theme style.

here's a screen shot: 
facebook-bug.jpg

 

I'd appreciate a "custom code" solution...
I have no real knowledge of css coding. 

thanks a lot.

Share this post


Link to post
Share on other sites
mackenzie

Looking at your site I am not seeing a Like button in the middle of the paragraph and when I tested all the Like's and Sends for Facebook they seemed to work for me (I'm in fireFox). Would it be possible to include a screenshot so we can troubleshoot, please?


Mackenzie - PageLines Help Desk

The Centsible Family - Writer, Photographer and Coffee Addict

---------------------------------------------------

Kindly search this forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

Share this post


Link to post
Share on other sites
yoavtaler

Thanks.

My like buttons are before and after a post/page's content. I checked it both on latest chrome and safari on mac. The likes and sends are working, but the comment box is cut.  here's a full screenshot:

facebook-bug1-1024x640.jpg

thanks.facebook-bug1-1024x640.jpg

Share this post


Link to post
Share on other sites
Jenny

Please visit PageLines -> Site Options -> Custom Code -> Custom CSS/LESS and add the following to the box:

 

body .entry_content iframe {
    max-width: 617%;
}

Hope that helps!


Jenny :: Web designer at Simple Mama (follow me at @simplemamacom)

Check out Share Me, a social sharing add-on for DMS that is super simple to set up.

Share this post


Link to post
Share on other sites
yoavtaler

Thanks Jenny. 
Well, it moves the whole comment box to the left and shows it completely. Which is good and functional.
Stil - Isn't there a "cleaner" solution? like making it appear where it should be? I'm no expert on css, but clearly something is overlapping the comment box.

 

Share this post


Link to post
Share on other sites
Rob

Hi,

 

I think the solution Jenny provided is the best for the present.  You're able to test other CSS options using Firebug for Firefox or Chrome's Inspection Tool.


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Similar Content

    • chamois_blanc
      By chamois_blanc+
      Hello,
      Shouldn't the image PL5 component be using the srcset/picture css directives to pick the correct size for an image? or it does already and I don't know how to use it? Thank you for any advice or enlightenment.
    • werdnags
      By werdnags+
      I know this does not have anything to do with Pagelines directly but this is happening on my PL5 site.  At the bottom of my blog posts I have put the Facebook Comments Plugin and it works well but when people are leaving comments they are the same for every post.  Does anyone have any idea on how to solve this so the comments are for the post they are on.  Does that make sense? Ha!
      Thanks for any ideas folks.
    • Dan Haddock
      By Dan Haddock
      Plugins Active and installed: 
      Akismet Anti-Spam
      Coming Soon Page & Maintenance Mode by SeedProd
      Contact Form 7
      Cookie Law Info
      DMS Professional Tools  
      Enhanced Media Library  
      Flamingo
      Google Analytics for WordPress by MonsterInsights
      Google XML Sitemap
      Jetpack by WordPress.com
      Legull 
      Loginizer   
      MailChimp for WordPress
      PageLines Updater    
      Schema App Structured Data 
      Sucuri Security - Auditing, Malware Scanner and Hardening
      Uber reCaptcha    
      Yoast SEO
      Wordpress Version: 4.8.1
      Pagelines Version: 2.2.4
       
      Good Evening/Afternoon or Morning, 
      I am running into a problem with CSS styling not applying inside of most browsers (Safari, Firefox) when I am logged in to wordpress, and all browsers that I have tested when I am logged off and the site has been made public (Chrome, Firefox and Safari).
      As a result, I have managed to identify the probable cause. It looks as though these browsers are refusing to render my sites compiled CSS file due to it being a HTTP URL rather than HTTPS.
      I have attempted to change this URL to HTTPS in my browser, however it brings back an ERROR: File not found page - https://www.shortfilmblog.com/wp-content/uploads/pagelines/compiled-css-core-1505847507.css
      What would you suggest in this regard? Would this be resolvable from your end?
      Happy to provide any further details required.
    • Borries
      By Borries+
      I know this is not an easy problem. Maybe there is a easy solution.
      I have tryed to uses the existing solution, that I have found in the forum
      I changed the colours of my nav (simple nav) and the hover effect (a. hover).
      I really tryed to highlight the active/used link in the nav but I cant figure it out.
      I want it to be black when active.
      Any help would be appreciated. Thanks.
      http://www.marcborries.de  nav link: "Sinn & Selbst" 
    • Michael Kummer
      By Michael Kummer+
      Hi guys,
      every since Chrome introduce scroll anchoring (see chrome://flags) blog posts on my page start scroll automatically as soon as the user scrolls down a bit. It is super annoying and I don't know exactly what triggers the incompatibility with Chrome's latest feature that is supposed to improve usability.
      Since I don't know what causes it (Pagelines, or a Plugin), I would like to disable the feature using a CSS override that Google describes as follow:
      "Scroll anchoring aims to be the default mode of behavior when launched, so that users benefit from it even on legacy content. A CSS property overflow-anchor can disable scroll anchoring in part or all of a webpage (opt out), or exclude portions of the DOM from the anchor node selection algorithm. This property supports the following values when applied to an element E:
      overflow-anchor: auto (the default value) declares that the DOM subtree rooted at E is eligible to participate in the anchor node selection algorithm for any scrolling box created by E or an ancestor of E. overflow-anchor: none declares that the DOM subtree rooted at E is not eligible to participate in the anchor node selection algorithm for any scrolling box created by E or an ancestor of E." Do you guys happen to know how to use that property with the ROOT element so it applies to the whole page?
      Thanks
      Michael 
×