Jump to content
Sign in to follow this  
jguerrieri

Space Between Fixed Top Navbar And Header

Recommended Posts

jguerrieri    1
jguerrieri

There is a sliver of space between the header and the top fixed navbar. How can I eliminate that? If I don't have the navbar active, it goes away. http://fitwit.rizzle.org/

Share this post


Link to post
Share on other sites
catrina    103
catrina

I'm trying to select the space with Firebug but it can't seem to find it. It seems to be a part of the page canvas (the light grey area background). I think the header needs to be brought up a bit to cover that space. You can adjust the header's top margin with Custom CSS: http://www.pagelines.com/wiki/Custom_CSS. Also, see here for guidance with the margin attribute: http://www.w3schools.com/css/css_margin.asp


Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites
jguerrieri    1
jguerrieri

Ok - so where would I put this? In another line on the Css/Less rules page? Right now it looks like this:

body{}

.plbrand-text {display: none;}

#header {background-color:black}

I tried to do "margin:100px 50px;" but nothing happened. Suggestions?

Share this post


Link to post
Share on other sites
batman    389
batman

Hi jquerrini

You can try add


body.fixed_width #page {padding-top: 0px;}


#header { margin-top: -10px;}


You can change #px as you like


Life is too short to remove USB safely ...

Share this post


Link to post
Share on other sites
jguerrieri    1
jguerrieri

Hi jquerrini

You can try add


body.fixed_width #page {padding-top: 0px;}


#header { margin-top: -10px;}


You can change #px as you like

Batman! that's twice now that you've helped me. Thanks so much. I don't even know what any of this is or what I'm doing messing with css stuff, so it's nice to get specific help. Wish I could help someone too, but I really don't know what I'm doing. Thanks!

  • Like 1

Share this post


Link to post
Share on other sites
Rob    547
Rob

Very happy Batman helped you. He's fantastic!

Try adding this to Custom Code > CSS Rules:


.navbar.pl-color-grey {

    background-color: #F1F1F1;

    background-image: -moz-linear-gradient(center top , #FFFFFF, #DCDCDC);

    background-repeat: repeat-x;

    border-top: 3px solid #DCDCDC;

    color: rgba(0, 0, 0, 0.5);

}


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
batman    389
batman

Hi Rob

Many thanks..... (he´s fantastic)

wpml_rose.gif


Life is too short to remove USB safely ...

Share this post


Link to post
Share on other sites
Danny    1,327
Danny

The topic was marked as resolved. However, if you require further assistance, simply reply here and the topic will re-open.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
bluecloud    3
bluecloud

Thank you for this fix, I was looking for this one too.

But in mobile view the navbar gets too small with this fix. How do I fix this?

Share this post


Link to post
Share on other sites
Danny    1,327
Danny

@Blue Cloud

 

Can you create a new topic please and provide a screenshot of your issue as well as more information.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Similar Content

    • janpeeters
      By janpeeters+
      Over the last month I had extensive communications with the developer of the (premium) Anything Boxes section (in Pagelines store) (Adam Munns) and the developer of the WP Polylang Multilingual plugin (Frederic Demarle).
       
      This was because the following problem occurred:
      Anything Boxes showed all posts of two languages (Dutch and English) on the respective static frontpages for each language. It should of course have filtered posts for Dutch language on the Dutch frontpage and English on the English frontpage.
       
      The solution to this problem was simple in the end. When duplicating a page for use in another language the settings for Anything Boxes were not copied to the new page and I should have set these settings manually again on the new page. I wasn't aware of this, but it makes sense. Because of this the pages didn't know how to differentiate between posts from different languages.
       
      The dev of Polylang told me that Polylang is currently smart enough to synchronize metas like Featured images and page templates but it does not work out of the box with metas created by plugins and themes but (according to Frederic) it is rather easy to add them in the list using the filter 'pll_copy_post_metas'.
      He mentions that he is not sure that these 'PageLines Meta Settings' are stored in post meta but that would make sense according to him. He asks if the Pagelines dev team will be interested to support this feature in the future.
       
      I'm also wondering if you will consider adding Polylang translation support for manually editable strings like the 'Read more…' strings in Pagelines Settings.
       
      Well that's of course up to you but I thought to let you know to be able to take this into consideration. I also post this for other users in case they experience the same kind of trouble and are looking for an answer.
       
      Best regards,
      Jan Peeters
    • bankrollbuilder
      By bankrollbuilder
      I used a custom hook to put a banner ad in my header. It works but its not in the right position. it is centered and above my logo and I would like to float it to the right of my logo in the header. heres the link: http://shaboopie.com/shaboopie-wp/free-logos-pg1/

      thanks.

      Dan B.
    • starlit
      By starlit
      Can one have two hero sections on one page?

      I want a landing page which leads/advertises two subpages.

      Or is there another option?

      Please help.

      THANK YOU
    • hutruk
      By hutruk
      Hi!

      I am using the shortcodes for tabs, as described in the documentation.

      When I insert the following code:


      [pl_tabs][pl_tabtitlesection type="tabs"] [pl_tabtitle number="1"]Title 1[/pl_tabtitle] [pl_tabtitle number="2"]Title 2[/pl_tabtitle] [/pl_tabtitlesection] [pl_tabcontentsection] [pl_tabcontent active="yes" number="1"] Lorem ipsum dolor sit amet, consectetur adipiscing elit [/pl_tabcontent] [pl_tabcontent number="2"] Lorem ipsum dolor sit amet, consectetur adipiscing elit [/pl_tabcontent] [/pl_tabcontentsection] [/pl_tabs]

      I get a strange output (in the attachment).

      Any ideas?

      Thanks in advance!

    • MooiWeb
      By MooiWeb
      Hello,

      I would like to align my qtranslate with my breadcrumb so that the flags are on the same hight.
      I'm aware of putting a code in the custom css and tryed severall codes from your site but for now, no succes

      The site i'm working on is http://nieuw.vazdias.nl

      Thx,
      Edwin



×