Jump to content
lmorrell

Features Section: Open In New Tab

Recommended Posts

lmorrell    0
lmorrell

Hi,

Sorry to bother you on the weekend but please can you tell me; is it possible to make the features open in new tab when the link is clicked? I may have missed it but can't find anywhere how to do it.

Cheers,

Lesley

Share this post


Link to post
Share on other sites
lmorrell    0
lmorrell

Thanks bat learning, not sure what it means, i guess the answer is that it cant be done. I will wait to see wht the 'team' have to say before I delete it from my site though.

Cheers

Share this post


Link to post
Share on other sites
Danny    1,327
Danny

Hi,

At this moment in time, its not currently possible to have the link open in a new tab/window. However, it has been added to our tracker system. If you would like this functionality now, you will need to contact one of our Pros.

http://www.pagelines.com/pros/

  • Like 1

Please search our forums, before posting!

Share this post


Link to post
Share on other sites
Simon    247
Simon

Feature was added in 2.3.1 there is a filter now pagelines_feature_target

Share this post


Link to post
Share on other sites
lmorrell    0
lmorrell

Thank you Simon

I am sorry but I am not sure how to impliment this. Any further instructions would be apreciated.

Share this post


Link to post
Share on other sites
lmorrell    0
lmorrell

Hi, can anyone help with this further?

Cheers Lesley

Share this post


Link to post
Share on other sites
Simon    247
Simon

Hi, yea the filter is actually pagelines_features_target, i made a typo on the old mobile wink.png

Anyway, heres a snippet you can add to customize functions.php, or a child themes functions.php:

 

 


 

add_filter( 'pagelines_features_target', function() { return 'target="_blank"'; } );
 

 

  • Like 1

Share this post


Link to post
Share on other sites
lmorrell    0
lmorrell

Super Fab! thanks. works prefectly.

And my next question is................................

dont worry I'll start another topic

Thanks again

Lesley

Share this post


Link to post
Share on other sites
mackenzie    12
mackenzie

The topic was marked as resolved.


Mackenzie - PageLines Help Desk

The Centsible Family - Writer, Photographer and Coffee Addict

---------------------------------------------------

Kindly search this forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

Share this post


Link to post
Share on other sites
nickod26+    0
nickod26

Hey Simon

I have tried placing this code and it keeps giving me an error. You got any ideas why?

Cheers

Nick

Hi, yea the filter is actually pagelines_features_target, i made a typo on the old mobile ;)

Anyway, heres a snippet you can add to customize functions.php, or a child themes functions.php:


add_filter( 'pagelines_features_target', function() { return 'target="_blank"'; } );

Share this post


Link to post
Share on other sites
Danny    1,327
Danny

Nick, this topic has been set to resolve, as the question the OP asked was answered. If you're having issues with the code, please reply to the topic, where I gave you the link please, you most likely haven't added it to the correct location.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Similar Content

    • cstreeting
      By cstreeting
      Hello,
       
      The site: www.wallacks.com
       
      I have added this code snippet to functions.php in my child theme:
       
      add_filter( 'pagelines_features_target', function() { return 'target="_blank"'; } );
       
      The Features' link does not open in a new target.
       
      Could a tech help? We are using v.2.4.2 (where that feature is included).
       
      Thank you,
       
      Chantale
    • janpeeters
      By janpeeters+
      Over the last month I had extensive communications with the developer of the (premium) Anything Boxes section (in Pagelines store) (Adam Munns) and the developer of the WP Polylang Multilingual plugin (Frederic Demarle).
       
      This was because the following problem occurred:
      Anything Boxes showed all posts of two languages (Dutch and English) on the respective static frontpages for each language. It should of course have filtered posts for Dutch language on the Dutch frontpage and English on the English frontpage.
       
      The solution to this problem was simple in the end. When duplicating a page for use in another language the settings for Anything Boxes were not copied to the new page and I should have set these settings manually again on the new page. I wasn't aware of this, but it makes sense. Because of this the pages didn't know how to differentiate between posts from different languages.
       
      The dev of Polylang told me that Polylang is currently smart enough to synchronize metas like Featured images and page templates but it does not work out of the box with metas created by plugins and themes but (according to Frederic) it is rather easy to add them in the list using the filter 'pll_copy_post_metas'.
      He mentions that he is not sure that these 'PageLines Meta Settings' are stored in post meta but that would make sense according to him. He asks if the Pagelines dev team will be interested to support this feature in the future.
       
      I'm also wondering if you will consider adding Polylang translation support for manually editable strings like the 'Read more…' strings in Pagelines Settings.
       
      Well that's of course up to you but I thought to let you know to be able to take this into consideration. I also post this for other users in case they experience the same kind of trouble and are looking for an answer.
       
      Best regards,
      Jan Peeters
    • bankrollbuilder
      By bankrollbuilder
      I used a custom hook to put a banner ad in my header. It works but its not in the right position. it is centered and above my logo and I would like to float it to the right of my logo in the header. heres the link: http://shaboopie.com/shaboopie-wp/free-logos-pg1/

      thanks.

      Dan B.
    • starlit
      By starlit
      Can one have two hero sections on one page?

      I want a landing page which leads/advertises two subpages.

      Or is there another option?

      Please help.

      THANK YOU
    • hutruk
      By hutruk
      Hi!

      I am using the shortcodes for tabs, as described in the documentation.

      When I insert the following code:


      [pl_tabs][pl_tabtitlesection type="tabs"] [pl_tabtitle number="1"]Title 1[/pl_tabtitle] [pl_tabtitle number="2"]Title 2[/pl_tabtitle] [/pl_tabtitlesection] [pl_tabcontentsection] [pl_tabcontent active="yes" number="1"] Lorem ipsum dolor sit amet, consectetur adipiscing elit [/pl_tabcontent] [pl_tabcontent number="2"] Lorem ipsum dolor sit amet, consectetur adipiscing elit [/pl_tabcontent] [/pl_tabcontentsection] [/pl_tabs]

      I get a strange output (in the attachment).

      Any ideas?

      Thanks in advance!

×