Jump to content
Beny Schonfeld

Css Parse Errors & Unresponsive Css

Recommended Posts

Beny Schonfeld

Hi there,

I upgraded from PL 2.3.3 to 2.3.4 this morning and now I'm getting some weirdness....

1. I'm getting the following error:

"PageLines Custom LESS/CSS error.

parse error: failed at `font-family: \"Century Gothic\", \"Helvetica Neue\", Helvetica, Arial, sans-serif; ` line: 970"

The weird thing is that when you look at line 970 it does not have that font-family instruction... It's actually a box-shadow instruction... Besides, that line of code has been there for weeks and never gave me an error....

2. The other issue (much bigger issue) is that none of the new CSS I'm adding is making any changes on the elements I'm targeting (I'm just trying to add a margin right now... nothing complex!)

How do I downgrade to 2.3.3 again please?!?


Beny Schonfeld

Appeando.com

On Twitter: @appeando

On Facebook: http://facebook.com/appeando

Share this post


Link to post
Share on other sites
ggusd

Hello, I also have this issue and would also like to know how to downgrade.

Share this post


Link to post
Share on other sites
Beny Schonfeld

I just tried to simply change the color of <h3> and nothing... The css is not producing any changes!

Guys, I need I link to the PL version 2.3.3 ASAP!

From my dashboard it's not available. And I need to finish this website today!!!!

Thx


Beny Schonfeld

Appeando.com

On Twitter: @appeando

On Facebook: http://facebook.com/appeando

Share this post


Link to post
Share on other sites
Simon

How about paste us the CSS you put into the custom CSS area.

Share this post


Link to post
Share on other sites
Beny Schonfeld

How about paste us the CSS you put into the custom CSS area.

There's a lot of CSS... but I was trying to add a margin to an element, simple stuff and no matter how I tried, it wouldn't take...

So then I tried this:


.page-id-31 div.entry_content h3 {

color: #7E60C4 !important;

}

And nothing... it didn't change the color (from gray to purple...). And BTW, when I inspect the <h3> using firebug, the instruction to change the color to purple doesn't even show up... It's like it never makes it from the Pagelines Custom CSS settings to the live page (yes, I reloaded the page, I emptied cache as well. Nothing).

That's when I started suspecting it might have to do with the update...

If you give me a link so I can download version 2.3.3 again, I'll install it and try again, and let you know if it resolved the issue.

Please provide me that link asap... I haven't been able to do and CSS work today on that site and I'm suposed to finish it today...

Please, please, pretty please... give me a link with the download...

Thanks

Beny


Beny Schonfeld

Appeando.com

On Twitter: @appeando

On Facebook: http://facebook.com/appeando

Share this post


Link to post
Share on other sites
Simon

You can add CSS to the customise plugins style.css and not use the less compiler

Looks to me like something in your code is escaping be it a quote or double quote. But I can't tell as you wouldn't paste it.

I won't have any Internet til tomorrow as I'm not at home to upload an older version but it will be the same as the less compiler has not been updated.

Share this post


Link to post
Share on other sites
James B

Hi there, do you see a button at the top of your site in the admin bar saying 'flush LESS', if you do please press it. This will flush the LESS errors and correct the code.


Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites
Beny Schonfeld

You can add CSS to the customise plugins style.css and not use the less compiler

Looks to me like something in your code is escaping be it a quote or double quote. But I can't tell as you wouldn't paste it.

I won't have any Internet til tomorrow as I'm not at home to upload an older version but it will be the same as the less compiler has not been updated.

I have over 3,000 lines of CSS... and all of it was working fine yesterday. Even this morning...

The only thing I tried to do today after the update was this:


.page-id-31 div.entry_content h3 {

color: @purple !important;

}



.about-page-optin form .text {

margin-top: 15px;

margin-bottom: 5px;

}

That's all... Then I tried instead of targeting that .text selector to target the selector above and add a margin-bottom, and the selector below to add a margin-top. But nothing... And BTW, I know the above .text selector works because all the instructions I wrote prior to the update are working... The full LESS code I'm using for that form is:

.about-page-optin {

	background: @grayLighter;

	border: 1px solid @grayLight;

	.roundCorners;

	form {

		text-align: center;

		margin: 15px 30px 30px 30px;

		h3 {

			margin-top: 15px;

			color: @purple;

			.simpleShadow (@white);

		}

		p {

			.simpleShadow (@white);

		}

		.text {

			width: 40% !important;

			min-width: 380px;

			padding: 10px 5px !important;

			margin-top: 15px !important;

			margin-bottom: 15px !important;

			height: 37px;

			background-color: #ffffff;

			color: #333333;

			border: 1px solid #a2a2a2;

			font-size: 13px;

			box-shadow: 0 0 5px #bababa !important;

			-moz-box-shadow: 0 0 5px #bababa !important;

			-webkit-box-shadow: 0 0 5px #bababa !important;

			border-radius: 4px !important;

			-moz-border-radius: 4px !important;

			-webkit-border-radius: 4px !important;

			background-image: url("http://www.designsbyfelicia.com/wp-content/uploads/2012/05/1337200790_email.png");

			background-repeat: no-repeat;

			background-position:96% 30%;

			background-size: 26px;

			&:focus {

				border: 1px solid #595959;

				box-shadow: 0 0 5px #e47532 !important;

				-moz-box-shadow: 0 0 5px #e47532 !important;

				-webkit-box-shadow: 0 0 5px #e47532 !important;

			}

		}

		input.submit {

			#buttonStyle > .orangeWithShadow;

		}

	}

}

Everything I've tried today as far as CSS is not producing any changes... The above code is being used right now, you can see the page here: http://designsbyfeli...icia-weinstein/

You'll notice that the <h3> is still in gray, and the .text field in the form doesn't have the 15px top margin and 5px bottom margin...

I'll try pasting the CSS into the customize plugin > style.css and let you know how that goes...

It's also worth noting that I don't write my LESS in the Pagelines compiler... I write my LESS in Coda, compile using the LESS app for Mac, then copy the compiled CSS into the Pagelines LESS/CSS compiler. The LESS app for mac gives me error alerts if there are any, and it is NOT giving me any errors... everything seems to be fine with the code.

Can anybody just email me a zip file with Pagelines version 2.3.3? It would be very straightforward to re-install it and assess if this is actually a bug with the update...

Click here to email me the file please!!!! It's really urgent.

I'll let you know about pasting the CSS to the customize plugin...


Beny Schonfeld

Appeando.com

On Twitter: @appeando

On Facebook: http://facebook.com/appeando

Share this post


Link to post
Share on other sites
Beny Schonfeld

You can add CSS to the customise plugins style.css and not use the less compiler

I deleted my CSS code from the pagelines compiler and pasted it into the customize plugin > style.css...

The code is working fine when I do that.

What does that mean?


Beny Schonfeld

Appeando.com

On Twitter: @appeando

On Facebook: http://facebook.com/appeando

Share this post


Link to post
Share on other sites
Beny Schonfeld

Hi there, do you see a button at the top of your site in the admin bar saying 'flush LESS', if you do please press it. This will flush the LESS errors and correct the code.

I do not see that button anywhere in my admin bar...


Beny Schonfeld

Appeando.com

On Twitter: @appeando

On Facebook: http://facebook.com/appeando

Share this post


Link to post
Share on other sites
James B

Hi there,

I've pasted the error line you're getting in and got the compile same error. LESS doesn't seem to like quotes. Please find that line in the css and remove the quotes. As soon as I removed the quotes the error resolved.

{font-family: Century Gothic, Helvetica Neue, Helvetica, Arial, sans-serif;}

http://imgur.com/5QB8X - Less Flush button


Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites
Beny Schonfeld

Hi there,

I've pasted the error line you're getting in and got the compile same error. LESS doesn't seem to like quotes. Please find that line in the css and remove the quotes. As soon as I removed the quotes the error resolved.

{font-family: Century Gothic, Helvetica Neue, Helvetica, Arial, sans-serif;}

I'll give it a try... though I find it strange that it's the first time I'm getting that error even though that code has been there for months...

I'll let you know how it goes. As for the "flush less" button, still not showing up for me: http://awesomescreenshot.com/043kf1443


Beny Schonfeld

Appeando.com

On Twitter: @appeando

On Facebook: http://facebook.com/appeando

Share this post


Link to post
Share on other sites
Beny Schonfeld

Hi there,

I've pasted the error line you're getting in and got the compile same error. LESS doesn't seem to like quotes. Please find that line in the css and remove the quotes. As soon as I removed the quotes the error resolved.

Hey James, I removed the quotes from the font-family instructions... that got rid of that error, but now it's giving me another one. The new error is also because of the quotes, but it's on a mixin that addresses IE gradient issues so I don't dare remove it, especially because I've been using all of this code for months without a single issue.

These issue started today, as soon as I updated from 2.3.3 to 2.3.4...

Now, here's something else interesting (in a very scary way!)

When I paste my compiled CSS code in the pagelines compiler, a lot of the instructions are NOT styling the page as they should... see pic here --> http://awesomescreenshot.com/0d1kf1ac4

But when I paste it into the Pagelines Customize Plugin > style.css the page looks as it should ---> http://awesomescreenshot.com/05bkf1r73

To be clear: the above pics are EXACTLY the same CSS code...

There's something definitely funky with this latest update...


Beny Schonfeld

Appeando.com

On Twitter: @appeando

On Facebook: http://facebook.com/appeando

Share this post


Link to post
Share on other sites
hopeofglory

I agree with you. I am also having lots of compile errors after I had upgraded to the latest version yesterday and its making my website look like a test environment :(. When you say you paste it in Pagelines Customize Plugin > style.css, is this via the editor?

Share this post


Link to post
Share on other sites
Simon

We decided to run the CSS through Wordpress kses data validation which all options should be ran through anyway.

Reason for this was simple, people were adding script tags Javascript and HTML into the CSS box rendering wp-admin completely inaccessible!

Only drawback it seems is kses is escaping quotes now and that's also breaking the less.

So I'm gonna have to find a middle ground.

Share this post


Link to post
Share on other sites
Beny Schonfeld

I agree with you. I am also having lots of compile errors after I had upgraded to the latest version yesterday and its making my website look like a test environment :(. When you say you paste it in Pagelines Customize Plugin > style.css, is this via the editor?

Yes. Go to plugins > editor then select "pagelines customize" from the menu on the top right of screen. Then click on the style.css file. Enter your CSS there and save.


Beny Schonfeld

Appeando.com

On Twitter: @appeando

On Facebook: http://facebook.com/appeando

Share this post


Link to post
Share on other sites
hopeofglory

Done this but I have lost lots of my customization as a result of this. Great job pagelines

Share this post


Link to post
Share on other sites
Beny Schonfeld

Done this but I have lost lots of my customization as a result of this. Great job pagelines

I forgot to mention... You probably did this but just in case...

When you add your CSS code to the pagelines customize plugin > style.css make sure you then remove any CSS you had in the pagelines less/CSS compiler...


Beny Schonfeld

Appeando.com

On Twitter: @appeando

On Facebook: http://facebook.com/appeando

Share this post


Link to post
Share on other sites
hopeofglory

Yes I did remove from pagelines less/CSS compiler but no difference

Share this post


Link to post
Share on other sites
Simon

So you removed the font family line from the CSS area and it's still giving the same error about font family?

Share this post


Link to post
Share on other sites
Simon

The CSS you posted above has quotes in it. Remove the quotes from the image URLs you don't need them

Share this post


Link to post
Share on other sites
Beny Schonfeld

So you removed the font family line from the CSS area and it's still giving the same error about font family?

No. Now it gives me another error from another instruction that has quotes.

But I'm not going to mess around with code that my LESS compiler says is fine. That's just looking for trouble. (All it takes is my fat thumb hitting something and then I'll be looking for that typo for hours...)

Besides if you look at the post above where I share the two screen pics you'll see that when I paste my CSS back into the compiler it's completely screwing up the website.... But when I place the code in the pl customize plugin it works fine.


Beny Schonfeld

Appeando.com

On Twitter: @appeando

On Facebook: http://facebook.com/appeando

Share this post


Link to post
Share on other sites
Simon

If its just CSS your better off having it in the customise plugin anyway

Share this post


Link to post
Share on other sites
hopeofglory

Did manage to resolve the problem by using a custom css plugin and all looks good.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Similar Content

    • IDdigital
      By IDdigital+
      Hi,
      A site of ours irregularly does not finish loading. The page in question is https://rw360.org/grievance-process/
      In Safari, I'll occasionally get the following error:
      [Error] TypeError: undefined is not an object (evaluating 'a.plModel.init')
          (anonymous function) (site.js:5:91)
          i (jquery.js:2:27455)
          add (jquery.js:2:27750)
          ready (jquery.js:2:29819)
          (anonymous function) (site.js:5)
          Global Code (site.js:5:3421)
      This seems to be a bug in PageLines as far as I can tell. Any suggestions or a fix coming?
      Thanks,
    • chamois_blanc
      By chamois_blanc+
      Hello,
      Shouldn't the image PL5 component be using the srcset/picture css directives to pick the correct size for an image? or it does already and I don't know how to use it? Thank you for any advice or enlightenment.
    • Dan Haddock
      By Dan Haddock
      Plugins Active and installed: 
      Akismet Anti-Spam
      Coming Soon Page & Maintenance Mode by SeedProd
      Contact Form 7
      Cookie Law Info
      DMS Professional Tools  
      Enhanced Media Library  
      Flamingo
      Google Analytics for WordPress by MonsterInsights
      Google XML Sitemap
      Jetpack by WordPress.com
      Legull 
      Loginizer   
      MailChimp for WordPress
      PageLines Updater    
      Schema App Structured Data 
      Sucuri Security - Auditing, Malware Scanner and Hardening
      Uber reCaptcha    
      Yoast SEO
      Wordpress Version: 4.8.1
      Pagelines Version: 2.2.4
       
      Good Evening/Afternoon or Morning, 
      I am running into a problem with CSS styling not applying inside of most browsers (Safari, Firefox) when I am logged in to wordpress, and all browsers that I have tested when I am logged off and the site has been made public (Chrome, Firefox and Safari).
      As a result, I have managed to identify the probable cause. It looks as though these browsers are refusing to render my sites compiled CSS file due to it being a HTTP URL rather than HTTPS.
      I have attempted to change this URL to HTTPS in my browser, however it brings back an ERROR: File not found page - https://www.shortfilmblog.com/wp-content/uploads/pagelines/compiled-css-core-1505847507.css
      What would you suggest in this regard? Would this be resolvable from your end?
      Happy to provide any further details required.
    • Borries
      By Borries+
      I know this is not an easy problem. Maybe there is a easy solution.
      I have tryed to uses the existing solution, that I have found in the forum
      I changed the colours of my nav (simple nav) and the hover effect (a. hover).
      I really tryed to highlight the active/used link in the nav but I cant figure it out.
      I want it to be black when active.
      Any help would be appreciated. Thanks.
      http://www.marcborries.de  nav link: "Sinn & Selbst" 
    • Michael Kummer
      By Michael Kummer+
      Hi guys,
      every since Chrome introduce scroll anchoring (see chrome://flags) blog posts on my page start scroll automatically as soon as the user scrolls down a bit. It is super annoying and I don't know exactly what triggers the incompatibility with Chrome's latest feature that is supposed to improve usability.
      Since I don't know what causes it (Pagelines, or a Plugin), I would like to disable the feature using a CSS override that Google describes as follow:
      "Scroll anchoring aims to be the default mode of behavior when launched, so that users benefit from it even on legacy content. A CSS property overflow-anchor can disable scroll anchoring in part or all of a webpage (opt out), or exclude portions of the DOM from the anchor node selection algorithm. This property supports the following values when applied to an element E:
      overflow-anchor: auto (the default value) declares that the DOM subtree rooted at E is eligible to participate in the anchor node selection algorithm for any scrolling box created by E or an ancestor of E. overflow-anchor: none declares that the DOM subtree rooted at E is not eligible to participate in the anchor node selection algorithm for any scrolling box created by E or an ancestor of E." Do you guys happen to know how to use that property with the ROOT element so it applies to the whole page?
      Thanks
      Michael 
×