Jump to content
hopeofglory

My Pagelines Homepage File

Recommended Posts

hopeofglory    0
hopeofglory

Hi

I want to make use of the jqFancyTransitions widget but as part of the instruction i need to update my homepage with followings:

<script src="js/jquery-1.4.2.min.js" type="text/javascript"></script>

<script src="js/jqFancyTransitions.1.7.min.js" type="text/javascript"></script>

Which file do I need to edit using the pagelines editor?

Or

How can i insert the slider or feature on the sidebar.

Thanks

Share this post


Link to post
Share on other sites
Simon    247
Simon

You can add custom code to pagelines => site settings => Custom Code => Header Scripts.

Share this post


Link to post
Share on other sites
hopeofglory    0
hopeofglory

Done that but with error on page as follows:

Warning: in_array() expects parameter 2 to be array, null given in /home/content/95/9458495/html/wp-content/themes/pagelines/includes/less.plugin.php on line 2551

Warning: in_array() expects parameter 2 to be array, null given in /home/content/95/9458495/html/wp-content/themes/pagelines/includes/less.plugin.php on line 2551

Warning: in_array() expects parameter 2 to be array, null given in /home/content/95/9458495/html/wp-content/themes/pagelines/includes/less.plugin.php on line 2551

Warning: in_array() expects parameter 2 to be array, null given in /home/content/95/9458495/html/wp-content/themes/pagelines/includes/less.plugin.php on line 2551

Share this post


Link to post
Share on other sites
catrina    103
catrina

It looks like there's a conflict between LESS and the jQuery you're trying to implement.

<script src="js/jquery-1.4.2.min.js" type="text/javascript"></script>[/CODE]

^ Can you try removing this line?


Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites
hopeofglory    0
hopeofglory

Now I am having a problem. I have removed the codes from the custom header and yet the error is still appearing my homepage. How can i remove the error from my homepage

Thanks

Share this post


Link to post
Share on other sites
hopeofglory    0
hopeofglory

hi catrina

just seen your reply, will do that now.

Share this post


Link to post
Share on other sites
hopeofglory    0
hopeofglory

Done that but error still appearing.

Share this post


Link to post
Share on other sites
Simon    247
Simon

You put the code the the wrong box, one is clearly CSS the other is Header Scripts.

Share this post


Link to post
Share on other sites
hopeofglory    0
hopeofglory

The code was added under Headerscripts Code and not CSS

Share this post


Link to post
Share on other sites
hopeofglory    0
hopeofglory

Saw this error:

PageLines Custom LESS/CSS error.

parse error: failed at `.entry_content p:first-child, .post-excerpt > p:first-child { ` line: 1017

Could this also be linked after I had updated my pagelines today before making this change?

Is there a way I can revert back even after removing the code from the header script

Share this post


Link to post
Share on other sites
Simon    247
Simon

Run the CSS through the w3c validation site

Share this post


Link to post
Share on other sites
hopeofglory    0
hopeofglory

Hi

the CSS issue was caused by your upgrade yesterday and that I have fixed but I am still seeing this error above my homepage:

Warning: in_array() expects parameter 2 to be array, null given in /home/content/95/9458495/html/wp-content/themes/pagelines/includes/less.plugin.php on line 2551

Warning: in_array() expects parameter 2 to be array, null given in /home/content/95/9458495/html/wp-content/themes/pagelines/includes/less.plugin.php on line 2551

Warning: in_array() expects parameter 2 to be array, null given in /home/content/95/9458495/html/wp-content/themes/pagelines/includes/less.plugin.php on line 2551

Warning: in_array() expects parameter 2 to be array, null given in /home/content/95/9458495/html/wp-content/themes/pagelines/includes/less.plugin.php on line 2551

How can I remove this. Its getting a bit annoying.

Share this post


Link to post
Share on other sites
hopeofglory    0
hopeofglory

This is even getting more weired. After validating my CSS and w3c validator confirms my CSS is OK, now I am getting more compile error. This time its:

PageLines Custom LESS/CSS error.

parse error: failed at `font-family: 'PT Serif',Georgia,serif; ` line: 1020

But I do not have my CSS up to line 1020 so where is pagelines getting this line from?

Share this post


Link to post
Share on other sites
hopeofglory    0
hopeofglory

Can I get a help here, my site is completely messed up and I am finding this annoying. It appears upgrading too early was a BAD idea

Share this post


Link to post
Share on other sites
Simon    247
Simon

Take the font family line out the quotes break the less compiler if you need a CSS line with quotes add it to the style.css file I mentioned before

Share this post


Link to post
Share on other sites
hopeofglory    0
hopeofglory

This is unbelievable, this was working before now and now everything I have done seems to have been messed up by your recent update.

Where can i download the previous version? Also you are just mentioning the style.css now.

I have had a look at the style.css and can see the following:

* Don't add customizations to this file!

- Customization CSS in PageLines

- Customize PageLines by adding CSS in the settings, child themes, or plugins

- Don't add it here; as it will either get overwritten by updates, and will prevent you from updating at all!

So should I ignore this and add all the custom css in the style.css page?

Share this post


Link to post
Share on other sites
Simon    247
Simon

All wp options have to run through the kses validation filter. Before the CSS box was whitelisted but this allowed people to add HTML Javascript script tags and all sorts into the CSS box then complain when wp-admin was inaccessible and the only resolution was with phpmyasmin. So the latest upgrade I removed the whitelist but now kses is escaping your font quotes and double quotes and the less compiler chokes on it so I need to find a way of blocking all scrips and HTML but allow you to use 1 font line.

This is my personal hell ;)

Share this post


Link to post
Share on other sites
hopeofglory    0
hopeofglory

Thanks for the update. My only concern is if I apply my CSS in style.css then this would be lost on next update in the event I forget to back that up :(.

Is there any alternative to this issue in the meantime.

Thanks

Share this post


Link to post
Share on other sites
Simon    247
Simon

Not the style in the customise plugin or a child theme they never get updated that's the whole purpose of them

Share this post


Link to post
Share on other sites
Denis Ciumbargi    3
Denis Ciumbargi

Done that but with error on page as follows:

Warning: in_array() expects parameter 2 to be array, null given in /home/content/95/9458495/html/wp-content/themes/pagelines/includes/less.plugin.php on line 2551

Warning: in_array() expects parameter 2 to be array, null given in /home/content/95/9458495/html/wp-content/themes/pagelines/includes/less.plugin.php on line 2551

Warning: in_array() expects parameter 2 to be array, null given in /home/content/95/9458495/html/wp-content/themes/pagelines/includes/less.plugin.php on line 2551

Warning: in_array() expects parameter 2 to be array, null given in /home/content/95/9458495/html/wp-content/themes/pagelines/includes/less.plugin.php on line 2551

This also happened to me and now i cannot fix this anymore... All happened when i put in the header script section the script from google custom search engine. Removed that and now the problem remains.


Where there is love, I'll be there.

Share this post


Link to post
Share on other sites
hopeofglory    0
hopeofglory

I did remove the script from the custom header scription section but issue still remained. It appears the recent update caused the whole issue. I ended up installing a customn css plugin which seems to have resolved the issue.

For now I will aviod any further updates.

Share this post


Link to post
Share on other sites
Denis Ciumbargi    3
Denis Ciumbargi

I did remove the script from the custom header scription section but issue still remained. It appears the recent update caused the whole issue. I ended up installing a customn css plugin which seems to have resolved the issue.

For now I will aviod any further updates.

I think it has to do with this update also... Which plugin, i would like to use it....


Where there is love, I'll be there.

Share this post


Link to post
Share on other sites
Rob    547
Rob

Okay, it sounds to me like both of you have a cache plugin running that you've forgotten about. If that's the case, then the solution is to clear the cache to see if the issue goes away since you both removed the code that caused the difficulty.

Simon, in his developer language, is trying to simply say to look over your custom CSS and take out any quotes (single or double) surrounding anything. Personally, I had quotes surrounding a background for my footer and once the quotes were removed, I was able to see the background again.


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
trebord_55    0
trebord_55

Simon, in his developer language, is trying to simply say to look over your custom CSS and take out any quotes (single or double) surrounding anything. Personally, I had quotes surrounding a background for my footer and once the quotes were removed, I was able to see the background again.

Thank you for clarifying this second point. Removing quotes resolved the problem for this newbie.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×