Jump to content
Sign in to follow this  
lyonshall

removal of the date in the url of a post

Recommended Posts

lyonshall    1
lyonshall

Hi

Its probably a very simple answer, but how can i remove the date from my post url?

i.e. http://www.lyonshallnurseries.co.uk/wp/2012/10/19/winter-hardy-pansy-and-viola/

the /2012/10/19/ date seems to always be present on all posts only not pages. I have used wordpress in other websites and not had this issue until i used this fantastic theme

I have looked through the forum, i have looked through my wordpress settings - can't see the wood from the trees!

Appreciate any help

thanks in advance


www.lyonshallnurseries.co.uk

Share this post


Link to post
Share on other sites
batman    389
batman

Hi

You have this type of Permalink Wordpress structure

You can go to

Dashboard > Settings > Permalinks

And change the option.

First please read this

http://codex.wordpress.org/Using_Permalinks


Life is too short to remove USB safely ...

Share this post


Link to post
Share on other sites
James B    436
James B

Hi there, let us know if Batman's answer worked for you.


Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites
lyonshall    1
lyonshall

Thanks, Batman that is great help. I will try tonight and let you know the outcome.


www.lyonshallnurseries.co.uk

Share this post


Link to post
Share on other sites
Rob    547
Rob

A good search-engine optimized permalink is /%post_id%/%postname% resulting in something like yoursite.com/123/this-is-my-post. The bots like it because it gives a unique ID number and the post name in full.


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
lyonshall    1
lyonshall

Batman - you're a star! I took the precaution backed up the site first. Read the link about permalinks. A 1 second click and it works without any problems. Thanks very much.


www.lyonshallnurseries.co.uk

Share this post


Link to post
Share on other sites
lyonshall    1
lyonshall

Rob - good tip, have gone for that one. Thanks


www.lyonshallnurseries.co.uk

Share this post


Link to post
Share on other sites
Rob    547
Rob

The topic was marked as resolved.


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Similar Content

    • David
      By David+
      We are building a long-page scrolling site with Pagelines 5. Our menu is made with # links that go to a container's unique ID, e.g. container_ux7al6g
      This works, but it doesn't look great in the menu. Is it possible to assign a 'nice' # link, e.g. /#solutions ? 
      We used to do this in the DMS2 platform through a workaround, but that doesn't seem to be possible now. 
      Any suggestions? 
    • ipitts
      By ipitts+
      Greetings! 
      We are using Pagelines >> DMS2 theme. We are using the DMS2 Media Box module on several pages throughout our site. The media box includes an image thumbnail with hyperlinked text (below the thumbnail - located in the embedded HTML text editor).  We would like for users to be able to click on the image in addition to the accompanying text. Is there a way to add a hyperlink on the image itself?
      Please see the attached screenshot. You'll see we have "Compatibility Matrix" thumbnail image & text within the "Text & Embedded HTML" section that provides an <a href="...."></a> to direct visitors to another page. 
      We tried to follow this post (http://slickmedia.co.uk/blog/glenns-blog/pagelines-dms-mediabox-add-link/), but it did not help us solve our challenge. 
      Thank you very much for your help,
      Marie Thiele
      Marketing Coordinator, Syn-Apps LLC
      480-355-6822
      mthiele@syn-apps.com
      media box.tiff
    • mnagillum
      By mnagillum+
      As noted elsewhere on the Forum, the Media Box section doesn't have an option to enter a hyperlink to link to another page on my site, ndtest.mamulligan.com. Can someone please advise me on the exact code to use in my child theme (or Jetpack Appearance file) to make the five media boxes (Program Design, etc.) clickable links to the five corresponding areas shown in the menubar? Thanks in advance for any/all help.
       
       
    • saur0
      By saur0
      Hi, 
       
      I have set up a website asolve.it and have another domain name which I wish to use with it asolveit.co.uk, I have set up a domain alias with my hosting provider, but when I visit the site the pagelines images are not visible. Is there anything I can do to resolve this situation.
       
      Thanks,  
    • jharri74
      By jharri74+
      Hello,
       
      Like a lot of people, I have built my wordpress (version 4) website in it's own folder. Not the top level of the hosting server.
       
      The domain was still pointing to the old website also in it's own folder. While i was building the the new website, the IP address/folder(http://s446863904.onlinehome.us/WP) was pointing to the website i was building. I eventually pointed the domain (http://envymeremy.com) here.
       
      Thats when things got a little screwed up. Especially when I made the change in wordpress general settings.
       
      WordPress Address (URL): http://s446863904.onlinehome.us/WP
      Site Address (URL): http://envymeremy.com(formerly the same as above)
       
      So after fixing the 505 and 404 issues (editing the .htaccess file in top level of this website) that now follow changing the url, the first thing i noticed was that the fonts weren't embedding.
       
      In my child theme's css file, i had to change:
       
      @import url("../dms/style.css");
      @import url("fonts/stylesheet.css");
       
      TO:
       
      @import url("../dms/style.css");
      @import url('http://envymeremy.com/wp-content/themes/jayharry_theme-child/fonts/stylesheet.css');
       
      The pagelines font/symbols  for dropdown and slider arrows aren't loading.

       
      So now whats happening is, when I launch the dms editor, it goes to a page that "does not exist". I'm thinking thats because the homepage was http://s446863904.onlinehome.us/WPand is now http://envymeremy.com/.
       
      When i click on the links in the navigation (Home, about us, etc), it takes me to the page, but I don't get the dms editor with options to add anything, edit the sections or anything. Just the page as i would see it if i were not logged into wordpress.
       
      I'm using:
      wordpress 4
      DMS 2 with a child theme
      hosting: 1and1.com plan: 1&1 Unlimited
       
       
       
       
       
       
×