Sign in to follow this  
Followers 0

Resolved PHP Fatal error: Class 'PageLinesNav' not found

5 posts in this topic


Running Wordpress 3.4.2 Tried to update Pagelines Framework to the latest version. However something went wrong and the site disappeared also lost access to Admin pages with an internal server error.

Looked at the logs and saw this error:

[19-Oct-2012 13:40:29] PHP Fatal error: Class 'PageLinesNav' not found in /home/hinelega/public_html/wp-content/themes/pagelines/sections/brandnav/section.php on line 18

So I physically disabled Pagelines theme by login in via FTP and adding XXX's into the pagelines directory name forcing the install to revert to Twenty Eleven theme, Admin pages came back up as did the site in Twenty Eleven theme, so data and Wordpress install seems fine.

Restored Pagelines framework from backup, however whenever I try to Activate the Framework I get the same error.

Deactivated all Plugins, but again same error.

Tried restoring the database from the backup and all was good with the database, but again no change.

The site is, (however I am blocking access to it right now). I am now not sure what update had last been done which I restored from my backup. However I was definitely updating to the latest Pagelines update when the error occurred. I'll also mention I am using a child theme with this install in case that is a factor.

Any ideas.



Share this post

Link to post
Share on other sites

Been struggling with this for hours now. Having done some Google searches, this error message is popping up in a lot of Error Logs, so seems to be something fairly common. However I can't find any mention of it in the Technical Support forums bar a few threads that closed without identifying the cause.

Am I missing something really obvious with this? works fine in any other theme, but as soon as I try to activate Pagelines Framework it breaks the site and throw up the error message in my earlier post. As soon as I force it back into the Twenty Eleven theme all is OK. Any help, suggestions/ advice would be gratefully received!!!



Share this post

Link to post
Share on other sites

Hi there, I'm not sure what the error messages means but it sounds as if a file could be corrupted inside your original pagelines theme. I'd say the best bet is to download a fresh version of Pagelines and re-install. Please switch back to the 2011 theme and then delete the original PL theme.

Go to and download a zip file of the latest version of the Framework from the 'your products' tab. Install into your wp dashboard through appearance>themes as a new theme. Hopefully this will resolve the issues you've been having.

If you're still receiving error messages please enable the wp-debug in wp-config.php and provide us with a full error report from this.

Share this post

Link to post
Share on other sites

Hi James,

Worked a treat!! For anyone else that gets this issue, James's suggestion worked perfectly. I backed up my child theme and just to be sure deleted everything Pagelines related, plugins etc. Reinstalled Pagelines and all related plugins and sections, then added my child theme back in and it worked.

I'm a little concerned my backups from just before the update event and a week before exhibited the same issue when restored to the server. However the fresh install has fixed it!

Sidebars and footer have defaulted but thats a minor concern compared to a broken site!!

I'm a happy man.

Thanks James, your help and simple suggestion is very much appreciated.

This can be marked as resolved.



Share this post

Link to post
Share on other sites

The topic was marked as resolved.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
Followers 0

  • Similar Content

    • Less.legacy.php error
      By station16
      I installed DMS for a new site and got an error message on install and when I install any plugin.
      Warning: Invalid argument supplied for foreach() in /nfs/c09/h04/mnt/208781/domains/ on line 818
      I installed the latest DMS
      Please advise. I'm now having issues getting any plugins to work. Not sure what to do next.
    • PL-Nextbox issue
      By abuzzelli+
      I'm trying to translate custom PHP templates that a developer coded into pagelines templates. I'm trying to paste the php into a nextbox, but I'm getting this error:
      Looks like your NextBox PHP resulted in an error :/
      Here's the code. Not sure what I'm doing wrong.
       * The template used for displaying page content in front-page.php

          <article id="post-<?php the_ID(); ?>" <?php post_class(); ?>>
              <header class="entry-header">
                  <?php if ( ! is_page_template( 'page-templates/front-page.php' ) ) : ?>
                      <?php the_post_thumbnail(); ?>
                  <?php endif; ?>
                  <h1 class="entry-title"><?php the_title(); ?></h1>

              <?php get_template_part( 'content', 'vehicle-gallery' ); ?>

              <div class="entry-content">
                  <?php the_content(); ?>
                  <?php wp_link_pages( array( 'before' => '<div class="page-links">' . __( 'Pages:', 'twentytwelve' ), 'after' => '</div>' ) ); ?>
              </div><!-- .entry-content -->
              <footer class="entry-meta">
                  <?php edit_post_link( __( 'Edit', 'twentytwelve' ), '<span class="edit-link">', '</span>' ); ?>
              </footer><!-- .entry-meta -->
          </article><!-- #post -->
    • PHP Loading Issue
      By mnos
      I have a 'common' PHP Loading Issue.
      It happens, because therewas a mistake in the PHP i added to the PL-Nextbox.
      The problem is... the PL-Nextbox and the PHP is in the header of the page... to every page I go (Except wp-admin/dashboard) I get this error.
      I have tried to deactivate/uninstall the plugin, but cant deleted the box. So each time I activate/reinstall the plugin, it comes back.
      Any way, advice in how to solve it?
      All plugins are up to date.
    • Anyway to add php include?
      By jason.
      Website URL:
      Framework Version: DMS 1.1.1
      WordPress Version: 4.1.1
      Plugins in Use: Custom Sidebars, Post Duplicator
      Server/Host: Linux somethingOrOther/ASmallOrange
      Ok, this is driving me up the wall. Ready to start breaking stuff :)
      I can't seem to add a php include to grab a piece of code. I have a formatted email subscription box that I want to call from within a page. I've been trying and trying for hours now and can't get anything to work.
      Here's my code. It's in a textbox section:
      <div class="signupBox"><h5>Hungry for more?</h5> More articles, coming right up. Punch in your email below and we'll let you know as soon as they're ready to devour. </div> <?php get_template_part( 'emailBox ' ); ?> <?php include ( 'emailBox.php' ); ?> <?php include 'emailBox.php'; ?> <?php include ($_SERVER['DOCUMENT_ROOT'].'/emailBox.php'); ?> The text looks great, the php stuff doesn't work. None of them.
      I can't see any errors, and it looks like Pagelines adds comment tags around the php when it's rendered! Yikes!
      When I view the page source they all look like this:
      <!--?php get_template_part( 'emailBox ' ); ?--> Really frustrating.
      Everything was going along swimmingly and now I'm growing gray hairs faster than your grandma.
      Any idea how I can add a simple php include?
    • Help! White page - PHP error. Can't access site.
      By verush
      Hi Guys!
      I installed the Pageline Customize Plugin in order to change the number of posts in the masonic grid. I tried adding a code to the fnctions.php file of the plugin, at the bottom. It didn't work, so I erased it but with it also a part of the PHP code. The site went blank, every page, even the login. Can't go back, I was told I should try access the place where the issue happened through the database but I don't think I have the necessary skills to resolve this.
      I am not very familiar with PHP either and obviously shouldn't have touched there in the first place. Lesson learned.
      What would you advice me to do in order to get my site back? Can you help?
      Thank you!