Jump to content
Sign in to follow this  
kmcshanethemcshanefirmcom

ECOPro Twitter Messages Not Available

Recommended Posts

kmcshanethemcshanefirmcom
http://paduiblog.com on the right you will see the greeting text and the twitter feed that is not working. It has been like this for about 5 days now. We have twitter updates multiple times per day.

Share this post


Link to post
Share on other sites
cmunns

We've had reports of this before although it usually comes back into service. I know that Twitter does place a limit on API requests per day but I'm not sure if this is related. It worked prior to five days ago, correct?...and I for good measure try clearing your cache.

Share this post


Link to post
Share on other sites
kmcshanethemcshanefirmcom

No we just installed it five days ago and it hasn't worked from the start. And I have cleared the cahce... no luck.

Share this post


Link to post
Share on other sites
bryan-hadaway

Have you re-entered your Twitter account info to double check it's correct? Also, are you using the latest version of your theme and WordPress? Thanks, Bryan

Share this post


Link to post
Share on other sites
kmcshanethemcshanefirmcom

Yes the account info is correct. If you go to my site it hyperlinks to the twitter account but does not display messages. I am using EcoPro 1.2.4 and WP 3.0.0 I am using this on a this on a Windows server and I have another site http://thetruthaboutforensicscience.com and the twitter in it isn't working either, albeit with a different error message "No recent Twitter posts." Even though I just tweeted a post for testing purposes.

Share this post


Link to post
Share on other sites
cmunns

I just want to double check, you only placed the username and not the full link to the site in the twitter option?

Share this post


Link to post
Share on other sites
kmcshanethemcshanefirmcom

yes only the username

Share this post


Link to post
Share on other sites
cmunns

I've looked at the code and the problem is that the twitter feed was using a deprecated function, meaning WP changed things around and doesn't support it anymore. We're working on a solution for this now.

Share this post


Link to post
Share on other sites
kmcshanethemcshanefirmcom

Please let me know when it is solved. In the meantime. Is there a way to remove the feed from the intro section because it looks rather odd displaying the error message.

Share this post


Link to post
Share on other sites
Andrew

That actually shouldn't have caused this issue... is this happening 100% of the time or something like 30%?

Share this post


Link to post
Share on other sites
kmcshanethemcshanefirmcom

It is not working at all. Not once have I seen a feed appear so it's totally broken. I hope you guys can find a solution to this.

Share this post


Link to post
Share on other sites
cmunns

The Twitter plug-in needed some updating since we integrated it. We'll be releasing a patch shortly.

Share this post


Link to post
Share on other sites
cptnemo

Change to a Linux server and the problem is fixed.

Share this post


Link to post
Share on other sites
bryan-hadaway

Yes, Windows servers are not exactly the most suitable for websites, I only wish more people knew this, so happy to hear you're with Linux now. Thanks, Bryan

Share this post


Link to post
Share on other sites
Andrew

Just updated the themes... turns out something changed with the integrated plugin and the Twitter API... anyway, the newly updated theme should fix this issue (we updated the plugin) If you don't want to update your whole theme, you could just add the "Twitter for WordPress" plugin. It's set up so it will override the native plugin; but work the same way :)

Share this post


Link to post
Share on other sites
kmcshanethemcshanefirmcom

Can you provide a link for the mentioned plugin? Thanks.

Share this post


Link to post
Share on other sites
kmcshanethemcshanefirmcom

I installed a plugin called "Twitter for Wordpress" by Ricardo Gonzales and when I try to activate it I get the following error: "Fatal error: Cannot redeclare twitter_messages() (previously declared in C:InetpubSitespaduiblogwp-contentthemesecoprocorepluginstwitter.php:49) in C:InetpubSitespaduiblogwp-contentpluginstwitter-for-wordpresstwitter.php on line 110"

Share this post


Link to post
Share on other sites
Andrew

The plugin was working on our test servers, and seems to be working on the demos. We will look at it more, but my guess is that there is an issue with the plugin and Twitter (as we have just integrated it into the theme) Maybe you are having a plugin conflict? The provider site: http://rick.jinlabs.com/code/twitter/

Share this post


Link to post
Share on other sites
sustainableweb

What's the easiest way to resolve the deprecation notice? I am using the EcoPro theme. I have a lot of other debugging to do so I'm just trying to clear up debug.log to make it easier for myself. [08-Oct-2010 16:04:33] PHP Notice: rss.php is deprecated since version 3.0! Use wp-includes/class-simplepie.php instead. in /Users/ivan/Dropbox/Projects/GreenDegreeDirectory/website/devgdd/wp-includes/functions.php on line 3277 [08-Oct-2010 16:04:33] PHP Stack trace: [08-Oct-2010 16:04:33] PHP 1. {main}() /Users/ivan/Dropbox/Projects/GreenDegreeDirectory/website/devgdd/index.php:0 [08-Oct-2010 16:04:33] PHP 2. require() /Users/ivan/Dropbox/Projects/GreenDegreeDirectory/website/devgdd/index.php:17 [08-Oct-2010 16:04:33] PHP 3. require_once() /Users/ivan/Dropbox/Projects/GreenDegreeDirectory/website/devgdd/wp-blog-header.php:16 [08-Oct-2010 16:04:33] PHP 4. include() /Users/ivan/Dropbox/Projects/GreenDegreeDirectory/website/devgdd/wp-includes/template-loader.php:43 [08-Oct-2010 16:04:33] PHP 5. get_template_part() /Users/ivan/Dropbox/Projects/GreenDegreeDirectory/website/devgdd/wp-content/themes/greendegreedirectory/index.php:10 [08-Oct-2010 16:04:33] PHP 6. locate_template() /Users/ivan/Dropbox/Projects/GreenDegreeDirectory/website/devgdd/wp-includes/general-template.php:128 [08-Oct-2010 16:04:33] PHP 7. load_template() /Users/ivan/Dropbox/Projects/GreenDegreeDirectory/website/devgdd/wp-includes/theme.php:1062 [08-Oct-2010 16:04:33] PHP 8. require() /Users/ivan/Dropbox/Projects/GreenDegreeDirectory/website/devgdd/wp-includes/theme.php:1088 [08-Oct-2010 16:04:33] PHP 9. get_template_part() /Users/ivan/Dropbox/Projects/GreenDegreeDirectory/website/devgdd/wp-content/themes/greendegreedirectory/_template.php:38 [08-Oct-2010 16:04:33] PHP 10. locate_template() /Users/ivan/Dropbox/Projects/GreenDegreeDirectory/website/devgdd/wp-includes/general-template.php:128 [08-Oct-2010 16:04:33] PHP 11. load_template() /Users/ivan/Dropbox/Projects/GreenDegreeDirectory/website/devgdd/wp-includes/theme.php:1062 [08-Oct-2010 16:04:33] PHP 12. require() /Users/ivan/Dropbox/Projects/GreenDegreeDirectory/website/devgdd/wp-includes/theme.php:1088 [08-Oct-2010 16:04:33] PHP 13. get_template_part() /Users/ivan/Dropbox/Projects/GreenDegreeDirectory/website/devgdd/wp-content/themes/greendegreedirectory/library/template_sidebar.php:15 [08-Oct-2010 16:04:33] PHP 14. locate_template() /Users/ivan/Dropbox/Projects/GreenDegreeDirectory/website/devgdd/wp-includes/general-template.php:128 [08-Oct-2010 16:04:33] PHP 15. load_template() /Users/ivan/Dropbox/Projects/GreenDegreeDirectory/website/devgdd/wp-includes/theme.php:1062 [08-Oct-2010 16:04:33] PHP 16. require() /Users/ivan/Dropbox/Projects/GreenDegreeDirectory/website/devgdd/wp-includes/theme.php:1088 [08-Oct-2010 16:04:33] PHP 17. get_template_part() /Users/ivan/Dropbox/Projects/GreenDegreeDirectory/website/devgdd/wp-content/themes/greendegreedirectory/library/_defaultsidebar.php:1 [08-Oct-2010 16:04:33] PHP 18. locate_template() /Users/ivan/Dropbox/Projects/GreenDegreeDirectory/website/devgdd/wp-includes/general-template.php:128 [08-Oct-2010 16:04:33] PHP 19. load_template() /Users/ivan/Dropbox/Projects/GreenDegreeDirectory/website/devgdd/wp-includes/theme.php:1062 [08-Oct-2010 16:04:33] PHP 20. require() /Users/ivan/Dropbox/Projects/GreenDegreeDirectory/website/devgdd/wp-includes/theme.php:1088 [08-Oct-2010 16:04:33] PHP 21. get_template_part() /Users/ivan/Dropbox/Projects/GreenDegreeDirectory/website/devgdd/wp-content/themes/greendegreedirectory/library/widget_welcome.php:7 [08-Oct-2010 16:04:33] PHP 22. locate_template() /Users/ivan/Dropbox/Projects/GreenDegreeDirectory/website/devgdd/wp-includes/general-template.php:128 [08-Oct-2010 16:04:33] PHP 23. load_template() /Users/ivan/Dropbox/Projects/GreenDegreeDirectory/website/devgdd/wp-includes/theme.php:1062 [08-Oct-2010 16:04:33] PHP 24. require() /Users/ivan/Dropbox/Projects/GreenDegreeDirectory/website/devgdd/wp-includes/theme.php:1088 [08-Oct-2010 16:04:33] PHP 25. twitter_messages() /Users/ivan/Dropbox/Projects/GreenDegreeDirectory/website/devgdd/wp-content/themes/greendegreedirectory/library/_twittermessages.php:3 [08-Oct-2010 16:04:33] PHP 26. include_once() /Users/ivan/Dropbox/Projects/GreenDegreeDirectory/website/devgdd/wp-content/themes/greendegreedirectory/core/plugins/twitter.php:52 [08-Oct-2010 16:04:33] PHP 27. _deprecated_file() /Users/ivan/Dropbox/Projects/GreenDegreeDirectory/website/devgdd/wp-includes/rss.php:18 [08-Oct-2010 16:04:33] PHP 28. trigger_error() /Users/ivan/Dropbox/Projects/GreenDegreeDirectory/website/devgdd/wp-includes/functions.php:3277

Share this post


Link to post
Share on other sites
cmunns

the integrated twitter messages code is taken from "Twitter for WordPress" which may not be completely debugged...which is why in teh future we aren't integrating in this way. the RSS.php I believe is used by that one. Also, make sure plugins are deactivated if you're going to debug...as many errors will come from those.

Share this post


Link to post
Share on other sites
brightgreenhomes

Hi, I'm a bit of a novice with Wordpress and HTML in general - not a complete numpty but pretty novice - I am having the same problem - but it the plug in worked perfectly for a while and now not at all - www.brightgreenhomes.co.uk - I'm a bit unsure of where or what to do next to resolve this issue? please help. thanks in advance - Alex

Share this post


Link to post
Share on other sites
bryan-hadaway

Can you remember what changed when it stopped working? Upgrade, new plugin etc.? Thanks, Bryan

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×