Jump to content
jbrouwer

Specify image dimensions and combine images

Recommended Posts

jbrouwer

Hi,

Google page speed suggests to specify image dimensions and to combine images using CSS sprites. Most of the images are from Pagelines, see the screenshot below.

1. How can I specify image dimensions? Do I need to set them manually in my child themes style sheet? Or can I specify them somewhere else?

2. About combining images. I can remember that Pagelines Pro already combined the icons of the social networks in the header. Why has this been changed?

Thank you.

screenshot-gtmetrix.jpg

Share this post


Link to post
Share on other sites
catrina

1. How can I specify image dimensions? Do I need to set them manually in my child themes style sheet? Or can I specify them somewhere else?

With custom CSS (using the dimension properties: http://www.w3schools.com/css/css_dimension.asp).

2. About combining images. I can remember that Pagelines Pro already combined the icons of the social networks in the header. Why has this been changed?

I'm not sure why this changed. Do you want the icons to change back to using sprites?

  • Like 1

Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites
jbrouwer

1. I specified the image dimensions of my logo in the header with:


.section-branding img.mainlogo-img{

    height: 75px;

    width: 300px;

}

However, it still turns up in the page speed recommendations. What am I doing wrong?

2. If that improves loading times. Unless there is some reason to not use sprites.

Share this post


Link to post
Share on other sites
catrina

I'm not sure what would be the issue (the image isn't even that big). If you're setting the width for the logo, you don't need to set the height dimension. Try clearing the browser cache to see if the page speed is still a problem.

It may make a difference, but you'd have to try it out and see if the page load issue disappears: http://www.w3schools.com/css/css_image_sprites.asp


Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites
seo_pro

I'm not sure why this changed. Do you want the icons to change back to using sprites?

I'm running into the same problem with pagespeed saying that facebook.png, linkedin.png, rss.png, twitter.png and youtube.png should be sprites.

How would I fix it so that updates wouldn't cause it to revert back or is converting the Pageline png's to sprites something that's in an upcoming release?

Thanks,

Kevin

Share this post


Link to post
Share on other sites
Rob

Kevin, the method would be the same as for adding a new social media icon; essentially, a hook. However, in this case, it would mean creating all the social media icons, rather than just adding one or two.

Are you familiar with hooks?


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
seo_pro

Thanks Rob. I had thought of doing it that way, but it sounded like they were talking about having the icons as sprites in the base package. Was wondering if that is a possibility of it being included as it affects every page speed calculation program and wouldn't be difficult to do. Seems like that would be a good addition as it was in Pagelines Pro.

Share this post


Link to post
Share on other sites
seo_pro

Just tried the Google Pagespeed link above and it gave me the same result as the other speed tests for the pagelines branding icons saying to combine into sprites as wel. Maybe you will consider adding it to Pagelines. Thanks

Share this post


Link to post
Share on other sites
Rob

Is this issue resolved?


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
jbrouwer

@caterina thank you for the link, I made a sprite of the social icons. Saved three http requests for my site.

Found another great tool as well: http://spriteme.org/

It scans your site for background images and gives you a suggestion about using a sprite, makes the new image and gives you the appropiate CSS! It does not suggests the pagelines social icons, because they are not background images. Anyway, great tool.

Share this post


Link to post
Share on other sites
Danny

Thanks for sharing!

The topic was marked as resolved.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Similar Content

    • janpeeters
      By janpeeters
      Over the last month I had extensive communications with the developer of the (premium) Anything Boxes section (in Pagelines store) (Adam Munns) and the developer of the WP Polylang Multilingual plugin (Frederic Demarle).
       
      This was because the following problem occurred:
      Anything Boxes showed all posts of two languages (Dutch and English) on the respective static frontpages for each language. It should of course have filtered posts for Dutch language on the Dutch frontpage and English on the English frontpage.
       
      The solution to this problem was simple in the end. When duplicating a page for use in another language the settings for Anything Boxes were not copied to the new page and I should have set these settings manually again on the new page. I wasn't aware of this, but it makes sense. Because of this the pages didn't know how to differentiate between posts from different languages.
       
      The dev of Polylang told me that Polylang is currently smart enough to synchronize metas like Featured images and page templates but it does not work out of the box with metas created by plugins and themes but (according to Frederic) it is rather easy to add them in the list using the filter 'pll_copy_post_metas'.
      He mentions that he is not sure that these 'PageLines Meta Settings' are stored in post meta but that would make sense according to him. He asks if the Pagelines dev team will be interested to support this feature in the future.
       
      I'm also wondering if you will consider adding Polylang translation support for manually editable strings like the 'Read more…' strings in Pagelines Settings.
       
      Well that's of course up to you but I thought to let you know to be able to take this into consideration. I also post this for other users in case they experience the same kind of trouble and are looking for an answer.
       
      Best regards,
      Jan Peeters
    • bankrollbuilder
      By bankrollbuilder
      I used a custom hook to put a banner ad in my header. It works but its not in the right position. it is centered and above my logo and I would like to float it to the right of my logo in the header. heres the link: http://shaboopie.com/shaboopie-wp/free-logos-pg1/

      thanks.

      Dan B.
    • starlit
      By starlit
      Can one have two hero sections on one page?

      I want a landing page which leads/advertises two subpages.

      Or is there another option?

      Please help.

      THANK YOU
    • hutruk
      By hutruk
      Hi!

      I am using the shortcodes for tabs, as described in the documentation.

      When I insert the following code:


      [pl_tabs][pl_tabtitlesection type="tabs"] [pl_tabtitle number="1"]Title 1[/pl_tabtitle] [pl_tabtitle number="2"]Title 2[/pl_tabtitle] [/pl_tabtitlesection] [pl_tabcontentsection] [pl_tabcontent active="yes" number="1"] Lorem ipsum dolor sit amet, consectetur adipiscing elit [/pl_tabcontent] [pl_tabcontent number="2"] Lorem ipsum dolor sit amet, consectetur adipiscing elit [/pl_tabcontent] [/pl_tabcontentsection] [/pl_tabs]

      I get a strange output (in the attachment).

      Any ideas?

      Thanks in advance!

    • MooiWeb
      By MooiWeb
      Hello,

      I would like to align my qtranslate with my breadcrumb so that the flags are on the same hight.
      I'm aware of putting a code in the custom css and tryed severall codes from your site but for now, no succes

      The site i'm working on is http://nieuw.vazdias.nl

      Thx,
      Edwin



×