Jump to content
devaldivia

Fatal Error on Upgrade

Recommended Posts

devaldivia    0
devaldivia

Hi there,

I am running version 2.1.6 and trying to upgrade to 2.3.2. but I get the following fatal error whenever I run the auto-update and click on details:

The update process is starting. This process may take a while on some hosts, so please be patient.

Enabling Maintenance mode…

Fatal error: Call to a member function display() on a non-object in /home/londonta/public_html/wp-admin/includes/class-wp-upgrader.php on line 1385

On the site itself, I get:

Briefly unavailable for scheduled maintenance. Check back in a minute.

I ran a site backup immediately prior to trying to update, so nothing lost, but I'd like to resolve the issue and proceed with the update.

Thank you for your help,

Bryan

Share this post


Link to post
Share on other sites
James B    436
James B

Hi there, its sounds like you're stuck in a loop there. You'll need to go in via FTP and delete the .maintenance file in the root folder. Well done for backing up in advance.

This link should help you further http://wordpress.org/support/topic/30-stuck-in-maintenance-mode-after-failed-plugin-upgrade


Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites
devaldivia    0
devaldivia

Hi James,

thank you for the tip. Funnily enough, I redid the update today, and it updated just fine all on it's own :)

The bad news is, my widgets got all scrambled up :(

I had waited to update hoping that the bugs had been worked out by now. I'm currently putting the widgets back where they belong, but would like to know what other bugs have been reported so I don't get any nasty surprises. I checked the current update thread, but it seems that the bugs I'm encountering came into the process sometime further back.

Kind Regards

Bryan

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Similar Content

    • dbrowne02
      By dbrowne02+
      Hey, this looks like a great product. Thank you for making it!
      Unfortunately, when I activated plugin, I got this error. Thanks in advance for helping with this. 

      Fatal error: Cannot redeclare wmHtmlEditorEnable() (previously declared in /home/dbrowne02/brownelaborlaw.com/wp-content/plugins/enhanced-options-editor/enhanced-options-editor.php:14) in /home/dbrowne02/brownelaborlaw.com/wp-content/plugins/enhanced-options-editor/enhanced-options-editor.php on line 15
    • pillar
      By pillar
      After preview OR activation of the Bespoke Theme 1.0.1 an internal error 500 occurs. Wp debug states: Fatal error: Cannot redeclare class EditorStoreFront in /var/www/[...]/wp-content/themes/jg-bespoke/dms/editor/editor.api.php on line 7.
       
      This happen on a clean webserver (Ubuntu 14.04 LTS server 64bit, Apache/2.4.7 (Ubuntu), MySQL5.5.40-0ubuntu0.14.04.1, PHP 5.5.9-1ubuntu4.5, Wordpress 4.0) and neither
      Wordpress plugins are installed nor .htaccess files are placed.
       
      Can anybody help me?
       
    • gsquared
      By gsquared
      For some reason, when I go to the home page of my client's site, it's showing the following error:
       
      Fatal error: Call to undefined function setup_pagelines_template() in /home/p1sivng/public_html/wp-content/themes/pagelines/page.alpha.php on line 24
       
      I tried disabling other plugins, but that didn't help. I changed enabled debug mode, but it didn't display any additional information.
       
      In the error log, it's showing the following line:
       
      PHP Fatal error:  Call to undefined function setup_pagelines_template() in /home/p1sivng/public_html/wp-content/themes/pagelines/index.php on line 50
       
      I am using PageLines Framework version 2.4.5
      Wordpress version 4.0
       
      The URL is: http://www.printadvertisingusa.com
       
      Any ideas what this could be?
       
      Gary
    • nfp1900
      By nfp1900
      Hi
       
      I'm really looking for some help from all those WP users out there as I've hit a bit of brick wall elsewhere. I built this site www.delada.net with no issues but a couple of days ago I started getting "Plugin could not be activated because it triggered a fatal error"  but no other error messages. If I update an active plugin it updates then fails to reactivate. There are a bunch of inactive plugins (from the previous developer - around 25) but only 6 are active on this site and it's nothing I haven't got on other installations. 
       
      I've built and updated  30+ wordpress sites with every version of pagelines right up to this DMS 2.0.4 version and I've never seen this before. I called the host Godaddy which the client already had in place (it wasn't my choice) and they simply said they don't support Wordpress so that wasn't such a good start. 
       
      Anyone got any bright ideas about what to do? The WP forums haven't turned up anything or a reply. Only thing I see is that there is a plugin nonce error on activation which points to an incorrect authentication key (maybe?).
       
       
       
       
×