Jump to content
creatov

Read more link

Recommended Posts

creatov    0
creatov

Since I use the Fixed Navbar is the Read More link a little strange. See the issue:

post-560-0-75797700-1349365431_thumb.jpg

This is where the right position has to be:

post-560-0-54400300-1349365466_thumb.jpg

This is the homepage: http://www.creatov.nl/

This is this article: http://www.creatov.n...-you-videoclip/

I do not see how to solve this one. And on the Pagelines demo I cannot see it either. Hope someone can help me out!

Share this post


Link to post
Share on other sites
catrina    103
catrina

The read more link is not supposed to be in the article page. Since you're already viewing the actual article page, there would be no need for a "read more" link. The link is also appearing correctly on the main blog page where the posts are located.


Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites
creatov    0
creatov

I understand this tag should not appear in the normal post. But the issue is, when you click the read more link the position of the more tag should be on the top of the page. But now it is somewhere above the top and you miss some ot the lines.

So, http://www.creatov.nl/2012/10/i-dont-deserve-you-videoclip/#more-14522 (this is the read more link) should be open like this:

http://www.screencast.com/t/Z8vvZyN4f

But now its around 100px to far to the top. Hope you understand the issue.

Share this post


Link to post
Share on other sites
creatov    0
creatov

I hope someone is able to give me hints to solve this thing... Am I the only one having this issue?

Share this post


Link to post
Share on other sites
Danny    1,327
Danny

Hi,

I have ran several tests and I am unable to reproduce your error. Therefore, I recommend you disable all non-PageLines plugins and see if this issue persists.

If it does, then it may be related to your custom code.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
creatov    0
creatov

Wow, it's hard to explain the issue. It's not an error, it's just disbehaving. The anchor point is under or above the fixed navbar, so I am missing the first sentences under the --> more link after clicking the "read more" link on the frontpage. To explain I've recoreded it. I hope you understand now:

http://www.screencast.com/t/lM3F8aZTVo

Share this post


Link to post
Share on other sites
Danny    1,327
Danny

Hi,

So you're using a custom read more link?


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
creatov    0
creatov

No, I use the normal "Read More" tag from within WordPress.

post-560-0-14652300-1349441551_thumb.jpg

post-560-0-14652300-1349441551_thumb.jpg

Share this post


Link to post
Share on other sites
creatov    0
creatov

Well, is there no hint to solve this issue? I'm still trying to figure out how to change this that it just works properly.

Share this post


Link to post
Share on other sites
Danny    1,327
Danny

OK, well this isn't actually an issue nor a bug and is actually working properly/as intended. This functionality is default in Wordpress as far as I'm aware.

http://codex.wordpre..._or_Top_of_Page

However, I am not sure why you have decided to use the more link, when if you choose the following settings:

PageLines > Blog & Posts > Post Excerpt or Summary Handling > Posts/Blog Page

And don't use full post content on the Blog/Post Page.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
creatov    0
creatov

Well, I want to have more control on the excerpt... But it's not just this issue. It is the same with anchors in an article. The link to the comments (.../#disqus_thread) are behaving the same: the anchor is under the fixed navbar and you don't see the beginning of the element.

Share this post


Link to post
Share on other sites
Danny    1,327
Danny

I will bring this to the attention of our developers and see if there is anything that can be done to resolve this. There seems to be quite a few topics regarding this with Bootstrap and their fixed navigation.

When I have more information, I will reply here.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
creatov    0
creatov

Danny, thanks for that.

Simon, this doesn't fix anything. I tried a lot of stuff, but it's hard make the page just start under the line of the fixed navigation. Whatever I tried in adding tricks in the CSS, it still doesn't work and I didn't find the right solution.

Share this post


Link to post
Share on other sites
Simon    247
Simon

Did you add that css?

Share this post


Link to post
Share on other sites
Simon    247
Simon

btw, you should turn off w3 cache while your developing it makes it impossible for us to help you.

i did find this in your html:


<?php wp_enqueue_script('jquery'); ?
[/CODE]

unrelated, but you shouldnt have php in your html so there is something wierd going on there.

Share this post


Link to post
Share on other sites
creatov    0
creatov

I did add this CSS but it doesn't do anything. So I erased the lines again.

PS: for now I've disabled the caching.

And that jquery I have to search where this is coming from.

Share this post


Link to post
Share on other sites
Simon    247
Simon

If you re-add the css, and we can see if it needs changing.

Share this post


Link to post
Share on other sites
Simon    247
Simon

The jquery line might be in the headerscripts area under custom code, possibly.

Share this post


Link to post
Share on other sites
creatov    0
creatov

Thanks, you're right. I think accidentally copied.

I've added the CSS again in the admin section

Share this post


Link to post
Share on other sites
Simon    247
Simon

Well it works in firefox, try lowercase h2

Share this post


Link to post
Share on other sites
creatov    0
creatov

Oké, I see. It works in Firefox (partly) but not in Safari and Chrome.

It does not solve this issue with other anchors have this one, only if I use an H2 after the "more" anchor. And in Firefox I have now just an extra white space to compensate the issue.

Share this post


Link to post
Share on other sites
Simon    247
Simon

Maybe someone who knows some css maybe able to help a bit more. But to be honest you gonna have to hack about with it.

Share this post


Link to post
Share on other sites
creatov    0
creatov

Thanks for now. I appreciate your help. It's a weird issue Normally I'm able to figure out how to manage things, but I'm stuck in this one. Again, thanks for now. I hope someone is having a great idea!

Share this post


Link to post
Share on other sites
mackenzie    12
mackenzie

I'm checking to see if anyone has responded to you or if this was resolved.


Mackenzie - PageLines Help Desk

The Centsible Family - Writer, Photographer and Coffee Addict

---------------------------------------------------

Kindly search this forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×