Jump to content
rtysmith

Featured slide whole image link

Recommended Posts

rtysmith    1
rtysmith

I've been using below in my function file for some time without issue, but now will not work in IE, any ideas?

add_action('pagelines_feature_before','whole_link_image');

function whole_link_image(){?>

<?php global $post;?>

<?php if(get_post_meta($post->ID, 'feature-link-url', true)):?>

<a class="whole_image_link" href="<?php echo get_post_meta($post->ID, 'feature-link-url', true);?>"></a>

<?php endif;?>

<?php }

In CSS:

a.whole_image_link {

position:absolute;

width:100%;

height:100%;

z-index:9999;

left:0; /*Firefox fix*/

}

Site is: http://eosworldwide.com (works in ff, chrome, not ie)

Share this post


Link to post
Share on other sites
batman    389
batman

HI, I´m not sure but you can try this plugin

"Browser Specific CSS"

It´s free at Pageline > Store > Plugin>Top Free

Add browser specific classes to the main body tags for all major browsers and devices.


Life is too short to remove USB safely ...

Share this post


Link to post
Share on other sites
Rob    547
Rob

If you see the attached picture, you'll see a check box for "Make Feature HTML Full Width" in PageLines Framework's Features.

If you check that, you do not need any additional code or CSS. Considering how sensitive IE is to select CSS code, it's probably best to let our code take precedent with that option.

I cannot say it works perfectly in IE8, but it does work in IE9. I've not seen any complaints about it for any browsers.

You should upgrade soon as PlatformPro is going to be deprecated soon.

post-6-0-91820300-1349317694_thumb.png


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
rtysmith    1
rtysmith

OK, that must be a version more recent then mine, I'm on 1.3.2; the theme is a bit customized and I've always been afraid to update, but I'll give it a try.

Share this post


Link to post
Share on other sites
rtysmith    1
rtysmith

I don't see this option in 1.5.2? What am I missing?

Share this post


Link to post
Share on other sites
catrina    103
catrina

"Make Feature HTML Full Width" <- I'm not seeing this option in the Features settings either. Perhaps it was removed. There would be need to be a workaround (it would've been the browser specific CSS plugin, but it can't be used with PlatformPro - only PageLines Framework). For an IE-related issue like this, I'm not sure what further action could be taken without adding CSS that works specifically for IE.


Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites
rtysmith    1
rtysmith

OK, so do you know what would need to be added for CSS?

Share this post


Link to post
Share on other sites
mackenzie    12
mackenzie

The topic was marked as resolved.


Mackenzie - PageLines Help Desk

The Centsible Family - Writer, Photographer and Coffee Addict

---------------------------------------------------

Kindly search this forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Similar Content

    • janpeeters
      By janpeeters+
      Over the last month I had extensive communications with the developer of the (premium) Anything Boxes section (in Pagelines store) (Adam Munns) and the developer of the WP Polylang Multilingual plugin (Frederic Demarle).
       
      This was because the following problem occurred:
      Anything Boxes showed all posts of two languages (Dutch and English) on the respective static frontpages for each language. It should of course have filtered posts for Dutch language on the Dutch frontpage and English on the English frontpage.
       
      The solution to this problem was simple in the end. When duplicating a page for use in another language the settings for Anything Boxes were not copied to the new page and I should have set these settings manually again on the new page. I wasn't aware of this, but it makes sense. Because of this the pages didn't know how to differentiate between posts from different languages.
       
      The dev of Polylang told me that Polylang is currently smart enough to synchronize metas like Featured images and page templates but it does not work out of the box with metas created by plugins and themes but (according to Frederic) it is rather easy to add them in the list using the filter 'pll_copy_post_metas'.
      He mentions that he is not sure that these 'PageLines Meta Settings' are stored in post meta but that would make sense according to him. He asks if the Pagelines dev team will be interested to support this feature in the future.
       
      I'm also wondering if you will consider adding Polylang translation support for manually editable strings like the 'Read more…' strings in Pagelines Settings.
       
      Well that's of course up to you but I thought to let you know to be able to take this into consideration. I also post this for other users in case they experience the same kind of trouble and are looking for an answer.
       
      Best regards,
      Jan Peeters
    • bankrollbuilder
      By bankrollbuilder
      I used a custom hook to put a banner ad in my header. It works but its not in the right position. it is centered and above my logo and I would like to float it to the right of my logo in the header. heres the link: http://shaboopie.com/shaboopie-wp/free-logos-pg1/

      thanks.

      Dan B.
    • starlit
      By starlit
      Can one have two hero sections on one page?

      I want a landing page which leads/advertises two subpages.

      Or is there another option?

      Please help.

      THANK YOU
    • hutruk
      By hutruk
      Hi!

      I am using the shortcodes for tabs, as described in the documentation.

      When I insert the following code:


      [pl_tabs][pl_tabtitlesection type="tabs"] [pl_tabtitle number="1"]Title 1[/pl_tabtitle] [pl_tabtitle number="2"]Title 2[/pl_tabtitle] [/pl_tabtitlesection] [pl_tabcontentsection] [pl_tabcontent active="yes" number="1"] Lorem ipsum dolor sit amet, consectetur adipiscing elit [/pl_tabcontent] [pl_tabcontent number="2"] Lorem ipsum dolor sit amet, consectetur adipiscing elit [/pl_tabcontent] [/pl_tabcontentsection] [/pl_tabs]

      I get a strange output (in the attachment).

      Any ideas?

      Thanks in advance!

    • MooiWeb
      By MooiWeb
      Hello,

      I would like to align my qtranslate with my breadcrumb so that the flags are on the same hight.
      I'm aware of putting a code in the custom css and tryed severall codes from your site but for now, no succes

      The site i'm working on is http://nieuw.vazdias.nl

      Thx,
      Edwin



×