Jump to content
Sign in to follow this  
nabil

WP-PostViews and Highslide Integration

Recommended Posts

nabil

Hi everyone, Firstly, I would like to apologies about my english because I'm french. So, I just bought your Iblog template and love it ! Anyway, I'm trying to make somme plugins, WP-PostViews and Highslide Integration, working but couldn't. I don't know where could I copy my WP-PostViews code to show it on all of my posts and pages. About Highslide Integration, just give up beacuse impossible to make it work... Do you have any idea ? Can't show you my website yet because I'm working on local. Thanks by advance, Nabil.A

Share this post


Link to post
Share on other sites
bryan-hadaway

Are you getting error messages? What about them is not working, will they not install at all? They may be out-dated and not work on WordPress 3.0+. Thanks, Bryan

Share this post


Link to post
Share on other sites
nabil

No, didn't get any error message. You can install them without any problem on Wordpress 3.0. You can check on my current template : www.gamebillstudio.com Then with Iblog, the install work perfectly but nothing works. About WP-PostViews, I just have to copy some php code to show it on all of my posts and pages but I don't know wich file. Thanks, Nabil.A

Share this post


Link to post
Share on other sites
cmunns

To get it show on posts and pages you need to add it inside of the _posts.php template file. There is a lot going on, but if you be more specific on where it should go i may better direct you. e.g. top of posts/ bottom of posts/ etc. With the other plug-in it's really hard to say why it's not working if there are no errors. Did you use a validator or something like that...maybe the menu for it moved locations ??

Share this post


Link to post
Share on other sites
nabil

Thank you cmunns. In the readme file, they say that I have to find <?php while (have_posts()) : the_post(); ?> And then add Anywhere Below It: <?php if(function_exists('the_views')) { the_views(); } ?> But I can't find the line <?php while (have_posts()) : the_post(); ?> I would like to show it as the picture below : postview_gbs.jpg Thank you.

Share this post


Link to post
Share on other sites
cmunns

You'll see that inside of the _posts.php file `<?php while (have_posts()) : the_post(); ?>` is right there at the top :)

Share this post


Link to post
Share on other sites
nabil

Thanks again cmunns. I did find the line at the top of the _posts.php file but still not working. By the way, the line of the _posts.php file is : <?php if (!is_404() && have_posts()) : while (have_posts()) : the_post(); ?> and not : <?php while (have_posts()) : the_post(); ?> Is it because is not working ? Believe me, I did try to copy the PostView's code everywhere inside of the _posts.php file but nothing... I'm sorry to disturb you with that but this is the only important thing that I miss before to put online the new design. I'm late about 2 days. Thank you again.

Share this post


Link to post
Share on other sites
cmunns

I put it inside of the metabar portion and it works for me. Did you activate the plug-in first? `<div class="metabar"> <em> <?php _e('On',TDOMAIN);?> <?php the_time(get_option('date_format')); ?>, <?php _e('in',TDOMAIN);?> <?php the_category(', ') ?>, <?php _e('by',TDOMAIN);?> <?php the_author(); ?> <?php edit_post_link(__('<strong>(Edit Post)</strong>', TDOMAIN), ' ', ' ');?> <?php if(function_exists('the_views')) { the_views(); } ?> </em> </div>`

Share this post


Link to post
Share on other sites
nabil

Big big thanks ! It's working now ! So, I just miss the "Highslide Integration" plugin. Maybe it's gonna be easy for you to check it since your design is now online here : www.gamebillstudio.com I also thanks you on the news about your website. One more question, I just lost my comments on post after to put online your design. But still have it on pages. Any idea ? Thanks !

Share this post


Link to post
Share on other sites
cmunns

You went live with the site and lost your comments? That's strange. Double check the discussion settings to make sure the options didn't get switched up somehow. For the highslide plug-in, the plug-in page says that it's only compatible up to WP 2.9.2. If you're looking for a lightbox plug-in then try LightBox Plus as an alternative

Share this post


Link to post
Share on other sites
nabil

Strangely, I had to add this to _post.php: <?php if(is_page() || pagelines('pagecomments', $post->ID)) include(THEME_LIB.'/_commentsform.php');?> under the line of <?php if(!VPRO || !is_page() || (is_page() && pagelines('pagecomments', $post->ID))) include(THEME_LIB.'/_commentsform.php');?> Work great. Just hope that it's not gonna break something in the template. For the highslide plug-in, it worked on Wordpress 3.0 with my old template. I just tried LightBox Plus but what I'm looking for is a zoom on picture. Anyway, thank you again.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×