Jump to content
Sign in to follow this  
ginnywills

Sidebar content is not showing

Recommended Posts

ginnywills    0
ginnywills

Hi

I have a simple site with most pages using the same Template. I have formatted that template so that it has a sidebar on the left and content on the right.

In the sidebar, I have a widget to show the top 3 posts. I also want a quickslider above it.

When you look at the site, the sidebar is empty. audaciousgroup.com/dev

I have checked the page setup on each page, I have added the images to the slider and made sure its not hidden. I have checked that the widget is populated with the Recent Posts. I have made sure the template has a left sidebar with Primary Sidebar in it. The quickslider is in the Wrap.

What am I missing?

Thanks,

Ginny

Share this post


Link to post
Share on other sites
ginnywills    0
ginnywills

When Page Template is highlighted, I have dragged CONTENT.

When Content is highlighted, it seems to only show my text when PostLoop is activated.

When Wrap is highlighted, I have dragged QUICKSLIDER.

When SB1 is highlighted, I have dragged PRIMARY SIDEBAR

The layout seems right because the sidebar is there when you look at the page, its just empty.

Share this post


Link to post
Share on other sites
ginnywills    0
ginnywills

Yes - I have made the layout with the left sidebar my default.

Share this post


Link to post
Share on other sites
catrina    103
catrina

Please clear your browser cache and check your site again to see if the issue persists.


Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites
ginnywills    0
ginnywills

I've been trying to figure this out for days. I have cleared the cache and also looked on 2 other browsers. Same problem. It used to work but I changed the home page a bunch last Friday and now its not working.

I now also have a black box in the middle of my home page but I don't have a background image. So not sure what that is either.

Share this post


Link to post
Share on other sites
ginnywills    0
ginnywills

I've been playing with it and no matter what section I activate in the SB1 area it does not show up. This includes any template.

Share this post


Link to post
Share on other sites
catrina    103
catrina

I've been trying to figure this out for days. I have cleared the cache and also looked on 2 other browsers. Same problem. It used to work but I changed the home page a bunch last Friday and now its not working.

Do you remember what changes you made?


Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites
ginnywills    0
ginnywills

No - but it was only layout changes. Nothing custom.

Share this post


Link to post
Share on other sites
Rob    547
Rob

Ginny, please go to each of the following places and look in the settings for "Hide Primary Sidebar" or "Hide Secondary Sidebar".

1. The static page you created, under PageLines Meta Settings

2. Dashboard > PageLines > Page Options (check Blog Page > Page Setup)

3. Also under Page Options, check the Page Setup under all the major groups (Archives, Categories, Author Posts).

I suspect that somewhere along the line, the sidebars are hidden. Most likely, it's going to be on the 1st of these three.


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
ginnywills    0
ginnywills

Hi,

I checked the things you asked.

1. Definitely not hidden for the static pages that I want the side bar to show in (Template 4 & Template 5)

2. Yes, the sidebar is hidden on the Blog Page (my home page) because I do not want it there

3. I checked the other major groups (even though have never even looked at these before because not using them) and its not hidden there.

Still a mystery. Are you allowed to use my login to poke around?

Thanks so much for your help on this. Its been really frustrating!

Ginny

Share this post


Link to post
Share on other sites
catrina    103
catrina

The next step would be to deactivate plugins to see if the sidebar content shows.


Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites
ginnywills    0
ginnywills

okay - I did that and nothing changed. I didn't really have too much activated anyway.

Share this post


Link to post
Share on other sites
ginnywills    0
ginnywills

Hi - I have made the site live so the URL is now www.audaciosugroup.com. I was sort of hoping the sidebar would automatically populate itself, but no go. I am really starting to get frantic. Can you please help me?

Additionally, the CSS code you gave me for the background image on the home page did not work.

Oh - and now the quickslider on the home page will not view.

Its going from bad to worse. I;ve never had a wordpress site take so long to get right.

Please? Can you help?

Share this post


Link to post
Share on other sites
ginnywills    0
ginnywills

I have got everything working again apart from the sidebar. No matter what section I activate to put in SB1 while in the Template Setup, it does not show up on my site. I have tried the sidebar on the left and the right and it makes no difference. You can see I had no problem with the footer. What am I missing?

Share this post


Link to post
Share on other sites
James B    436
James B

Hi Ginny, can you set me up as a user and email the details to me (i'll pm you my email address) and I'll look in and have a look to try and work out whats happening for you. I'm UK based so if there's a delay in response its due to the time difference.


Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites
ginnywills    0
ginnywills

Thanks James. I have set you up and emailed you the information. I noticed this morning if you drag the browser to a really small size, the sidebar does show up (but looks crap).

Share this post


Link to post
Share on other sites
ginnywills    0
ginnywills

I have not heard from him but I have noticed that the sidebar is showing again. It seems to be running over into the main content area, so I am hoping he is still working on it. I am very curious to learn what went wrong or what I had done to cause the issue!

Share this post


Link to post
Share on other sites
ginnywills    0
ginnywills

Is there a way to make the sidebar scroll when I scroll through the content? By the time I get to the end of the content, the footer is sitting on top of the sidebar.

Share this post


Link to post
Share on other sites
James B    436
James B

The issue was that your sidebar was set in the css to a width of 0px. I've overridden this now for you in the custom css box and it's displaying on your site.

The problem with the display on mobile devices seems to be to do with your custom css. The responsive design will move the sections to suit the width of the browser and rearrange them. However, some of the sections you've fixed with Css, and adjusted-removed some of the padding/line spacing which is why it isn't reacting very well on the mobile screen. You can adjust the css for mobile devices only, so you could correct it manually if you like the set up you have on the larger screens.


Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites
James B    436
James B

Hi Ginny, sorry I've just seen your other comments. Yes the sidebar will scroll normally, but someone has set some custom css in Pagelines>Site Options>Custom Code which has made it fixed. If you remove this, the sidebar will scroll as normal.

Alot of the issues relating to the mobile layout are also down to some of the css in the custom code box. Its obviously been put there for a reason originally, so I'd suggest you get the person who made the alterations to go back in there double check it to make sure its required still :-)

Let us know if you require any further assistance


Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Similar Content

    • artos90
      By artos90+
      I am trying to start from scratch and create a page template. i have inserted the navbar and header with a text area and the primary sidebar on the right hand side of the page. 
       
      My page is 1200 pixels wide and I want to have the text column to be 900 pixels and the sidebar column 300 pixels
       
      I have tried adding a two column and three column into the section and adjusting the sizes of the text area and the sidebar.
       
      When I get the text area width above 6/12 and the sidebar 3/12 the sidebar jumps to the bottom of the section with the text area above it. 
       
      Any Ideas? What am I missing here? Appreciate any help!
    • redstate
      By redstate
      I'm just trying to set up a standard website with a primary sidebar in the right column and blog on the Homepage beneath a RevSlider, Highlight and ibox. The templates seem to have changed with DMS2. Please tell me how to set this up. On a DMS1 website, I set up a Home page template, inside pages template and 2 others, needing only a little help.
       
      On this DMS2 website, I just want a Home page template and all other pages template. Please tell me how. The website is rockwallrocks.com.
       
      Thanks!
    • meanmcbean
      By meanmcbean
      Hi, the Primary sidebar on my site's Calendar page looks great on Chrome, but doesn't show in Firefox or IE?  The crazy thing is that it worked fine while on my test site.  But now this problem has appeared on my client's live site.  I am using DMS 1 and Wordpress 3.9.  I deactivated all plugins and the problem still remains.  Here is the Calendar page's link... http://eastondems.com/calendar-3/.  You'll see that the sidebar is visible only in Chrome.  Not sure how to fix this?
    • himalaya01
      By himalaya01
      My primary sidebar is full of widgets, when I go to the widget menu in wordpress I don't see any widgets in the universal sidebar.
      What do you suggest me to do? 
       
      Thank in advance!
    • hjerterom333
      By hjerterom333
      Dear PageLines team,

      Hi. How are you doing today?
       
      While I was editing my website, something happened to my Primary SIdebar.
      It looks like this. [x]  Unfortunately, I have no idea why this has happened.

      This width cannot afford what I want to show (e.g. categories, monthly archives) in each line.
      Would you kindly tell me how to adjust the width?
       
      Thank you in advance for your support.
       
      Ayumu
×