Jump to content
Sign in to follow this  
biltonsilver

Font color for mobile menu

Recommended Posts

biltonsilver    0
biltonsilver

Hi,

Due to browser compatability issues with the black transparent top menu, I use the light grey one. This is great for browsers but the mobile menu has white text and makes it unreadable.

Does anyone know the custon css i can use in Pagelines lite?

Many thanks

Share this post


Link to post
Share on other sites
catrina    103
catrina

This documentation shows you how to change link colors: http://www.w3schools.com/css/css_link.asp

However, to take advantage of the browser specific plugin, which allows you to change CSS for different devices (internet browsers and phones), you will need to upgrade to PageLines Framework.


Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites
biltonsilver    0
biltonsilver

Hey Catrina,

Thanks for your reply. The menu link color is fine in standard size; only when the menu is condensed (or collapsed i think PL calls it) the links go white which makes them unreadable against the grey background.

I am building a website for a charity and cannot spend $139 for this only benefit.

If you point me toward any custom css i could use to fix this I would be most grateful.

Regards,

Matt

Share this post


Link to post
Share on other sites
biltonsilver    0
biltonsilver

This is one of the offending styles: removing the bold line fixes the "child" menu items but not the parent

#site .navbar .dropdown-menu a {

padding: 6px 15px;

background: none repeat scroll 0% 0% transparent;

color: rgb(255, 255, 255);

border-radius: 3px 3px 3px 3px;

Share this post


Link to post
Share on other sites
biltonsilver    0
biltonsilver

and the one for the parent menu items:

#site .navbar .navline > li > a {

margin-bottom: 2px;

padding: 6px 15px;

background: none repeat scroll 0% 0% transparent;

color: rgb(255, 255, 255);

border-radius: 3px 3px 3px 3px;

}

if only i could figure out how to fix this is the custom code css so im not hacking up PageLines core files.....

Share this post


Link to post
Share on other sites
biltonsilver    0
biltonsilver

sorted!!

I put this in custom css


#site .navbar .navline > li > a {

    color: rgb(0, 0, 0);

}

#site .navbar .dropdown-menu a {

    color: rgb(0, 0, 0);

}

:D

Share this post


Link to post
Share on other sites
Danny    1,327
Danny

The topic was marked as resolved.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
biltonsilver    0
biltonsilver

and....

to fix the changed link hover text color:


#site .navbar .dropdown-menu a:hover {

			 color: rgb(255, 255, 255);

}

Share this post


Link to post
Share on other sites
Rob    547
Rob

Excellent.


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
Rob    547
Rob

The topic was marked as resolved.


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Similar Content

    • janpeeters
      By janpeeters+
      Over the last month I had extensive communications with the developer of the (premium) Anything Boxes section (in Pagelines store) (Adam Munns) and the developer of the WP Polylang Multilingual plugin (Frederic Demarle).
       
      This was because the following problem occurred:
      Anything Boxes showed all posts of two languages (Dutch and English) on the respective static frontpages for each language. It should of course have filtered posts for Dutch language on the Dutch frontpage and English on the English frontpage.
       
      The solution to this problem was simple in the end. When duplicating a page for use in another language the settings for Anything Boxes were not copied to the new page and I should have set these settings manually again on the new page. I wasn't aware of this, but it makes sense. Because of this the pages didn't know how to differentiate between posts from different languages.
       
      The dev of Polylang told me that Polylang is currently smart enough to synchronize metas like Featured images and page templates but it does not work out of the box with metas created by plugins and themes but (according to Frederic) it is rather easy to add them in the list using the filter 'pll_copy_post_metas'.
      He mentions that he is not sure that these 'PageLines Meta Settings' are stored in post meta but that would make sense according to him. He asks if the Pagelines dev team will be interested to support this feature in the future.
       
      I'm also wondering if you will consider adding Polylang translation support for manually editable strings like the 'Read more…' strings in Pagelines Settings.
       
      Well that's of course up to you but I thought to let you know to be able to take this into consideration. I also post this for other users in case they experience the same kind of trouble and are looking for an answer.
       
      Best regards,
      Jan Peeters
    • bankrollbuilder
      By bankrollbuilder
      I used a custom hook to put a banner ad in my header. It works but its not in the right position. it is centered and above my logo and I would like to float it to the right of my logo in the header. heres the link: http://shaboopie.com/shaboopie-wp/free-logos-pg1/

      thanks.

      Dan B.
    • starlit
      By starlit
      Can one have two hero sections on one page?

      I want a landing page which leads/advertises two subpages.

      Or is there another option?

      Please help.

      THANK YOU
    • hutruk
      By hutruk
      Hi!

      I am using the shortcodes for tabs, as described in the documentation.

      When I insert the following code:


      [pl_tabs][pl_tabtitlesection type="tabs"] [pl_tabtitle number="1"]Title 1[/pl_tabtitle] [pl_tabtitle number="2"]Title 2[/pl_tabtitle] [/pl_tabtitlesection] [pl_tabcontentsection] [pl_tabcontent active="yes" number="1"] Lorem ipsum dolor sit amet, consectetur adipiscing elit [/pl_tabcontent] [pl_tabcontent number="2"] Lorem ipsum dolor sit amet, consectetur adipiscing elit [/pl_tabcontent] [/pl_tabcontentsection] [/pl_tabs]

      I get a strange output (in the attachment).

      Any ideas?

      Thanks in advance!

    • MooiWeb
      By MooiWeb
      Hello,

      I would like to align my qtranslate with my breadcrumb so that the flags are on the same hight.
      I'm aware of putting a code in the custom css and tryed severall codes from your site but for now, no succes

      The site i'm working on is http://nieuw.vazdias.nl

      Thx,
      Edwin



×