Jump to content
thorstone137

Broken CSS with New Install at Pagoda Box

Recommended Posts

thorstone137

Hey Guys, I've recent jumped over to Pagoda Box ( Object Oriented Hosting Framework ); which I'm hoping isn't to good to be true..

I just pushed Pagelines 2.3 and intitially everything worked. But, now my LESS compiled CSS Path is broken for some reason rwoac.us

Here's the response I got..

data:text/html;,<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN"><html><head><title>404 Not Found</title></head><body><h1>Not Found</h1><p>The requested URL /wp-content/themes/pagelines/pagelines-compiled-css-1_1348983099/ was not found on this server.</p></body></html>

I checked gtmetrix.com and posted a screen shot for ya..

I've also posted a ticket at Pagoda Box.

Is there I dependency that Pagoda is missing? It seems like it might be a rewrite issue..

post-19868-0-54349900-1348984910_thumb.p


Best Regards! Pagelines = Innovation!

Share this post


Link to post
Share on other sites
Danny

Hi,

Try adding this to your wo-config file:

define( 'LESS_FILE_MODE', true );[/CODE]

and see if this resolves your issue.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
thorstone137

I'm getting this error

Warning: Invalid argument supplied for foreach() in /var/www/wp-content/themes/pagelines/includes/class.render.css.php on line 706


Best Regards! Pagelines = Innovation!

Share this post


Link to post
Share on other sites
Danny

Hi,

You received that error after adding the code I provided above ?


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
thorstone137

Yes. I got that error after following your instructions. Pagoda Box is run on Apache2 but there are some non-traditional configurations happening to support their automation. I'm working with them as well. Neither I nor the Pagoda Box Support Tech I'm working with is super familiar with LESS and I'm still not sure what dependences specific to Pagelines are required. As far as I can tell it is a simple read write permissions problem.

I appreciate your attention to this matter..


Best Regards! Pagelines = Innovation!

Share this post


Link to post
Share on other sites
Rob

LESS is a dynamic stylesheet. See this for more info: http://lesscss.org/

LESS shouldn't really break if WP works. The problem I'm seeing is, you're getting a message about an unknown App. WordPress isn't an App. So my question is... without PageLines, is WordPress working with Twenty Ten or Twenty Eleven theme (preinstalled with WP)?


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
thorstone137

LESS shouldn't really break if WP works. The problem I'm seeing is, you're getting a message about an unknown App. WordPress isn't an App. So my question is... without PageLines, is WordPress working with Twenty Ten or Twenty Eleven theme (preinstalled with WP)?
- Rob

Rob, Yep. It works fine with the other themes.. I'll relay this thought to Pagoda Box..

If you have any ideas in the meantime. I'd appreciate it. Like I said, "Pagoda Box is run on Apache2 but there are some non-traditional configurations happening to support their automation"...


Best Regards! Pagelines = Innovation!

Share this post


Link to post
Share on other sites
thorstone137

Right.. Thanks Simon. :wacko:


Best Regards! Pagelines = Innovation!

Share this post


Link to post
Share on other sites
thorstone137

Um. So, regular themes work for me regardless of permalink settings. But, pagelines is only allowing the default setting. So, this is not resolved..


Best Regards! Pagelines = Innovation!

Share this post


Link to post
Share on other sites
Rob

Permalinks may be readily changed and read properly with PageLines Framework. My own sites all use custom permalink settings. There has never been a single problem with any of the 12 sites I own or manage.

We do not alter, amend, or change in any way, the elements of the WordPress functions.


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
Simon

Add

define( 'PL_NO_DYNAMIC_URL', true );[/CODE]

to wp-config.php

Share this post


Link to post
Share on other sites
thorstone137

Thank you Gentlemen for the tips! I'm good to go!

Pagoda Box requires Git versioning. I've been cowboying it until now and with the change in workflow my .htaccess file was being saved as a text file. Ugh.. Lamo I know.

Again I appreciate the help.

Best Regards, Dustin


Best Regards! Pagelines = Innovation!

Share this post


Link to post
Share on other sites
Danny

The topic was marked as resolved.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Similar Content

    • chamois_blanc
      By chamois_blanc+
      Hello,
      Shouldn't the image PL5 component be using the srcset/picture css directives to pick the correct size for an image? or it does already and I don't know how to use it? Thank you for any advice or enlightenment.
    • Dan Haddock
      By Dan Haddock
      Plugins Active and installed: 
      Akismet Anti-Spam
      Coming Soon Page & Maintenance Mode by SeedProd
      Contact Form 7
      Cookie Law Info
      DMS Professional Tools  
      Enhanced Media Library  
      Flamingo
      Google Analytics for WordPress by MonsterInsights
      Google XML Sitemap
      Jetpack by WordPress.com
      Legull 
      Loginizer   
      MailChimp for WordPress
      PageLines Updater    
      Schema App Structured Data 
      Sucuri Security - Auditing, Malware Scanner and Hardening
      Uber reCaptcha    
      Yoast SEO
      Wordpress Version: 4.8.1
      Pagelines Version: 2.2.4
       
      Good Evening/Afternoon or Morning, 
      I am running into a problem with CSS styling not applying inside of most browsers (Safari, Firefox) when I am logged in to wordpress, and all browsers that I have tested when I am logged off and the site has been made public (Chrome, Firefox and Safari).
      As a result, I have managed to identify the probable cause. It looks as though these browsers are refusing to render my sites compiled CSS file due to it being a HTTP URL rather than HTTPS.
      I have attempted to change this URL to HTTPS in my browser, however it brings back an ERROR: File not found page - https://www.shortfilmblog.com/wp-content/uploads/pagelines/compiled-css-core-1505847507.css
      What would you suggest in this regard? Would this be resolvable from your end?
      Happy to provide any further details required.
    • Borries
      By Borries+
      I know this is not an easy problem. Maybe there is a easy solution.
      I have tryed to uses the existing solution, that I have found in the forum
      I changed the colours of my nav (simple nav) and the hover effect (a. hover).
      I really tryed to highlight the active/used link in the nav but I cant figure it out.
      I want it to be black when active.
      Any help would be appreciated. Thanks.
      http://www.marcborries.de  nav link: "Sinn & Selbst" 
    • Michael Kummer
      By Michael Kummer+
      Hi guys,
      every since Chrome introduce scroll anchoring (see chrome://flags) blog posts on my page start scroll automatically as soon as the user scrolls down a bit. It is super annoying and I don't know exactly what triggers the incompatibility with Chrome's latest feature that is supposed to improve usability.
      Since I don't know what causes it (Pagelines, or a Plugin), I would like to disable the feature using a CSS override that Google describes as follow:
      "Scroll anchoring aims to be the default mode of behavior when launched, so that users benefit from it even on legacy content. A CSS property overflow-anchor can disable scroll anchoring in part or all of a webpage (opt out), or exclude portions of the DOM from the anchor node selection algorithm. This property supports the following values when applied to an element E:
      overflow-anchor: auto (the default value) declares that the DOM subtree rooted at E is eligible to participate in the anchor node selection algorithm for any scrolling box created by E or an ancestor of E. overflow-anchor: none declares that the DOM subtree rooted at E is not eligible to participate in the anchor node selection algorithm for any scrolling box created by E or an ancestor of E." Do you guys happen to know how to use that property with the ROOT element so it applies to the whole page?
      Thanks
      Michael 
    • wyo22ski
      By wyo22ski+
      Hello,
       
      I'm basically a designer and understand a little on how to change CSS, etc., so please excuse my ignorance...  I recently upgraded to the newest platform from the DMS and my old DMS theme no longer functions.  I'm trying to replace the image slider that my Horizon Photography Theme (Nick Haskins) had created.  The Impulse image slider seemed the closest to what I need, but there are problems.
      It seems the the Impulse section for sliding images defaults to the image width, no the height.  I can change the Impulse stage height and width, but this does nothing to the internal content.  For instance, if I change the height to 200 pixels, the image remains the full width and only shows a cropped section.  I would like the ability to change the Impulse height, and have the image height fit space. 
      I've put this custom CSS in, but again, this only controls the stage height of Impulse:
      .pl-sn-impulse .pl-impulse-cell .cell-wrap, .pl-impulse-container, .owl-stage-outer {
        width: 100%;
      }
       
      Any suggestions welcome.  Thanks 
×