Jump to content
Sign in to follow this  
wandr_mari

Can't remove grey background & images in a slideshow's thumbnails since 2.3 upgrade

Recommended Posts

wandr_mari

Hi, After updating to 2.3, I have been unable to remove some background images, colors and borders on a page of thumbnails I want to use for a portfolio page. Here's a link to what I'm talking about: http://www.maripfeif...olio-slideshow/

I used the Firefox Firebug to find the CSS and change it; it worked live, then I put it in my Custom CSS box, saved the changes and refreshed the page. The thumbnails still had a grey background and when I hovered over a thumbnail, a grey background would appear.

I'm using the Framework 2.3, the latest version of Wordpress and the slideshow plugin I'm using is the Slideshow Pro plugin from Raygun. I did use the NextGen gallery before but didn't like it.

I disabled plugins to see if there was some kind of a conflict; none that I could find.

Here's the interesting thing: I switched themes for a moment to the default twentyeleven them and there were no grey backgrounds or grey hover in the backgrounds. So, I think it's a Pagelines thing. See the attached screenshot.

Could you please help me? I like PL a lot, and I really don't want to change themes at this point.

Thanks in advance for your help.

~ mari


Have an okay day.

maripfeiffer.com

Share this post


Link to post
Share on other sites
Rob

Try:

.pager a, .pager span {

    display: inline-block;

   padding: 0 5px 14px;

}

I have no idea if this will work. There's still a hover action I can't seem to narrow down either. What's creating this selection of products? A plugin?


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
wandr_mari

Hi Rob, Yes, it's a plugin, the Slideshow Pro from made by Raygun. I didn't like the NextGen plugin - to me, it was messy and didn't give the result I was looking for. This slideshow pro plugin can do a lot of things, and that's why I am using it.

I'll try your code, see if it works; i'm having someone from Raygun help, too.

I hate to say this but I do think it's a Pagelines issue. I'm wondering if this has anything to do with the PL pagination? I'm just thinking out loud here...the plugin works beautifully on other themes (grr).

One other thing I noticed was that when I changed the CSS to "display: none;" for example, to get rid of the grey stuff, I found another line of CSS code that had the same information. So, I think there's a duplicate CSS rule going on there...

Well, I'll try a few more things. Please don't mark this resolved yet...


Have an okay day.

maripfeiffer.com

Share this post


Link to post
Share on other sites
Rob

Well, topics remain open till you say the issue is fixed.

It very well could be a conflict with the plugin and PL 2.3. We changed several CSS selectors and switched to LESS, completely. That could have caused an issue with the plugin if it's not prepared for it.

I found the code below works, but there's an empty

<span>
tag with a closing one inside the grey box with rounded corners. When I use Firebug and remove the opening and closing span tags, I can successfully apply the code below and get a borderless image.
.pager a, .pager span {

background-color: #F3F3F3;

background-image: -moz-linear-gradient(center top , #F6F6F6, #EFEFEF);

background-repeat: repeat-x;

border: 1px solid #DDDDDD;

border-radius: 15px 15px 15px 15px;

display: inline-block;

padding: 0;

}

[/code]

Please show them the attached snapshots. You'll see a tiny oval within the rounded box. That oval is the span tags.

In the second image, I've removed the span tags and changed the padding to 0 (zero) and the images line up perfectly.

post-6-0-03076800-1348952676_thumb.png

post-6-0-95925800-1348952688_thumb.png


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Similar Content

    • Michael Kummer
      By Michael Kummer+
      Hi guys!
      I have noticed that my primary sidebar becomes intermittently invisible when browsing through various blog articles on michaelkummer.com/blog.
      See:
      https://www.dropbox.com/s/z646sgoa3mfjl1j/Screenshot 2018-07-12 15.57.46.jpg?dl=0 and https://www.dropbox.com/s/vdledzzgginvwgv/Screenshot 2018-07-12 15.57.57.jpg?dl=0
      Upon refresh, the sidebar appears. I have been using the following CSS code to hide the sidebar on mobile without any issues. 
      @media only screen and (max-width: 993px) {
      /* hide sidebars */
           .plsb {
              display: none !important;
          }
      }
      I tried to add the following CSS to force the sidebar to show on screens that are wider than 994 pixels but to no avail. Any clue what could be causing this issue?
    • Michael Kummer
      By Michael Kummer+
      Hi guys!
      I am using the LESS/CSS Pagelines extension and tried to add the following code to make use of FontAwesome:
      a.c2a:before {
          content: "\f07a\00a0";
          font-family: "Font Awesome 5 Pro";
          Font-weight: 900;
          font-style: normal;
          font-weight: normal;
          text-decoration: inherit;
          padding-left: 4px;
      }
       
      The issue is that as soon as I have the CSS via the Custom Styling text box, Pagelines (or the extension) strips out the backslashes (\). As a result, I had to abandon the CSS/LESS extension and instead add all my CSS code to a separate .css file.
      Is there a fix or workaround for this?
      Thanks
      Michael
    • glyph.marketing
      By glyph.marketing+
      Hello, I am having a problem similar to that experienced by Michael Kummer here. We have pages that show this automatic scrolling issue (examples here and here) and it is sufficiently annoying that we have seen customers bounce while trying to convert. Strangely, it only happens at specific resolutions, so it can be difficult to reproduce. In general we can only consistently reproduce it on a 4k resolution with a browser width between 1517 and 1536px. 
      Thanks to Michael Kummer's help we were able to set the overflow-anchor property to none in the entire body, which fixed the issue as far as we can tell, but also obviously disabled scroll anchoring for the whole site. I tried applying it to the specific element that looked like it was being reloaded, which was the PL Meganav extension, but that was unsuccessful. 
      Can anyone help us figure out which element or ID we can apply this property to, so that we can fix the scrolling issue but not disable scroll anchoring for the entire site?
      Thank you - 
      Glyph Language Services
    • chamois_blanc
      By chamois_blanc+
      Hello,
      Shouldn't the image PL5 component be using the srcset/picture css directives to pick the correct size for an image? or it does already and I don't know how to use it? Thank you for any advice or enlightenment.
    • Dan Haddock
      By Dan Haddock
      Plugins Active and installed: 
      Akismet Anti-Spam
      Coming Soon Page & Maintenance Mode by SeedProd
      Contact Form 7
      Cookie Law Info
      DMS Professional Tools  
      Enhanced Media Library  
      Flamingo
      Google Analytics for WordPress by MonsterInsights
      Google XML Sitemap
      Jetpack by WordPress.com
      Legull 
      Loginizer   
      MailChimp for WordPress
      PageLines Updater    
      Schema App Structured Data 
      Sucuri Security - Auditing, Malware Scanner and Hardening
      Uber reCaptcha    
      Yoast SEO
      Wordpress Version: 4.8.1
      Pagelines Version: 2.2.4
       
      Good Evening/Afternoon or Morning, 
      I am running into a problem with CSS styling not applying inside of most browsers (Safari, Firefox) when I am logged in to wordpress, and all browsers that I have tested when I am logged off and the site has been made public (Chrome, Firefox and Safari).
      As a result, I have managed to identify the probable cause. It looks as though these browsers are refusing to render my sites compiled CSS file due to it being a HTTP URL rather than HTTPS.
      I have attempted to change this URL to HTTPS in my browser, however it brings back an ERROR: File not found page - https://www.shortfilmblog.com/wp-content/uploads/pagelines/compiled-css-core-1505847507.css
      What would you suggest in this regard? Would this be resolvable from your end?
      Happy to provide any further details required.
×