Jump to content
brightgreenhomes

Style Sheet Missing

Recommended Posts

brightgreenhomes

Hi,

I have a site - www.bhesco.co.uk - and when performing an update yesterday it seems that the style sheet has gone missing.

I have checked my hosting file manager online and all the folders seem to still be there?

The site doesn't load, and re-installing pagelines framework 2.0 doesn't work because it is already installed?

I am not a developer, so have pretty average skills - but this seems to be a problem that occured when I upgraded... please help... this is a new venture and i REALLY need this website up asap...

Alex

wordpress issue.tiff

Share this post


Link to post
Share on other sites
catrina

What specific stylesheet are you referring to? Is it the style.css file in either PageLines Customize or the base theme?


Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites
brightgreenhomes

Hi,

its pagelines framework - just went to upgrade it yesterday from 2.5 to 2.3 and the website has just stopped working?

now all i have is a blank page and when you visit the themes section in the dashboad it says that the stlysheet is missing (as I tried to show in the tiff?)

Share this post


Link to post
Share on other sites
Rob

Three things can cause this:

1. Bad plugins - check all, make sure they're up to date.

2. Bad code in a functions.php file. - make sure the function.php is up to date.

3. Bad installation of 2.3 - remove wp-content/themes/pagelines and reinstall via FTP to the same location. Do not attempt to overwrite the files. This won't always work. (NOTE: No customizations properly made will be lost!)


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
Simon

White screen, thats a PHP error, open wp-config.php and uncomment WP_DEBUG line, and set to true.

Id say the theme folder is missing and wordpress is throwing a fatal error.

Share this post


Link to post
Share on other sites
brightgreenhomes

Hi,

I have tried all the plugins, disabled them all and tried to reload - again nothing?

I have also amended the wp-config.php file to 'true' and nothing again?

I have been to my host and made sure that the .php configuration is up to date...

Not entirely sure how I go about removing wp-content/themes/pagelines folder - I can deleter it via FTP, but what do I repace it with? the pagelines.zip file that I used to install 2.0 doesn't have a pagelines folder? or is this whole unzipped file the 'theme'?

Please bear with me as I am not a developer - rather a self taught amateur...

Thanks - Alex

Share this post


Link to post
Share on other sites
Danny

Hi,

Can you take a screenshot of your file and directory structure please. So we can make sure you have everything installed correctly.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
brightgreenhomes

Everything was working perfectly correctly when I pressed the button to upgrade pagelines 2.5 to 3.0

Since then it is not. So - it is reasonable to assume that it is something to do with the upgrade?

I only have 44.78kb of file space to upload to - when I reduce the picture size to <50kb the res is so bad you can't read it - should i start this thread again so I have the full amount of space again? The original tiff I uploaded showed that on the home page of WP dashboad it says in red:

ERROR: The themes directory is either empty or doesn’t exist. Please check your installation.

You are using WordPress 3.4.2.

and on the themes page:

Broken Themes

The following themes are installed but incomplete. Themes must have a stylesheet and a template. Name Description pagelines Stylesheet is missing. twentyeleven Stylesheet is missing. twentyten Stylesheet is missing.

Share this post


Link to post
Share on other sites
Danny

Ok, but can you load up your FTP client navigate to the Wordpress directory, open the wp-content folder as well as the themes folder and take a screenshot please.

Also, there is no possible way as far as I am aware that our update process can remove the Wordpress default themes.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
brightgreenhomes

yes - but as I said the trouble is that this support forum says I can only upload a screenshot of maximum 44.78kb of files - and the screenshot of any decent resolution is unreadable. So how would you like me to upload this?

Share this post


Link to post
Share on other sites
Simon

Why are you saving screenshots as tiff files? I dont even know what a tiff is!!

Upload you screenshots to imgur.com and please use jpegs

Share this post


Link to post
Share on other sites
brightgreenhomes

shall we start a new thread if this allows me to begin with the full complement of space for an upload?

Share this post


Link to post
Share on other sites
Simon

No please dont start a new thread, you can manage your attachments in your user settings. Just dont upload tiffs ( whatever they are )

Share this post


Link to post
Share on other sites
Danny

Ok, those images are poor in quality I cant see the text properly. Therefore, can you PM me and send me your FTP details so we can take a closer look please.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
brightgreenhomes

now all i am seeing is:

Fatal error: Call to undefined function pl_default_setting() in /content/Hosting/b/h/bhesco.co.uk/web/wp-content/themes/pagelines-mud/functions.php on line 26

this is really starting to confuse and frustrate me... this is a new venture we are launching and having the site down is a major problem and I am at a loss for what to do? please help?

Share this post


Link to post
Share on other sites
brightgreenhomes

no - i haven't edited that file.

I pressed update from pagelines 2.5 to pagelines 3.0 - then the theme style sheets became deleted and the site stopped working...

thats it.

  • Like 1

Share this post


Link to post
Share on other sites
Simon

Updating a theme would not cause the 2010 and 2011 theme folders to become empty.

I have looked on your FTP, both wordpress theme folders are empty, and the pagelines folder only has an empty admin folder and an empty css folder.

You need to start by downloading to 2010 theme and the 2011 theme from wordpress.org, unzip them and FTP the contents into the empty dirs.

Then download pagelines.zip from your members area and do the same, making sure ALL files transfer properly. Clearly your host will not let you use the wordpress inbuilt upgrader without destroying itself.

Share this post


Link to post
Share on other sites
stebac

Hi all.

I have had the exact same problem as brightgreenhomes tonight. Everything he has mentioned in this thread has happened to me in the exact same way. I went to update to pagelines 3.0 and something went wrong and the stylesheet has gone missing and site vanished. I originally got a white screen with a short maintenance message on it asking to check back in a few minutes.

I am also a self taught amateur and not a developer so i cant rely contribute with a solution, only add to the confusion and frustration :unsure:

I use GoDaddy hosting applications to set up Wordpress.

Luckily i was setting up a new site when it happened so i deleted everything within my hosting and started again, unfortunately it has happened the second time of trying.

I like the last post though, installing the files manually will probably be a better idea. I have a friend a little more knowledgeable than me to help me with that fortunately so i will be giving that a go.

I just thought i should post to highlight that this is not an isolated incident.

Share this post


Link to post
Share on other sites
Simon

stebac Well sorry your host has the same restrictions as the OP, PageLines does not use ANY custom code for the update, we just tell wordpress where to grab the zip, it does the rest.

  • Like 1

Share this post


Link to post
Share on other sites
brightgreenhomes

Thanks Stebac - I love the way developers make pronouncements like "Updating a theme would not cause the 2010 and 2011 theme folders to become empty." when CLEARLY it does happen.... it must be something to do with the host/program/user interface but it clearly DOES happen. Its nice to know i'm not the only one.

Ok - so I have used filezilla to replace all the files in the pagelines theme... and hurrah we have a site back - not quite as it was but its a start... thanks...

now it asked me to update to pagelines 2.3... which (after first attempt not working and deleting all the files in the theme on my host again - reloading and starting again).... worked, then these error messages appeared:

Can someone please explain what they mean - thanks.

Notice: has_cap was called with an argument that is deprecated since version 2.0! Usage of user levels by plugins and themes is deprecated. Use roles and capabilities instead. in /content/Hosting/b/h/bhesco.co.uk/web/wp-includes/functions.php on line 2722

Notice: has_cap was called with an argument that is deprecated since version 2.0! Usage of user levels by plugins and themes is deprecated. Use roles and capabilities instead. in /content/Hosting/b/h/bhesco.co.uk/web/wp-includes/functions.php on line 2722

Notice: Undefined index: update in /content/Hosting/b/h/bhesco.co.uk/web/wp-content/plugins/cforms/cforms.php(48) : runtime-created function on line 1

It’s so nice to have you back where you belong

Notice: Undefined index: update in /content/Hosting/b/h/bhesco.co.uk/web/wp-content/plugins/cforms/cforms-options.php on line 13

Notice: Undefined index: cforms_confirmerr in /content/Hosting/b/h/bhesco.co.uk/web/wp-content/plugins/cforms/lib_options_err.php on line 3

Share this post


Link to post
Share on other sites
brightgreenhomes

oh, and deactivating all of the plugins to see if this is the problem ends up leaving me with a white page that says:

Notice: has_cap was called with an argument that is deprecated since version 2.0! Usage of user levels by plugins and themes is deprecated. Use roles and capabilities instead. in /content/Hosting/b/h/bhesco.co.uk/web/wp-includes/functions.php on line 2722

Notice: has_cap was called with an argument that is deprecated since version 2.0! Usage of user levels by plugins and themes is deprecated. Use roles and capabilities instead. in /content/Hosting/b/h/bhesco.co.uk/web/wp-includes/functions.php on line 2722

Warning: Cannot modify header information - headers already sent by (output started at /content/Hosting/b/h/bhesco.co.uk/web/wp-includes/functions.php:2722) in /content/Hosting/b/h/bhesco.co.uk/web/wp-includes/pluggable.php on line 881

Share this post


Link to post
Share on other sites
Simon

Well that error is caused by a plugin, using code that was deprecated in 2.0 of wordpress, which was 7 years ago.

Id turn off WP_DEBUG now, most plugin devs do not use debug and their code is sloppy.

Share this post


Link to post
Share on other sites
brightgreenhomes

HI,

OK - so the site is up and running again and I have turned off the debug:

But there is another new error message -

PageLines Sections LESS/CSS error.

expected color value: failed at `color: fadeout(@authorplusHeadingColor, 70%);` line: 2879

It doesn't seem to be having a massively detrimental effect, but nonetheless it would be nice to resolve...

we are getting there!! phew...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Similar Content

    • dreamsight
      By dreamsight
      We are using Mouseflow on a client's site and we keep having problems with the recordings of the site.
       
      The problem is when the two stylesheets are updated ('compiled-css-sections-1422467206.css' and 'compiled-css-core-1422467206.css'), they're automatically renamed. But the recordings made before this change are still looking for the previous version, which no longer exist on the server.
       
      To get around this issue in the future, I need to redirect Mouseflow (which I can do as a Mouseflow comment) to a stable version of these style sheets.
       
      Any idea how to get a stable version of them?
    • SaschaM
      By SaschaM+
      How can i change the iBox link style to:
       
       /* unvisited link */
      a:link {
      color: #FF0000;
      }

      /* visited link */
      a:visited {
      color: #00FF00;
      }

      /* mouse over link */
      a:hover {
      color: #FF00FF;
      }

      /* selected link */
      a:active {
      color: #0000FF;
      }
       
       
      In addition please see attachement screen in red
    • janpeeters
      By janpeeters
      Over the last month I had extensive communications with the developer of the (premium) Anything Boxes section (in Pagelines store) (Adam Munns) and the developer of the WP Polylang Multilingual plugin (Frederic Demarle).
       
      This was because the following problem occurred:
      Anything Boxes showed all posts of two languages (Dutch and English) on the respective static frontpages for each language. It should of course have filtered posts for Dutch language on the Dutch frontpage and English on the English frontpage.
       
      The solution to this problem was simple in the end. When duplicating a page for use in another language the settings for Anything Boxes were not copied to the new page and I should have set these settings manually again on the new page. I wasn't aware of this, but it makes sense. Because of this the pages didn't know how to differentiate between posts from different languages.
       
      The dev of Polylang told me that Polylang is currently smart enough to synchronize metas like Featured images and page templates but it does not work out of the box with metas created by plugins and themes but (according to Frederic) it is rather easy to add them in the list using the filter 'pll_copy_post_metas'.
      He mentions that he is not sure that these 'PageLines Meta Settings' are stored in post meta but that would make sense according to him. He asks if the Pagelines dev team will be interested to support this feature in the future.
       
      I'm also wondering if you will consider adding Polylang translation support for manually editable strings like the 'Read more…' strings in Pagelines Settings.
       
      Well that's of course up to you but I thought to let you know to be able to take this into consideration. I also post this for other users in case they experience the same kind of trouble and are looking for an answer.
       
      Best regards,
      Jan Peeters
    • bankrollbuilder
      By bankrollbuilder
      I used a custom hook to put a banner ad in my header. It works but its not in the right position. it is centered and above my logo and I would like to float it to the right of my logo in the header. heres the link: http://shaboopie.com/shaboopie-wp/free-logos-pg1/

      thanks.

      Dan B.
    • starlit
      By starlit
      Can one have two hero sections on one page?

      I want a landing page which leads/advertises two subpages.

      Or is there another option?

      Please help.

      THANK YOU
×