Jump to content
iamklaus

Carousel in Content Area

Recommended Posts

iamklaus    0
iamklaus
Why isn't it possible to add a Carousel into the Content Area via Drag and drop? Why do we have that limitation or am I doing something wrong?

Share this post


Link to post
Share on other sites
Danny    1,327
Danny
Hi,

I am unsure of the reason as to why the Carousel is not available in the Content Area. However, you can change this if you like, although we will be unable to support you should you run into any errors.

To add Carousel support for the Content Area do the following:

1. Download a fresh a copy of PageLines Framework.
2. Navigate to sections/carousel and then open the Carousel's section.php file in a text editor.
3. Replace this code:

[CODE]
<?php
/*
Section: Carousel
Author: PageLines
Author URI: http://www.pagelines.com
Description: Creates a flickr, nextgen, or featured image carousel.
Class Name: PageLinesCarousel
Cloning: true
Workswith: content, header, footer
Edition: pro
*/
[/CODE]

With this:

[CODE]
<?php
/*
Section: Carousel
Author: PageLines
Author URI: http://www.pagelines.com
Description: Creates a flickr, nextgen, or featured image carousel.
Class Name: PageLinesCarousel
Cloning: true
Workswith: templates, main, content, header, footer
Edition: pro
*/
[/CODE]

4. Then save your changes.
5. Now you need to upload (via FTP) the Carousel folder containing the edited section.php file to either:
a) Your child themes section folder - wp-content/themes/child-theme/sections/
B) If you're not using a child theme, then upload the folder here - wp-content/plugins/pagelines-sections/
6. Once the folder has been uploaded, go to Wordpress Admin Dashboard > PageLines > Store and do nothing (simply refreshes the store).
7. Once the store has loaded, go to Wordpress Admin Dashboard > PageLines > Drag and Drop.
8 You should now see the Carousel section in the Content Area.

Please bear in mind that this type of customisation is not supported.
  • Like 1

Please search our forums, before posting!

Share this post


Link to post
Share on other sites
vogelwild    24
vogelwild

Great! I had the same problem. Now it works. Thank you!

Share this post


Link to post
Share on other sites
mackenzie    12
mackenzie

I have marked this topic as answered however let us know if you have questions.


Mackenzie - PageLines Help Desk

The Centsible Family - Writer, Photographer and Coffee Addict

---------------------------------------------------

Kindly search this forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

Share this post


Link to post
Share on other sites
Stephan Lipphardt    0
Stephan Lipphardt

Danny's Answer helped also me.

 

I hope in the next PageLines-Updates that this will consist the Update-Progress...

 

Thanks a lot.

Share this post


Link to post
Share on other sites
xcel7    1
xcel7

brilliant! Just what I was looking for!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Similar Content

    • oseehys
      By oseehys+
      The Grams section of Platform 5, is lacking lots of important features, that DMS multigram was having, there is no space for another user ID asie the default user, that was one of the strongest point of multigrams, because the Hashtag option cannot capture everyone, multiple User ID is the default standard for Instagram,  Also there is no carousel or slide on this one, it means now that if you want to display 18 pictures in one page all will be visible at once thats not good engineering.
      My appeal to the Pagelines Team, guys please let the next update have all the DMS Multigrams features that is missing on Platform 5 Grams, that will bring it to its glory...
       
       
    • onlinedesigns4u
      By onlinedesigns4u+
      Hi Guys, 
       
      I noticed this a while back but thought it happened back when there was security issues with the wordpress plugin revolution slider and thats why they disappeared, but thinking i was wrong now as mine are the DMS versions.
       
      Basically, my front end editor is missing the icons for;
       
      • Rev Slider
      • Revolution Slider
      • Quick Slider
       

       
       
      What i've also noticed is a difference in how the menu tabs on the left hand side of the front end editor have changed. They were not styled like this before. Its like the css is off or something isnt quite right with the install somehow, somewhere.
       
      Even though the icons are missing for the slider sections. I can still drag them onto my pages and configure them, to a certain degree anyway.
       
      I tried adding the revolution slider to a page yesterday. But it wasnt responding to the way i had configured it. I choose a slide set for it to use and it took no notice. It just used every slide and every caption regardless.
       
      Leaving the revolution slider behind i took a look at the rev slider. Adding the correct images is fine. But i don't get any captions showing when i set them? Tried a few different options but nothing.
       
      Id like to know if my pagelines DMS 2 install is corrupt in anyway? Does anyone else's front end editor look the same as mine? Is anyone else missing the icons for the sliders and have no padding-right for the menu items?
       
      Is anyone using any of the sliders at the moment without issues?
       
      Im using the child theme 'Sophistique" which uses the revolution slider on the homepage. It works fine and its configured the way i want it using thh slide sets ive choosen so dont understand why it would be working inside the website.
       
      Any advice or help is appreciated. Thank for your time guys. Ben
       
       
       
    • dgsarnow
      By dgsarnow+
      I have DMS2 installed and my site is being served over HTTPS. However, I am getting an error that a placeholder image for Quick Carousel (which is not a being used on any of my pages) is being served over http://
       
      Mixed Content: The page at 'https://harqen.com/'was loaded over HTTPS, but requested an insecure image 'http://placehold.it/45x45/f0f0f0/ccc'. This content should also be served over HTTPS.
       
      How can I remove this?
       
      Found it. It was the Recent Posts Widget that was calling this little devil. I have removed the reference and all is well in SSL land.
    • dgsarnow
      By dgsarnow+
      I just updated to the new theme and I am now getting errors on my HTTPS site that the quick carousel is trying to deliver content through HTTP.
       
      Mixed Content: The page at 'https://harqen.com/'was loaded over HTTPS, but requested an insecure script 'http://harqen.com/wp-content/themes/dms/sections/quickcarousel/caroufredsel.js?ver=98ab90'. This request has been blocked; the content must be served over HTTPS.
       
      Can you please help me correct this issue?
       
       
    • Dave2
      By Dave2
      I added the PL Carousel to my homepage and it seems to switch the height when it changes the displayed image. I have the images all set to the same size (height & width) so I am not sure why the carousel does this. It is a bit distracting in that it makes the page jerk up/down when the slide changes. Do I need to add a fixed height element around the carousel to stop this behaviour or is there some other setting I should use?
×