Jump to content
pracede

How to remove index.php in the permalinks ?

Recommended Posts

pracede    0
pracede

I use Pagelines developper edition. Wordpress is installed on the root directory of my server. I configure my permalink like http://mpmea-congo.com/index.php/sample-post/ (see attached file) this but all my link are formed like the following http://mpmea-congo.com/index.php/demarches-administratives/ having index.php in the permalink. I'd like to knnow how to remove it ?

Thanks

post-41565-0-01815200-1348141096_thumb.j

Share this post


Link to post
Share on other sites
Simon    247
Simon

This is a server config issue.

What server software is it?

Share this post


Link to post
Share on other sites
pracede    0
pracede

I don't know really. I don't have admin tool to monitor server. I just hava a ftp connexion link to upload my file. I ask to my hoster.

Share this post


Link to post
Share on other sites
Rob    547
Rob

What happens when you go to Dashboard > Settings > Permalinks and changing /index.php/%postname%/ to /%postname%/ and then saving?


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
pracede    0
pracede

@

Advocate

When i change the /index.php/%postname%/ to /%postname%/ , the web site send a 404 error.

@Simon Prosser The server is IIS the windows one not apache. But i don't have configuration tools to it

Share this post


Link to post
Share on other sites
Simon    247
Simon

Then you need to talk to your host.

Share this post


Link to post
Share on other sites
pracede    0
pracede

You think my problem is about web server configuration ? What i have to tell him: just my permalink are not good ? Or something else ?

Thanks

Share this post


Link to post
Share on other sites
Danny    1,327
Danny

Hi,

When you remove /index.php from your permalink structure, all your posts/pages will have index.php removed also. This will mean that if you navigate to any of your posts/pages and the link contains index.php/ then its obviously going to lead to a 404 error, as there is no such post or page.

Try this please.

  • Remove index.php/ from your permalinks, so you simply have /%postname%/, save your settings.
  • Then go to Wordpress admin dashboard > Posts or Pages and then click on the view Post/Page link and see if this leads to a 404 error. If it does, then its most certainly a server configuration error.

If you do indeed continue to receive this error, then please contact your web host provider, as this is not related to PageLines.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
pracede    0
pracede

@Danny I just make your test and always have 404 error from pages or posts display. I contact my host provider.

Share this post


Link to post
Share on other sites
Danny    1,327
Danny

OK, thanks for trying and yes contacting your host provider is the best option, as this is an issue only they can resolve.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Similar Content

    • marc.stubbe
      By marc.stubbe
      i created more than one page inspiration, with a result that the only current page inspiration is named: http://www.vmhdigital.nl/inspiration-3/
       
      I emptied the garbage bin, but cannot rename this permalink, do you know how to solve that?
    • juice-qr
      By juice-qr
      Hi, we're on pagelines 1.5.2 (I believe the free version) with wordpress 3.8.1,
       
      We have 2 servers, a new server running apache 2.2.15 with centos 6., and an older server with centos 5.5. running apache 2.4.2.
       
      Trying to figure out a caching issue on the newer server, when we make changes to the custom css, it's not being updated on the apache 2.2.15 server.  On the apache 2.4.2 server, it works fine.
       
      Is this possibly an issue with pagelines needing to be updated? Or is there an apache config somewhere I can check? I read that it might be an issue with the apache sendfile directive, I've turned that off on the new server.
       
    • jonesbre10
      By jonesbre10
      Hi,
       
      I am recieving the same error message for all of my posts "404! Sorry this page does not exist" and Im not sure what I did to cause it. I was able to view the posts fine recently.
       
      The only thing I have noticed is that all of my posts have the same permalink now which looks something like "www.website.com/rock". I admit I was messing around with permalinks for the different pages but I dont know now how to reset the posts or any permalinks. Even new posts now make this permalink connection with "www.website.com/rock".
       
      Any advice would help I dont know much about permalinks and would be happy just to reset them.
    • calvado32
      By calvado32+
      Hallo ,
       
      For some unknown reason, my site has suddenly started putting an error line:
      500 Internal Server Error
      The server encountered an internal error or misconfiguration and was unable to complete your request.
      bla...bla...
       
      I checked the server error log :
      mod_fcgid: stderr: PHP Warning: call_user_func_array() expects parameter 1 to be a valid callback, first array member is not a valid class name or object in /var/www/vhosts/polishdinner.de/httpdocs/wp-includes/plugin.php on line 406 or,
      Options FollowSymLinks or SymLinksIfOwnerMatch is off which implies that RewriteRule directive is forbidden: /var/www/vhosts/polishdinner.de/httpdocs/index.pl :stuff: Help! What I have to do ? I'm just a cook. :D
       
      Any help much appreciated
      thanks,
      Mariusz
    • seattle5021209
      By seattle5021209
      Hello and thank you for your help with these questions.
       
      I have two questions, but they are tied to one another so I decided to post them together.
       
      I would like to replicate the way the following website has set up their posts:
       
      http://www.loopinsight.com
       
      1. Straight Link to 3rd party sites - As you can see, if they are linking to a 3rd party article, they credit the article and when you click on the post title it takes you straight to an outside website [straight link], and not to the loopinsight.com post permalink.  
       
      I would like to set up my posts this way.  If I am writing my own content post, when visitors click on the title they should be taken to the post's permalink.  However, if I am linking to a 3rd party site post that I found interesting, when visitors click the title it should take them straight to that 3rd party site.
       
       
      2. Permalink Button - I would like to recreate the little loop besides every post [with my own button of course].  This little loop button takes you the post's permalink [http://www.loopinsight.com/...].  
       
      I would like to display a corresponding "Permalink" button next to each of my posts.
       
       
       
      Thank you so much for your help.
       
       
×