Jump to content
Sign in to follow this  
adpearance

Feature Setup Settings Won't Save

Recommended Posts

adpearance

When I click 'Feature Setup' and then enter information, and then click 'Save Setup', the admin screen refreshes to the Whitehouse Pro > Theme Options and does not save the settings. Previously, when I tried to save my feature setup settings, I received this error: " Not Acceptable An appropriate representation of the requested resource /wp-admin/admin-post.php could not be found on this server. Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request. " After researching solutions to this, I created an .htaccess file within my main public_html folder and added the following code: # BEGIN WordPress

<IfModule mod_rewrite.c>
	RewriteEngine On
	RewriteBase /
	RewriteRule ^index.php$ - [L]
	RewriteCond %{REQUEST_FILENAME} !-f
	RewriteCond %{REQUEST_FILENAME} !-d
	RewriteRule . /index.php [L]
	</IfModule>
	
	# END WordPress

And now I am getting the refresh to the Theme Options page and the settings are not saving. Any idea why this might be happening and how I can fix it? I'm using Wordpress 3.01 Thanks

Share this post


Link to post
Share on other sites
bryan-hadaway

I see you're using the latest WordPress version, but are you using the latest theme version? Thanks, Bryan

Share this post


Link to post
Share on other sites
adpearance

I believe so? Is there a simple way to find out what version of the theme I'm using?

Share this post


Link to post
Share on other sites
adpearance

Okay, so now I'm using wordpress version 3.0. I'm transferring this over from a testing site, where it is working fine. I transfered over the same exact files: everything in the public html folder. So, the same theme files and same version of wordpress that is working in one place is not working in another place and I need to know why. Please help, this is a very frustrating issue that I have been struggling with for over 8 hours. When I do the apache mod rewrite, the error disappears, but the settings still will not save. When I delete all of my .htaccess files, the original error returns showing this: " Not Acceptable An appropriate representation of the requested resource /wp-admin/admin-post.php could not be found on this server. Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request. Apache Server at ilikemiketv.com Port 80 " Thanks for your help.

Share this post


Link to post
Share on other sites
cmunns

Miranda, sorry for the issues. It sounds like the testing/live environment are different. Can you check with your hosting provider for error log messages and make sure that they support WP3.0 since all hosts are not yet caught up to speed. If it works in the local environment, it is unrelated to the theme but we'll offer as much help as possible.

Share this post


Link to post
Share on other sites
adpearance

Hello - we host the site using host9. I checked the error log messages. Here is the one that keeps occurring: [Tue Aug 03 17:13:14 2010] [error] [client 173.164.72.169] File does not exist: /home/likemike/public_html/406.shtml, referer: http://ilikemiketv.com/wp-admin/admin.php?page=pagelines_feature Its true that a 4-6.shtml file does not exist, but neither does it exist in the hosting environment. Both environments are on host9 by the way so there should be no difference there. They both support WP3.0. I understand that I'm probably your nightmare ticket, but I'm really at a loss on this issue. Is there any other info I can give you that would help?

Share this post


Link to post
Share on other sites
bryan-hadaway

Well, first let's check and make sure you're using the latest version of the theme, also there is a new version of WordPress now too. To check your theme version go to: Appearance > Themes then log into LaunchPad to see if there is a newer version. If you need help upgrading, see here: http://www.pagelines.com/forum/topic.php?id=2284 Thanks, Bryan

Share this post


Link to post
Share on other sites
adpearance

Ah it turned out to be an Apache issue with my host. Mod Rewrite. Thanks!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×