Jump to content
ratputin

Add Title to Carousel

Recommended Posts

ratputin+    2
ratputin
Thanks for the input Simon. I have tried it with the code you provided and still no result. However, the client wants to launch the site late this week/early next so I am going to table this until then. Afterwards, the site will be accesible and maybe something will become evident.

Thanks all for the help. I'll be back after the launch.

Rat

Share this post


Link to post
Share on other sites
Rob    547
Rob
Thanks for keeping us posted.

Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
quinntinm    4
quinntinm

Hi there.

I tried adding this as per the post by batman to add a title, but it broke the site. Any ideas?

 

add_action('pagelines_inside_top_carousel','add_carousel_title');
function add_carousel_title() {?>
YOUR TITLE HERE
<?php
}

Share this post


Link to post
Share on other sites
Rob    547
Rob

Hi, there may be some errors in that code, due to coversion to ascii

 

Try

add_action('pagelines_inside_top_carousel','add_carousel_title');
function add_carousel_title() {?>
YOUR TITLE HERE
<?php
}

Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
quinntinm    4
quinntinm

BRILLIANT!!

thank you.

Share this post


Link to post
Share on other sites
ratputin+    2
ratputin
add_action('pagelines_inside_top_carousel','add_carousel_title');
function add_carousel_title() {?>
YOUR TITLE HERE
<?php
}

 

 

Rob,

I saw this pop up today and decided to take another crack at it, too. Here's what I have "almost" working:

 

 

add_action('pagelines_inside_top_carousel','add_carousel_title');
function add_carousel_title() {
printf( '<p class="cat-see-more">SEE MORE IN</p>' . the_category( ) );
}

The reason I say "almost" is that the "SEE MORE IN" verbiage shoots to the right of the category name. It seems to be a result of the ul float:left that applies to section#carousel .content ul li and I cannot remove it as it is the same class as the images in the carousel. Is there a way to attribute a class to "the_category" in the code above? If so, I could give it a little CSS love. OR is there another way to add the "SEE MORE" text so that is would appear to the left of the_category? FYI, I even used :before { content:"See More In" } but was stonewalled when it applied to the images in the carousel.

 

TIA

Rat

Share this post


Link to post
Share on other sites
James B    436
James B

Hi there, looking at the code above there is a class for the p tag, cat-see-more. You should be able to use that for your css.


Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites
ratputin+    2
ratputin

Hi there, looking at the code above there is a class for the p tag, cat-see-more. You should be able to use that for your css.

 

Hi James!
I added it, and do use it for the "See More" verbiage, but it does not wrap "the_category". "the_category" is wrapped with "section#carousel .content ul li a". section#carousel .content ul li a is also used for the images in the carousel so I cannot add a :before to the class without it showing above the images in the carousel as well. Any idea how to get another class on "the_category"?

 

Rat

Share this post


Link to post
Share on other sites
ratputin+    2
ratputin

I have implemented an ugly work around...but it works in IE8-10, FF, Chrome & Safari as well on an iPad. In the end, I have done the following...

 

Add this code to plugins > page lines-customize > functions.php

add_action('pagelines_inside_top_carousel','add_carousel_title');
function add_carousel_title() {
printf( '<p class="cat-see-more">&nbsp;</p>' . the_category( ) );
}

*note: the p class was needed in order to have the carousel position properly under the new title.

 

Add this CSS to the Child Theme Stylesheet:

#carousel .content ul li a span.list-title { 
line-height:10px;
/* The following was added because alpha background was acting wonky in IE8 */
height:115px;
padding-top:50px; 
bottom:-75px;
background-image: url(/wp-content/uploads/2013/07/pixel_000-75pct.png);
background-color:transparent;
 }

#carousel .content ul li a:before { content:"See more in "; } /* Adds verbiage before the_category */

.section-carousel .content ul li a img { margin-top:-25px; } /* hides the verbiage that shows up above the carousel pictures */

.cat-see-more { margin-bottom: 20px; line-height:35px; } /* Added this for some position love */

This isn't the most elegant solution, but it does the job until a better one comes along. Thanks to all who helped along the way.

 

~Rat

 

Share this post


Link to post
Share on other sites
Rob    547
Rob

You're very welcome.


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Similar Content

    • oseehys
      By oseehys+
      The Grams section of Platform 5, is lacking lots of important features, that DMS multigram was having, there is no space for another user ID asie the default user, that was one of the strongest point of multigrams, because the Hashtag option cannot capture everyone, multiple User ID is the default standard for Instagram,  Also there is no carousel or slide on this one, it means now that if you want to display 18 pictures in one page all will be visible at once thats not good engineering.
      My appeal to the Pagelines Team, guys please let the next update have all the DMS Multigrams features that is missing on Platform 5 Grams, that will bring it to its glory...
       
       
    • Claudio
      By Claudio+
      I have a problem with the typography settings. I set the H1 class with "font-weight: 300;" (Very thin weight), and "font-size: 50px;" (To have considerable evidence of my problem). Unfortunately, as you can see on the screenshots, those setting don't have any incidence on the site, Infact in the home page editor there is a trial title called "Text test", bold, and 26 px approximatly sized.
      Why the typography settings are not transposed on the site? Where I wrong?


    • onlinedesigns4u
      By onlinedesigns4u+
      Hi Guys, 
       
      I noticed this a while back but thought it happened back when there was security issues with the wordpress plugin revolution slider and thats why they disappeared, but thinking i was wrong now as mine are the DMS versions.
       
      Basically, my front end editor is missing the icons for;
       
      • Rev Slider
      • Revolution Slider
      • Quick Slider
       

       
       
      What i've also noticed is a difference in how the menu tabs on the left hand side of the front end editor have changed. They were not styled like this before. Its like the css is off or something isnt quite right with the install somehow, somewhere.
       
      Even though the icons are missing for the slider sections. I can still drag them onto my pages and configure them, to a certain degree anyway.
       
      I tried adding the revolution slider to a page yesterday. But it wasnt responding to the way i had configured it. I choose a slide set for it to use and it took no notice. It just used every slide and every caption regardless.
       
      Leaving the revolution slider behind i took a look at the rev slider. Adding the correct images is fine. But i don't get any captions showing when i set them? Tried a few different options but nothing.
       
      Id like to know if my pagelines DMS 2 install is corrupt in anyway? Does anyone else's front end editor look the same as mine? Is anyone else missing the icons for the sliders and have no padding-right for the menu items?
       
      Is anyone using any of the sliders at the moment without issues?
       
      Im using the child theme 'Sophistique" which uses the revolution slider on the homepage. It works fine and its configured the way i want it using thh slide sets ive choosen so dont understand why it would be working inside the website.
       
      Any advice or help is appreciated. Thank for your time guys. Ben
       
       
       
    • dgsarnow
      By dgsarnow+
      I have DMS2 installed and my site is being served over HTTPS. However, I am getting an error that a placeholder image for Quick Carousel (which is not a being used on any of my pages) is being served over http://
       
      Mixed Content: The page at 'https://harqen.com/'was loaded over HTTPS, but requested an insecure image 'http://placehold.it/45x45/f0f0f0/ccc'. This content should also be served over HTTPS.
       
      How can I remove this?
       
      Found it. It was the Recent Posts Widget that was calling this little devil. I have removed the reference and all is well in SSL land.
    • dgsarnow
      By dgsarnow+
      I just updated to the new theme and I am now getting errors on my HTTPS site that the quick carousel is trying to deliver content through HTTP.
       
      Mixed Content: The page at 'https://harqen.com/'was loaded over HTTPS, but requested an insecure script 'http://harqen.com/wp-content/themes/dms/sections/quickcarousel/caroufredsel.js?ver=98ab90'. This request has been blocked; the content must be served over HTTPS.
       
      Can you please help me correct this issue?
       
       
×