Jump to content
linkinp

Custom Posts with Custom Taxonomy Permalink gives 404

Recommended Posts

linkinp    4
linkinp

I have a custom post + custom taxonomy.

The generated url for this post is

www.my-website.com/custom_post/custom_taxonomy/post/

Till yesterday :

www.my-website.com/custom_post/custom_taxonomy/ gave me a list of custom posts and when I clicked one of the posts it would display the post in the url www.my-website.com/custom_post/custom_taxonomy/post/

But today

www.my-website.com/custom_post/custom_taxonomy/ gives me list of custom posts, but I CANNOT ACCESS ANY OF MY CUSTOM POSTS.

PLease help.

Share this post


Link to post
Share on other sites
Simon    247
Simon

Well what did you change overnight? I can assure you we didnt change anything ;)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Similar Content

    • kri8it
      By kri8it
      Hi,
      I seem to be having a problem with my pages being detected as 'type' -> 'blog' when I use a custom permalink structure ( /%category%/%postname%/ ).
      However, when I switch to the default wordpress permalink structure, the pages work fine and show up as 'type' -> 'page'.
      I've used DMS on a lot of sites and this is the first time I've experienced this. I have deactivated all plugins, removed all custom code and the problem still persists. 
      Any help would be amazing...
    • sethoof
      By sethoof
      I am trying to get the featured image that shows in posts to display above rather than below the post title.  I have looked into other forum posts, but can't see, to find anything that clearly states how to do this. Is there a quickfix for this?  Also, I would like to center the image rather than it being left justified. Thanks in advance for your help!
    • superhumains
      By superhumains
      hello,
       
      I'm a dms pro user but i can't post in the appropriate forum !!
       
      Whatever the article on which you click, it takes on the same article.    The URL that appears correct but not Article! So we can not see the good post.    I checked the HTACCESS. I revalidate permalinks settings.    But I still have the same problem:    www.superhumains.com
    • jakenielson
      By jakenielson
      Hi,
       
      I'm having an issue that may have to do with permalinks but I'm not certain. Ever since I upgraded to the new DMS version, whenever I access certain pages on my site when not logged into the site as an administrator, the correct URL shows in the address bar but the incorrect post content is shown on the page.
       
      However, when I'm logged in as an administrator and when the DMS pagelines editor is on, I always get the correct post with the correct URL.
       
      Below is my debug information:
      DMS Debug Info WordPress Version
      3.8.1
      WordPress Debug
      Disabled
      Multisite Enabled
      No
      Current Role
      Administrator
      Framework Path
      /home/content/p3nexnas03/34/2066234/html/wp-content/themes/dms
      Framework URI
      http://theinnovativemanager.com/wp-content/themes/dms
      Framework Version
      1.1.7
      PHP Version
      5.4
      PHP memory
      256
      Mysql version
      5.5.33-log
      PHP type
      Cgi-fcgi
      PHP User
      Posix functions are disabled on this host!
      OS
      Linux
      Licence OK
      Jakenielson@gmail.com
      Installed Plugins
      advanced-iframe/advanced-iframe.php
      aweber-web-form-widget/aweber.php
      custom-sidebars/customsidebars.php
      dms-plugin-pro/dms-plugin-pro.php
      download-manager/download-manager.php
      feedburner-plugin/fdfeedburner.php
      hybridconnect/hybridconnect.php
      jetpack/jetpack.php
      jquery-smooth-scroll/jquery-smooth-scroll.php
      leadpages/leadpages.php
      outbrain/outbrain.php
      pagelines-sections/pagelines-sections.php
      social-sharing-toolkit/social_sharing_toolkit.php
      tinymce-advanced/tinymce-advanced.php
      ubermenu-megamenu-adapter/ubermenu-megamenu-adapter.php
      ubermenu/ubermenu.php
      updraftplus/updraftplus.php
      wordpress-seo/wp-seo.php
      youtube-embed-plus/youtube.php
    • gogeiger
      By gogeiger
      Hi,
       
      I originally had problem
       
      My site http://www.elitehvaccontractors.com/ not having a main blog page for blog ,
       
      I changed my permalink
       
      To custom /blog/%postname%/ and now I have a blog page http://www.elitehvaccontractors.com/blog/
       
      New problem developed
       
      My location page went from http://www.elitehvaccontractors.com/locations/hvac-contractors-collegeville-pa/
      To the following: http://www.elitehvaccontractors.com/blog/locations/hvac-contractors-collegeville-pa/
       
       
      I need help with the following:
      Keeping Blog main page for web site Change locations back to original and not have it follow blog file Goal:
      http://www.elitehvaccontractors.com/blog/
      http://www.elitehvaccontractors.com/Locations/
       
      NOTE:
      I use plug in Yoast WordPress SEO: Local SEO have contacted them and they say plug in is working and resulting because I put blog in custom permalink. They could not support any further advice.
      If I take blog out then my main blog page disappears.
        
       
      Thank you in advance for a solution,
      Tim Geiger
       
       
×