Jump to content
Sign in to follow this  
TMC

Problem with navigation

Recommended Posts

TMC

I have added new items to my primary navigation from categories (not pages). Now, I have two different box colors, one when I click on pages, and, a different one when I click on categories--as part of the navigation menu, please help. Following is the URL, http://themedcircle.com/

Share this post


Link to post
Share on other sites
Rob

When I hover over the parent items of your menu (pages or categories) I see only one color. The one item with a drop down item changes the background color of the child menu item. is it this to which you refer?


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
TMC

When you click on patient, clinician and contact the box color changes to orange but if you click on news and research update (which are categories and not pages), the box color remains white.

Share this post


Link to post
Share on other sites
Danny

Hi,

Do you have any plugin or have you added any code, as you have tracking javascript on all your menu items.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
TMC

  1. No, I don't have any specific plugin for the navigation. I am using pageline's platform pro.

Share this post


Link to post
Share on other sites
Rob

Go to Dashboard > PlatformPro > Design Control and look for Primary Site Element Colors.

The first item on the list in that grouping is "Box Color - Primary Elements"

That should be set to the color you desire. My own installation shows that if I change it to an orange, I get the same effect you're seeing.

Save the settings once you change it and see if it works.


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
TMC

I have done that already, it works only for pages not for categories or custom links (added to navigation).. If you check it on my site you wil see that by clicking for example, patients (a page), the color changes to orange but by clicking news (which is a category) nothing happens.

Share this post


Link to post
Share on other sites
Danny

Hi,

Try adding this to your custom CSS.


.main-nav li.current-menu-item {
background: #EB9770;
}
[/CODE]

  • Like 1

Please search our forums, before posting!

Share this post


Link to post
Share on other sites
Simon

The topic was marked as resolved.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Similar Content

    • gregory.guz
      By gregory.guz+
      Hi ,
      I just noticed that the color picker has stopped showing up on my PL5 site ( please see attached image ) 
      Any idea what could be causing the problem?
       
      Thanks 
      Greg

    • greatthingsllc
      By greatthingsllc+
      In Platform 5, Using Framework Section for Content , I have set the hyperlink colors in the CUSTOMIZE section.   However, none of the pages are properly displaying the link colors.   Just defaulting to black, and underline on hover.   I did not see where this would be controlled at the page level or lower
      Site    doritbrauer.com
      Thanks
      Josh

    • JP
      By JP+
      Hello,
      We are working on a 2 languages site (https://liguecardioliga.be) with wpml, and lately the call of a category in the loops section (and all the sections requiring a category to select posts) doesn't work in the translated language. It worked well until recently so I wonder if it's because of a recent update (wordpress, wpml, pagelines, a plugin?). Anyone has the same problem? a solution?
      TIA
    • bnapoli
      By bnapoli+
      http://731.34b.myftpupload.com/ this website is using the NavPro navigation in Platform 5. It has a lot of menu items, so it breaks to two lines when the window is sized down. What is the media query to make the navigation either a) switch to "mobile mode" at a higher width, or b ) expand the nav into two lines. Thanks
    • nadielp
      By nadielp+
      Hi Everyone,
      I am trying to get a single navigation item to center. I am using a scroll menu in the navigation component of Impulse. I would like to have the item in the center of the page but it defaults right. I tried setting the item to center a few different ways and nothing is working. I added {
        display: inline-block;
        position: relative;
        text-align: center;
      }
      but that didn't work...any help would be appreciated. Site is at http://vetpaw.org/new
       
      Thanks!
      Daniel
×