Jump to content
theoptimystic

Navigation bar click instead of hover

Recommended Posts

theoptimystic    0
theoptimystic

Hi there,

I want my primary navigation bar (the tabs on the top of my site) to show the dropdown menus when I click on it, NOT when I hover over it. How can I change this?

THanks,

Lu

Share this post


Link to post
Share on other sites
batman    389
batman

Hi theoptimystic

I read at forum...

"Unfortunately, the NavBar not supporting the dropdown menus when "click". The Navbar section is based on Twitters Bootstraps navigation and they have designed their navigation this way.

If you wish to have this type of functionality, you can either contact one of our Pros or use the Nav Classic menu section instead."


Life is too short to remove USB safely ...

Share this post


Link to post
Share on other sites
Rob    547
Rob

The issue stems from Twitter Bootstrap in the NavBar which requires click to drop down the menu. You can go to Dashboard > PageLines > Drag & Drop > Header and replace NavBar with Nav Classic (found in Available Sections).

I know the Nav Classic doesn't have the same look and feel of NavBar, but this can be achieved with styling.


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
theoptimystic    0
theoptimystic

Thanks...it looks like I am already using Nav Classic, so how would I enable it to click and drop? Because it is still hovering.

Share this post


Link to post
Share on other sites
Rob    547
Rob

Okay. Sorry for my confusion. You're asking just the opposite of what everyone else asks lately. :)

Go to Dashboard > PageLines > Drag & Drop and click the box that says "Header".

You'll see under "Active Sections" a button for Nav Classic. Move it to the right. Now, drag NavBar from the right under "Available Sections" to the left so it's now under "Active Sections".

However, NavBar's parent links don't link, so you'll need to add a new parent menu item for each, moving the current one down. NavBar also does not allow grandchild menu items.

So you'll need to have the parent with no link and the child menu items only.

Use Dashboard > PageLines > Site Options > NavBar to select colors, etc.


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×