Jump to content
lovealbatross74

A Thursday morning Noob...

Recommended Posts

lovealbatross74

Hi everybody,

Sorry for the noobness but I've just decided to upgrade from the Platform theme to the full pagelines framework so that I can do all the fancy stuff that pagelines allows you to do (features, more typefaces, etc).

So I had my site setup here: http://www.traphicmarketing.co.uk and it's all working just fine, a few plugins for a contact form and some social/seo stuff. It hasn't moved far from the original theme, very simple stuff.

So bought the framework, downloaded, installed and activated (having read the wiki entry on moving from platform to pagelines) and ended up with a bit of a mess. Looks like all the data has been retained but there seems to be no styling. Even when I play around with site settings, menus, templates, the menus look awful, there's no layout regardless of what layout option I choose, etc. Obviously it's me at fault but I'm not sure where to start. Any ideas? I've attached an image of what it looks like when I activate Pagelines.

Thanks in advance of any help you can give me!

Cheers

James

post-41616-0-35739600-1347525590_thumb.p

Share this post


Link to post
Share on other sites
Danny

Hi James,

Would it be possible for you to enable PageLines Framework again and also add this line of code to your wp-config.php file please and see if this resolves your issue.


define('WP_DEBUG', false);
[/CODE]


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
lovealbatross74

Thanks for looking Danny, I've done that and it's not made a difference I'm afraid. Although I did just paste the line at the end of the wpconfig file - is that the right place?

Theme is currently active on traphicmarketing.co.uk if you want to see it live.

Cheers

Share this post


Link to post
Share on other sites
Danny

Hi James,

Are you currently experiencing issues with your site, as when I go to visit. All I get is a white screen ?


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
lovealbatross74

No, I can see the site OK, only it still looks like the image I sent you. I'm going to revert back to the old theme for a bit until we resolve.

Share this post


Link to post
Share on other sites
Danny

Hi,

OK there doesn't appear to be a Memory Limit issue. However, I noticed that you have index.php/ in your link structure, this may well be the cause of the error when you enable PageLines Framework.

Can you go to your Wordpress Admin Dashboard > Settings > Permalink and change it to PostName please. Then enable PageLines Framework and see if this resolves your issue.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
lovealbatross74

Thanks Danny, but still no. At a loss here!

Share this post


Link to post
Share on other sites
Simon

I'd suggest to start with disabling permalinks by setting them to default.

Share this post


Link to post
Share on other sites
lovealbatross74

Thanks Simon, but that results in links just not working at all - just showing a white page so changed it back to post name. Besides, that would change indexed urls and I don't want to do that.

Basically I've set up a site I'm happy with in Platform and just wanted to upgrade to some extra features to improve it. But what I'm seeing when I switch themes in so kind of starting point that I can fathom. I realise I may have to rejigg some stuff, but why isn't it displaying at the right size and there are no styles to anything (menus etc)?

Share this post


Link to post
Share on other sites
Simon

Well Sorry, I cant look at it and help you if you dont leave things set for more than 10s ;)

See I was thinking it was something with your webserver being Zeus.

Share this post


Link to post
Share on other sites
lovealbatross74

Sorry Simon, just trying to balance this issue with it not looking like a bag of spanners to clients all day! I'll change it back now - appreciate your time.

Share this post


Link to post
Share on other sites
Simon

And set permalinks to default, and click save.

Share this post


Link to post
Share on other sites
Simon

Right, I know whats happening.

We set a mime type of text/css to the dynamic css generated, but zeus is ignoring that and setting a mime type text/html.

So browsers are ignoring the css as it has the wrong mimetype.

So first of all try this:

In wp-config.php add this ABOVE the WP_DEBUG line


define( 'LESS_FILE_MODE', true );
[/CODE]

If that does not work you will have to contact your host to fix the mimetype

Timestamp: 13/09/2012 13:52:12

Error: The stylesheet http://www.traphicmarketing.co.uk/?pageless=1'>http://www.traphicmarketing.co.uk/?pageless=1 was not loaded because its MIME type, "text/html", is not "text/css".

Source File: http://www.traphicmarketing.co.uk/

Line: 0

  • Like 1

Share this post


Link to post
Share on other sites
lovealbatross74

BINGO!

Great stuff Simon - thank you very much.

J

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×