Jump to content
Sign in to follow this  
andrewkkirk

Navigation Menu Buttons not working

Recommended Posts

andrewkkirk    0
andrewkkirk

http://www.andrewkkirk.com/

Recently launched site with latest version of PageLines Pro. I've created several pages. However, in the main navigation, the links for all pages point directly to the home page.

I'm able to access these pages by inputing the exact URL directly, just not from the menu buttons.

No plugins are activated.

Share this post


Link to post
Share on other sites
Danny    1,327
Danny

Hi Andrew,

Basically you have made some significant changes to both the Branding and Navigation. I noticed you have this CSS:


.section-navbar {
z-index: 2020;
margin: 0 auto;
width: 100%;
}
[/CODE] z-index only works when used with position:absolute/relative. Therefore, replace your code with the follow and your navigation links will then work correctly.
[CODE]
.section-navbar {
z-index: 2020;
margin: 0 auto;
width: 100%;
position: relative;
}

However, why didn't you use the BrandNav section, the BrandNav has your logo and navigation aligned with one another.

  • Like 1

Please search our forums, before posting!

Share this post


Link to post
Share on other sites
andrewkkirk    0
andrewkkirk

Danny,

Removed the extra CSS and the menu links are working. Also, I switched to BrandNav section, which was I not previously aware of. It is much better than my work-around trying to move the two sections side-by-side.

You solved my error and provided by a better solution, thanks!

Share this post


Link to post
Share on other sites
Danny    1,327
Danny

Hi Andrew,

No problem, was more than happy to help!


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
Danny    1,327
Danny

The topic was marked as resolved.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Similar Content

    • khat
      By khat+
      I think I may have installed pagelines pro incorrectly, and then used features incorrectly. I installed first platforms framework theme and then the child, thinking I could do setup for child later. I tried to set up a background image, and tried custom css feature in pagelines dashboard. I had mistakes in my css, and just thought that if I deleted the info in the css custom feature in pagelines dashboard that the new information would overwrite the old info. The background image didn't respond at all, probably because I didn't have the child directory renamed. I then tried to use the LSS plugin to create css and added more css, possibly, somewhere -sigh-. I never did change the background image and get it placed properly. I used a workaround and in nested containers I placed a background image which worked well enough, so I moved on to try to create my nav bar/ menu bar. When I go to the Menus panel, there is NO area where I can place a menu on a page. I have read and reread and re- re- reread the instructions for placing a menu. I've used the pagelines editor to place a menu, however only HOME shows up. I've been at this for many hours. I've since uninstalled all of my pagelines items and reinstalled, thinking that it would restore all my changes to default, but no, it is still all there, with all my unresolved issues. I am completely at a loss as to what to do next.
    • bnapoli
      By bnapoli+
      http://731.34b.myftpupload.com/ this website is using the NavPro navigation in Platform 5. It has a lot of menu items, so it breaks to two lines when the window is sized down. What is the media query to make the navigation either a) switch to "mobile mode" at a higher width, or b ) expand the nav into two lines. Thanks
    • Jarek
      By Jarek+
      How to make the Impulse menu sticky?
      Here is a site that seems like it is doing just that: http://www.manhattanperiodontist.com/
      Here is the site I am working on: http://boeriu.digitalvector.com/ 
      I have no problem showing the menu at the bottom, but when scrolling up it does not stick.  I tried to add Nav Pro menu but when I do that, it just shows on top and no matter what I try is not working as I want it to.
      Any suggestions?
    • Dave
      By Dave+
      1) Toggle menu on mobile devices does not work properly, combination Chrome 56.0.2924.87 with Android 6.0.1

      2) Mobile / Default Menu > Set the primary/default navigation for your site. This will be used in the pop out mobile menu and as the default in navigation sections. Does not work.
×