Jump to content
Sign in to follow this  
dawsonbarber

Oswald G font getting cut in half when set as header

Recommended Posts

dawsonbarber

I've got the full Google font library installed and activated and am having problems with the font I want to use for headers. When selected as the header font, Oswald does not display properly. It appears to be cut in half (horizontally) - both in the preview in the Typography section and on the site itself. It's fine when selected as Primary Font - not what I want - but not as header font. Any ideas?

Share this post


Link to post
Share on other sites
Rob

Your site is in Maintenance Mode, but my guess is that the line-height where the font is cut in half is insufficient to accommodate that font in full height, in that font-size. Use Firebug to find the element, check the existing CSS and make sure the line height is a few pixels greater than the font size in pixels.


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
dawsonbarber

I played around with line-height, font-size, padding, and basically every other property I could think of and the problem remains. And it also appears cut in half in the preview window inside the Typography section of PageLines Site Options, which makes no sense to me whatsoever. I've taken a look on another installation (local) and it's the same thing. All other fonts appear to be okay (those that I played around with), regardless of line-height and other property values. Have you taken a look at an actual installation to see if you can see the same thing?

Share this post


Link to post
Share on other sites
Rob

I have an installation with Oswald font http://www.epicurus.com and none of them are cut.


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
dawsonbarber

I took another look at the Typography settings - specifically, under Edit Font Settings. I played around with some of the values and ended up changing the font-weight from what appeared to be the default for Oswald - bold - and set it to normal. That did the trick. I changed it again to Light, just to see what would happen, and, once again, Oswald gets cut in half. I used Firefox to apply bold and light to Oswald on your site, and it didn't cause any problems. Anyway, I think Oswald looks better when set to a normal weight, so I guess I'm all sorted. Cheers

Share this post


Link to post
Share on other sites
Rob

Glad to hear that!


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×