Jump to content
Sign in to follow this  
kellid

Error when installing new framwork

Recommended Posts

kellid

Hi, I've upgraded with Framework 2.2 and I got an error when I uploaded to my dev site. Thank goodess it's the dev site!! This is the error.. Warning: Invalid argument supplied for foreach() in /home/devmodel/public_html/wp-content/themes/pagelines/includes/less.plugin.php on line 1902 Warning: Invalid argument supplied for foreach() in /home/devmodel/public_html/wp-content/themes/pagelines/includes/less.plugin.php on line 1911 Any ideas?! Thanks!

Share this post


Link to post
Share on other sites
kellid

I've activated the theme... PageLines Custom LESS/CSS error. parse error: failed at ` border-right: 1px solid #D9D9D9; ` line: 1050

Share this post


Link to post
Share on other sites
Rob

Kelli I used the CSS validator and found you have 15 errors. Copy your custom CSS, then go to http://jigsaw.w3.org/css-validator/validator and click the tab for Direct Input. Paste your code there. It will tell you which lines are in error. You can affix your changes from there. Meanwhile, regarding the first bit, I've written to the developers and asked them what caused the errors. I hope to hear back soon.


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
kellid

Wow, thanks so much Rangelone!! Let me know...much appreciated!!

Share this post


Link to post
Share on other sites
Danny

HI Kellid, As Rob mentioned above, you have errors in your CSS. PageLines Framework 2.2+ using LESS CSS, which is not as forgiving as standard CSS. Regarding the errors you have, can you follow the instructions in the post below and see if that resolves your issue. http://www.pagelines.com/forum/discussion/20011/problems-with-wp-3.4-and-the-store#Item_1


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
kellid

That worked!! You've put me onto a great new tool, thanks Rob!!! and Thank you, Danny. :)

Share this post


Link to post
Share on other sites
Rob

Kelli, as always, a pleasure! Please accept an answer to resolve this topic. Hope your weekend's going well.


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
Rob

Kelli, the Dev's said you might have some files missing and recommend re-installing PageLines Framework. If you do this, don't reinstall the plugins, just the framework. Go to your launchpad account via https://www.pagelines.com/launchpad/ and please download Framework to your local machine. Unzip the file and you'll find a folder "pagelines" (without quotes). FTP into your site and upload that folder to wp-content/themes. When it asks if you want to overwrite existing files, say Yes. This will not impact any custom CSS found in Dashboard > PageLines > Site Options > Custom Code, nor any settings. However, to make sure, back everything up beforehand.


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
kellid

Ok, will do. Thanks a lot. But can I ask why? Is it because of the CSS problem or my Loop issue? .....so many issues :(

Share this post


Link to post
Share on other sites
Rob

It could simply be a file that did not completely install or install correctly. That could also be affecting your other issues. So, since it can't do any harm, it's not a bad idea to do the reinstall. At least we'll know whether that's the problem.


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×