Jump to content
Sign in to follow this  
tfhowley

How do I embed a tweet in Framework 2.2.5?

Recommended Posts

tfhowley

Wordpress 4.3.1 says "You can now embed individual tweets in posts. It includes action links that allow readers to reply to, retweet, and favorite the tweet without leaving your site. Just paste a tweet URL on its own line." I cant seem to get this to work in Framework version 2.2.5. I've tried using the URL and/or the embed link from twitter, and nothing seems to work.

Share this post


Link to post
Share on other sites
catrina

Where are you trying to get this to work? According to documentation, this works only in posts and pages.


Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites
tfhowley

I'm trying to get it to work on posts to show up on the main blog page.

Share this post


Link to post
Share on other sites
tmeister

@tfhowley Just make sure that the URL is not hyperlinked and on its own line, in others words use the HTML tab instead of the Visual when you paste the URL. Regards!!


Enrique Chavez - Premium DMS Themes, Sections and Plugins.

http://enriquechavez.co

Share this post


Link to post
Share on other sites
tfhowley

I tried using the HTML tab to paste it and it still didn't work ... Have to go to work now and wont be able to respond till late tonight. Thanks.

Share this post


Link to post
Share on other sites
catrina

tfhowley, when you can, try activating another theme (TwentyEleven or TwentyTen) and try embedding that Twitter URL in a post to see if it works. That way, we know if it's WP-related or PageLines-related.


Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites
tfhowley

I appears to be Pagelines-related. I activated TwentyEleven and pasted the URL using the HTML tab (thanks Tmeister) and it a worked. When I reactivated PageLines Framework, the tweets maintained their formatting but embedding a new tweet URL didn't work.

Share this post


Link to post
Share on other sites
Danny

HI, There is no issue here, I have embedded several tweets to a post/page. All you need to do is click on the HTML tab of your content editor and add the tweets URL. Once you have added the URL, simply hit return/enter on your keyboard to add a line break and then save your post/page.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
tfhowley

I'm not sure what I'm doing wrong but it still does not work on my site. I clicked on the HTML tab on the Ad New Post page and added the tweet's URL. I hit return/enter on your keyboard to add a line break. Next I saved the draft and then clicked publish. I doesn't for format correctly on the post or blog page.

Share this post


Link to post
Share on other sites
tfhowley

I tried but still no luck. Next I restored all defaults and tried again...on the post pages it is formatted correctly but not on the blog page? I guess I'm getting closer.

Share this post


Link to post
Share on other sites
tfhowley

Danny, Thanks for the video! However it still doesn't work on my site. I followed the directions and it doesn't work on the posts or pages. If you can look at my site maybe you can see what I'm doing wrong. www.howleypost.com

Share this post


Link to post
Share on other sites
catrina

I inspected your site. Are you adding your code to the post excerpt area or the post editor area? Also, can you please try disable excerpts and enabling full post content on the blog/posts page?


Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites
tfhowley

Thank you Catrina! It's working now. I have been using the post editor not the post excerpt area. I disabled excerpts and enabled full post content on the blog/posts page and it now formats the tweets correctly. After playing around with it a bit, I think it's the excerpts that are causing the problem.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×